<!doctype html>
<html lang="en" style="display:block;min-width:1040px;">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="xqz76zmvfde7oisbofkg13kwkw4b67yf6bzn770iq7vzpcpjszundefy599v43fjk2m6zn9al-vxetd12no8tukobbk8y22lna705yov843ltiolagx5f7wj389vu-6c" />
<meta name="viewport" content="width=1040">
	
<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location};
var qva = '539382';var fan = '3739';var jwa = '116261';var geq = '-bup-ac';</script>

<link rel="stylesheet" type="text/css" href="https://www.com-unik.info/wp-content/themes/alambre-com-unik/style.css?v=12" media="screen" />
<link href="https://www.com-unik.info/feed" rel="alternate" title="Community Financial News RSS Feed" type="application/rss+xml" />
<link href="https://www.com-unik.info/feed/atom" rel="alternate" title="Community Financial News Atom Feed" type="application/atom+xml" />
<link href="https://www.com-unik.info/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css&#038;ver=1579791688' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://www.com-unik.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.com-unik.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.com-unik.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Kulicke and Soffa Industries (NASDAQ:KLIC) Posts Quarterly  Earnings Results, Beats Estimates By $0.10 EPS' href='https://www.com-unik.info/2020/01/31/kulicke-and-soffa-industries-nasdaqklic-posts-quarterly-earnings-results-beats-estimates-by-0-10-eps.html' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html" />
<link rel='shortlink' href='https://www.com-unik.info/?p=2703895' />
<link rel="alternate" type="application/json+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F01%2F31%2Fmix-telematics-nysemixt-releases-fy20-earnings-guidance.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F01%2F31%2Fmix-telematics-nysemixt-releases-fy20-earnings-guidance.html&#038;format=xml" />
<link rel="amphtml" href="https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html/amp" /><link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="32x32" />
<link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
<meta name="msapplication-TileImage" content="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
 
	
<!-- Start Meta Data -->

<title>MiX Telematics (NYSE:MIXT) Releases FY20 Earnings Guidance - Community Financial News</title>


<meta name="description" content="MiX Telematics (NYSE:MIXT) updated its FY20 earnings guidance on Thursday. The company provided EPS guidance of ZAR0.39-0.41 for the period, compared to the Thomson Reuters consensus EPS estimate of $0.42. The company issued revenue guidance of ZAR2.10-2.12 billion, compared to the consensus revenue estimate of $2.13 billion.MiX Telematics also updated its FY 2020 Pre-Market guidance [&hellip;]" />
<meta name="author" content="Cynthia Vaughn">
<meta name="news_keywords" content="MiX Telematics,NYSE:MIXT,MIXT,Computer and Technology,guidance,earnings,preannouncement" />
<meta name="keywords" content="MiX Telematics,NYSE:MIXT,MIXT,Computer and Technology,guidance,earnings,preannouncement" />
<meta name="ticker" content="NYSE:MIXT" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@CFinancialNews" />
<meta name="twitter:title" content="MiX Telematics (NYSE:MIXT) Releases FY20 Earnings Guidance"/>
<meta name="twitter:description" content="MiX Telematics (NYSE:MIXT) updated its FY20 earnings guidance on Thursday. The company provided EPS guidance of ZAR0.39-0.41 for the period, compared to the Thomson Reuters consensus EPS estimate of $0.42. The company issued revenue guidance of ZAR2.10-2.12 billion, compared to the consensus revenue estimate of $2.13 billion.MiX Telematics also updated its FY 2020 Pre-Market guidance [&hellip;]" />
<meta name="twitter:creator" content="@CFinancialNews" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/mix-telematics-ltd-logo.png" />

<!-- Open Graph Data -->
<meta property="og:title" content="MiX Telematics (NYSE:MIXT) Releases FY20 Earnings Guidance" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/mix-telematics-ltd-logo.png" />
<meta property="og:description" content="MiX Telematics (NYSE:MIXT) updated its FY20 earnings guidance on Thursday. The company provided EPS guidance of ZAR0.39-0.41 for the period, compared to the Thomson Reuters consensus EPS estimate of $0.42. The company issued revenue guidance of ZAR2.10-2.12 billion, compared to the consensus revenue estimate of $2.13 billion.MiX Telematics also updated its FY 2020 Pre-Market guidance [&hellip;]" />
<meta property="og:site_name" content="Community Financial News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-01-31T19:38:42+0000" />
<meta property="article:modified_time" content="2020-01-31T19:38:42+0000" />
<meta property="article:tag" content="NYSE:MIXT" />
<meta property="article:tag" content="MiX Telematics,NYSE:MIXT,MIXT,Computer and Technology,guidance,earnings,preannouncement" />
<meta property="article:section" content="Finance" />


<!-- End Meta Data -->

<script type='text/javascript'>var PopupAdChannel=''; </script>


 <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'com-unik.info';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e44ae816-df10-443c-9af6-8ac7ebff4880",
      safari_web_id: 'web.onesignal.auto.486fe890-0d3a-4b25-a01f-9ae2be714cd5',
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}
  </script>

<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
	
<!-- start ims header script -->
	<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13226773,
				sizes: [[300,250]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'Com_Unik_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
	
	<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	
<!-- end ims header script -->
	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
</head>

<body>


<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Community Financial News', 'com-unik.info', 'NYSE:MIXT', 'MiX Telematics', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/mix-telematics-ltd-logo.png');</script>
<!-- End MarketBeat Modern Popup -->
	


<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-nav" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>				<form id="searchform" action="https://www.com-unik.info/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding" style="height:110px"><!-- start: width-limiter with logo and space for alternate header unit -->
<div style="float:left;width:280px;">
		<a href="https://www.com-unik.info"><img id="logo" src="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png" alt="community financial news logo"></a>



</div>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" style='float:right;width:728px;height:90px;'>

<!-- Network Wide AdSense Unit - Header Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="5679141823" data-ad-format="horizontal" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

</div> 
<!-- End Header Unit-->

	</div> <!-- end: width-limiter with logo and space for alternate header unit -->



	<div id="menu">
		<div class="width-limiter">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-front-page-categories" class="menu"><li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li id="menu-item-107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter">
		<aside>

<div>
<!-- Begin Dianomi Unit -->
<iframe width="336" height="670" scrolling="NO" src="//www.dianomi.com/smartads.epl?id=3355" style="width: 336px; border: none; overflow: hidden;"></iframe>
<!-- End Dianomi Unit -->
</div>
	
<!-- first square unit -->
<div class="ad336x280">

<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

</div>
<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
<!-- end second square unit -->
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for MiX Telematics</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for MiX Telematics with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:MIXT" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<a href="https://twitter.com/CFinancialNews" class="twitter-follow-button" data-show-count="false">Follow @CFinancialNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FCommunity-Financial-News-1775168779380432&amp;width=336&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true&amp;appId=229098600454584" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:336px; height:250px;" allowTransparency="true"></iframe>






<!-- start IMS -->
	
<div id="Com_Unik_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('Com_Unik_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- end IMS -->



<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Top Stories</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html">MiX Telematics (NYSE:MIXT) Releases FY20 Earnings Guidance</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/kulicke-and-soffa-industries-nasdaqklic-posts-quarterly-earnings-results-beats-estimates-by-0-10-eps.html">Kulicke and Soffa Industries (NASDAQ:KLIC) Posts Quarterly  Earnings Results, Beats Estimates By $0.10 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/jpmorgan-chase-co-increases-quilter-lonqlt-price-target-to-gbx-195.html">JPMorgan Chase &#038; Co. Increases Quilter (LON:QLT) Price Target to GBX 195</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/relx-lonrel-pt-raised-to-gbx-2275.html">Relx (LON:REL) PT Raised to GBX 2,275</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/berenberg-bank-boosts-ultra-electronics-lonule-price-target-to-gbx-2300.html">Berenberg Bank Boosts Ultra Electronics (LON:ULE) Price Target to GBX 2,300</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/barclays-reiterates-overweight-rating-for-wh-smith-lonsmwh.html">Barclays Reiterates Overweight Rating for WH Smith (LON:SMWH)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/rocket-internet-frarket-given-a-23-00-price-target-by-barclays-analysts.html">Rocket Internet (FRA:RKET) Given a &euro;23.00 Price Target by Barclays Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/bancfirst-co-nasdaqbanf-receives-consensus-recommendation-of-hold-from-brokerages.html">BancFirst Co. (NASDAQ:BANF) Receives Consensus Recommendation of &#8220;Hold&#8221; from Brokerages</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/bank7-corp-nasdaqbsvn-given-average-recommendation-of-strong-buy-by-analysts.html">Bank7 Corp (NASDAQ:BSVN) Given Average Recommendation of &#8220;Strong Buy&#8221; by Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/servicenow-nysenow-price-target-increased-to-370-00-by-analysts-at-credit-suisse-group.html">ServiceNow (NYSE:NOW) Price Target Increased to $370.00 by Analysts at Credit Suisse Group</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/sanmina-nasdaqsanm-upgraded-to-strong-buy-at-zacks-investment-research.html">Sanmina (NASDAQ:SANM) Upgraded to &#8220;Strong-Buy&#8221; at Zacks Investment Research</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/mastercard-nysema-given-new-380-00-price-target-at-suntrust-banks.html">Mastercard (NYSE:MA) Given New $380.00 Price Target at SunTrust Banks</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/sprints-s-hold-rating-reiterated-at-royal-bank-of-canada.html">Sprint&#8217;s (S) Hold Rating Reiterated at Royal Bank of Canada</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/computer-modelling-group-tsecmg-stock-crosses-above-200-day-moving-average-of-7-22.html">Computer Modelling Group (TSE:CMG) Stock Crosses Above 200-Day Moving Average of $7.22</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/northwest-health-prop-real-est-inv-trust-tsenwh-un-stock-price-passes-above-two-hundred-day-moving-average-of-11-92.html">NorthWest Health Prop Real Est Inv Trust (TSE:NWH.UN) Stock Price Passes Above Two Hundred Day Moving Average of $11.92</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/wepower-price-up-4-3-over-last-7-days-wpr.html">WePower Price Up 4.3% Over Last 7 Days (WPR)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/topps-tiles-lontpt-stock-price-crosses-above-two-hundred-day-moving-average-of-70-18.html">Topps Tiles (LON:TPT) Stock Price Crosses Above Two Hundred Day Moving Average of $70.18</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/cwc-energy-services-cvecwc-share-price-crosses-below-200-day-moving-average-of-0-12.html">CWC Energy Services (CVE:CWC) Share Price Crosses Below 200 Day Moving Average of $0.12</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/immunodiagnostic-systems-lonidh-share-price-crosses-below-two-hundred-day-moving-average-of-238-98.html">Immunodiagnostic Systems (LON:IDH) Share Price Crosses Below Two Hundred Day Moving Average of $238.98</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/01/31/micro-imaging-technology-otcmktsmmtc-shares-cross-above-fifty-day-moving-average-of-0-16.html">Micro Imaging Technology (OTCMKTS:MMTC) Shares Cross Above Fifty Day Moving Average of $0.16</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->

		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html" />
				<h1 itemprop="headline" class="page-title">MiX Telematics (NYSE:MIXT) Releases FY20 Earnings Guidance</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author"><a href="https://www.com-unik.info/author/cynthia" title="Posts by Cynthia Vaughn" rel="author">Cynthia Vaughn</a></span> on <span itemprop="datePublished dateModified" content="2020-01-31T19:38:42+0000">Jan 31st, 2020</span>
				</p><!--end .postmeta-->
				
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/mix-telematics-ltd-logo.png" alt="MiX Telematics logo" title="MiX Telematics logo" class="companylogo" />MiX Telematics (NYSE:MIXT) updated its FY20 earnings guidance on Thursday. The company provided EPS guidance of ZAR0.39-0.41 for the period, compared to the Thomson Reuters consensus EPS estimate of $0.42. The company issued revenue guidance of ZAR2.10-2.12 billion, compared to the consensus revenue estimate of $2.13 billion.MiX Telematics also updated its FY 2020<br />
Pre-Market guidance to 0.67-0.71 EPS.</p>
<p>Several research firms have recently weighed in on MIXT. Canaccord Genuity  restated a buy rating and issued a $30.00 price target on shares of MiX Telematics in a research note on Thursday. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> upgraded MiX Telematics from a strong sell rating to a hold rating in a research note on Wednesday, January 1st. Finally, <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?ValuEngine=1&#038;Symbol=MIXT'>ValuEngine</a> upgraded MiX Telematics from a sell rating to a hold rating in a research note on Thursday, October 31st.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Community Financial News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:MIXT" />    <label for="InPostRegistrationEmail">Get <b>MiX Telematics</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>Shares of <a href='https://www.marketbeat.com/stocks/NYSE/MIXT/earnings/' target='_blank' rel="noopener noreferrer">MIXT stock</a> traded down $0.77 during mid-day trading on Friday, hitting $13.08. The company&#8217;s stock had a trading volume of 71,900 shares, compared to its average volume of 76,648. MiX Telematics has a 52-week low of $11.96 and a 52-week high of $20.07. The business has a 50-day moving average price of $13.48 and a 200 day moving average price of $13.57. The stock has a market cap of $296.48 million, a price-to-earnings ratio of 17.82, a PEG ratio of 0.78 and a beta of 0.77. </p>
<p>
		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;width:340px;">

			  <!-- Network Wide AdSense Unit - In-Post Position -->
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9254111670"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

                 </div>


                 MiX Telematics (NYSE:MIXT) last posted its quarterly earnings results on Thursday, October 31st. The technology company reported $0.19 earnings per share for the quarter, missing the Thomson Reuters&#8217; consensus estimate of $0.20 by ($0.01). MiX Telematics had a return on equity of 15.49% and a net margin of 11.80%. The business had revenue of $35.50 million during the quarter, compared to analysts&#8217; expectations of $37.45 million.  As a group, equities research analysts predict that  MiX Telematics will post 0.76 EPS for the current fiscal year. </p>
<p><strong>About MiX Telematics</strong></p>
<p>MiX Telematics Limited provides fleet and mobile asset management solutions through software-as-a-service delivery model. The company offers fleet solutions, including MiX Fleet Manager Premium that provides access to secure information about drivers and vehicles; MiX Fleet Manager Essential for monitoring drivers and vehicles; and MiX Asset Manager, a solution for fleet owners and managers to track and monitor vehicles.</p>
<p>Featured Article: <a href='https://www.marketbeat.com/financial-terms/what-is-a-support-level/'>Using other technical indicators with support levels</a><!--ViewCount:ArticleHistoryID=46687727&PostDate=2020-1-31&type=g&tertiary=1&id=45549--></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/EarningsEstimatesChart.ashx?Prefix=NYSE&#038;Symbol=MIXT' alt='Earnings History and Estimates for MiX Telematics (NYSE:MIXT)' title='Earnings History and Estimates for MiX Telematics (NYSE:MIXT)' /></p>
<p><!--Keyword: MiX Telematics,NYSE:MIXT,MIXT,Computer and Technology,guidance,earnings,preannouncement--><!--Ratings:4,1,NYSE:MIXT--></p>
			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for MiX Telematics Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for MiX Telematics and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:MIXT&c=MiX+Telematics" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:MIXT" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.marketbeat.com/logos/mix-telematics-ltd-logo.png" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png">
 						<meta itemprop="height" content="90">
					 </div>
					<meta itemprop="name" content="Community Financial News"/>
					<meta itemprop="url" content="https://com-unik.info" />
 				</div>
				<!-- end article metadata -->

			</article>

<!-- IMS below post -->
		<div id="Com_Unik_ROS_BelowPost_1"></div><br><br>
<!-- end IMS below post -->	
		
<!-- start Dianomi – sponsored content -->
<iframe width="654" height="787" scrolling="no" src="//www.dianomi.com/smartads.epl?id=2341"></iframe>
<!-- end sponsored content -->

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.com-unik.info/2020/01/31/kulicke-and-soffa-industries-nasdaqklic-posts-quarterly-earnings-results-beats-estimates-by-0-10-eps.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Kulicke and Soffa Industries (NASDAQ:KLIC) Posts Quarterly  Earnings Results, Beats Estimates By $0.10 EPS</p></div></a>							
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/mix-telematics-ltd-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="MiX Telematics  Releases FY20 Earnings Guidance" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html" rel="bookmark">MiX Telematics  Releases FY20 Earnings Guidance</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/kulicke-amp;-soffa-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Kulicke and Soffa Industries  Posts Quarterly  Earnings Results, Beats Estimates By $0.10 EPS" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/01/31/kulicke-and-soffa-industries-nasdaqklic-posts-quarterly-earnings-results-beats-estimates-by-0-10-eps.html" rel="bookmark">Kulicke and Soffa Industries  Posts Quarterly  Earnings Results, Beats Estimates By $0.10 EPS</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/quilter-plc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="JPMorgan Chase &#038; Co. Increases Quilter  Price Target to GBX 195" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/01/31/jpmorgan-chase-co-increases-quilter-lonqlt-price-target-to-gbx-195.html" rel="bookmark">JPMorgan Chase &#038; Co. Increases Quilter  Price Target to GBX 195</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/reed-elsevier-logo.jpeg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Relx  PT Raised to GBX 2,275" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/01/31/relx-lonrel-pt-raised-to-gbx-2275.html" rel="bookmark">Relx  PT Raised to GBX 2,275</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/ultra-electronics-holdings-plc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Berenberg Bank Boosts Ultra Electronics  Price Target to GBX 2,300" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/01/31/berenberg-bank-boosts-ultra-electronics-lonule-price-target-to-gbx-2300.html" rel="bookmark">Berenberg Bank Boosts Ultra Electronics  Price Target to GBX 2,300</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/wh-smith-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Barclays Reiterates Overweight Rating for WH Smith " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/01/31/barclays-reiterates-overweight-rating-for-wh-smith-lonsmwh.html" rel="bookmark">Barclays Reiterates Overweight Rating for WH Smith </a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
				<h2 style="padding: 5px 0; border-bottom: solid 1px #ddd; margin: 10px 0 4px 0;">Comments</h2>
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	</div> 			<!-- end comments section --> 



<!-- second ad spot -->


<br>

	</main> <!-- end main -->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<div style="clear:both"></div>
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2013-2020 <a href="https://www.com-unik.info">Community Financial News</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/js/wp-embed.min.js&#038;ver=1579791688'></script>

<!-- Start of StatCounter Code for Com-Unik -->
<script type="text/javascript">
var sc_project=10928871; 
var sc_invisible=1; 
var sc_security="cc698371"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/10928871/0/cc698371/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Com-Unik -->

<!-- Start of StatCounter Code for Finance Articles -->
<script type="text/javascript">
	var sc_project=9021069; 
	var sc_invisible=1; 
	var sc_security="fdde5482"; 
	var sc_https=1; 
	document.write("<sc"+"ript type='text/javascript' src='https://www.statcounter.com/counter/counter.js'></" + "script>");
</script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/"></noscript>
<!-- End of StatCounter Code for Finance Articles -->

<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html" target="_blank"><img src="https://www.com-unik.info//images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=MiX Telematics $NYSE:MIXT Releases FY20 Earnings Guidance https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html" target="_blank"><img src="https://www.com-unik.info//images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html" target="_blank"><img src="https://www.com-unik.info//images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=MiX Telematics $NYSE:MIXT Releases FY20 Earnings Guidance https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html" target="_blank"><img src="https://www.com-unik.info/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.com-unik.info/2020/01/31/mix-telematics-nysemixt-releases-fy20-earnings-guidance.html&title=MiX Telematics (NYSE:MIXT) Releases FY20 Earnings Guidance" target="_blank"><img src="https://www.com-unik.info//images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=46687727&PostDate=2020-1-31&type=g&tertiary=1&id=45549&domain=www.com-unik.info&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Start of StatCounter Code for Group 2 News Sites -->
<script type="text/javascript">
var sc_project=10694665; 
var sc_invisible=1; 
var sc_security="475eacb4"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" + scJsHost+ "statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><img class="statcounter" src="https://c.statcounter.com/10694665/0/475eacb4/1/"></noscript>
<!-- End of StatCounter Code for Group 2 News Sites -->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	</body>

</html>
