<!doctype html>
<html lang="en" style="display:block;min-width:1040px;">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="xqz76zmvfde7oisbofkg13kwkw4b67yf6bzn770iq7vzpcpjszundefy599v43fjk2m6zn9al-vxetd12no8tukobbk8y22lna705yov843ltiolagx5f7wj389vu-6c" />
<meta name="viewport" content="width=1040">
	
<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location};
var qva = '539382';var fan = '3739';var jwa = '116261';var geq = '-bup-ac';</script>

<link rel="stylesheet" type="text/css" href="https://www.com-unik.info/wp-content/themes/alambre-com-unik/style.css?v=12" media="screen" />
<link href="https://www.com-unik.info/feed" rel="alternate" title="Community Financial News RSS Feed" type="application/rss+xml" />
<link href="https://www.com-unik.info/feed/atom" rel="alternate" title="Community Financial News Atom Feed" type="application/atom+xml" />
<link href="https://www.com-unik.info/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css&#038;ver=1579791688' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://www.com-unik.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.com-unik.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.com-unik.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Insulet (NASDAQ:PODD) Price Target Cut to $206.00 by Analysts at Citigroup' href='https://www.com-unik.info/2020/03/31/insulet-nasdaqpodd-price-target-cut-to-206-00-by-analysts-at-citigroup.html' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html" />
<link rel='shortlink' href='https://www.com-unik.info/?p=2853095' />
<link rel="alternate" type="application/json+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F03%2F31%2Flamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F03%2F31%2Flamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html&#038;format=xml" />
<link rel="amphtml" href="https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html/amp" /><link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="32x32" />
<link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
<meta name="msapplication-TileImage" content="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
 
	
<!-- Start Meta Data -->

<title>Lamar Advertising (NASDAQ:LAMR) Rating Lowered to C at TheStreet - Community Financial News</title>


<meta name="description" content="TheStreet cut shares of Lamar Advertising (NASDAQ:LAMR) from a b- rating to a c rating in a research note published on Friday morning, TheStreetRatingsTable reports. Several other equities analysts have also recently commented on LAMR. Imperial Capital upgraded shares of Lamar Advertising from an in-line rating to an outperform rating and boosted their price target [&hellip;]" />
<meta name="author" content="Cynthia Vaughn">
<meta name="news_keywords" content="Lamar Advertising,NASDAQ:LAMR,LAMR,Finance,51281510,Downgrade,TheStreet" />
<meta name="keywords" content="Lamar Advertising,NASDAQ:LAMR,LAMR,Finance,51281510,Downgrade,TheStreet" />
<meta name="ticker" content="NASDAQ:LAMR" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@CFinancialNews" />
<meta name="twitter:title" content="Lamar Advertising (NASDAQ:LAMR) Rating Lowered to C at TheStreet"/>
<meta name="twitter:description" content="TheStreet cut shares of Lamar Advertising (NASDAQ:LAMR) from a b- rating to a c rating in a research note published on Friday morning, TheStreetRatingsTable reports. Several other equities analysts have also recently commented on LAMR. Imperial Capital upgraded shares of Lamar Advertising from an in-line rating to an outperform rating and boosted their price target [&hellip;]" />
<meta name="twitter:creator" content="@CFinancialNews" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/lamar-advertising-company-logo.jpg" />

<!-- Open Graph Data -->
<meta property="og:title" content="Lamar Advertising (NASDAQ:LAMR) Rating Lowered to C at TheStreet" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/lamar-advertising-company-logo.jpg" />
<meta property="og:description" content="TheStreet cut shares of Lamar Advertising (NASDAQ:LAMR) from a b- rating to a c rating in a research note published on Friday morning, TheStreetRatingsTable reports. Several other equities analysts have also recently commented on LAMR. Imperial Capital upgraded shares of Lamar Advertising from an in-line rating to an outperform rating and boosted their price target [&hellip;]" />
<meta property="og:site_name" content="Community Financial News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-03-31T10:58:43+0000" />
<meta property="article:modified_time" content="2020-03-31T10:58:43+0000" />
<meta property="article:tag" content="NASDAQ:LAMR" />
<meta property="article:tag" content="Lamar Advertising,NASDAQ:LAMR,LAMR,Finance,51281510,Downgrade,TheStreet" />
<meta property="article:section" content="Finance" />


<!-- End Meta Data -->

<script type='text/javascript'>var PopupAdChannel=''; </script>


 <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'com-unik.info';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e44ae816-df10-443c-9af6-8ac7ebff4880",
      safari_web_id: 'web.onesignal.auto.486fe890-0d3a-4b25-a01f-9ae2be714cd5',
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}
  </script>

<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
	
<!-- start ims header script -->
	<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13226773,
				sizes: [[300,250]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'Com_Unik_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
	
	<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	
<!-- end ims header script -->
	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
</head>

<body>


<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Community Financial News', 'com-unik.info', 'NASDAQ:LAMR', 'Lamar Advertising', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/lamar-advertising-company-logo.jpg');</script>
<!-- End MarketBeat Modern Popup -->
	


<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-nav" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>				<form id="searchform" action="https://www.com-unik.info/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding" style="height:110px"><!-- start: width-limiter with logo and space for alternate header unit -->
<div style="float:left;width:280px;">
		<a href="https://www.com-unik.info"><img id="logo" src="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png" alt="community financial news logo"></a>



</div>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" style='float:right;width:728px;height:90px;'>
<iframe src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no"></iframe>
	</div> 
<!-- End Header Unit-->

	</div> <!-- end: width-limiter with logo and space for alternate header unit -->



	<div id="menu">
		<div class="width-limiter">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-front-page-categories" class="menu"><li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li id="menu-item-107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter">
		<aside>
	
<iframe src="https://marketbeat.com/scripts/SidebarAdNewsSites.ashx" width="336" height="280" frameborder="no"></iframe><br>

	
<!-- first square unit -->
<div class="ad336x280">

<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

</div>
<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
<!-- end second square unit -->
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Lamar Advertising</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Lamar Advertising with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:LAMR" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<a href="https://twitter.com/CFinancialNews" class="twitter-follow-button" data-show-count="false">Follow @CFinancialNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FCommunity-Financial-News-1775168779380432&amp;width=336&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true&amp;appId=229098600454584" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:336px; height:250px;" allowTransparency="true"></iframe>






<!-- start IMS -->
	
<div id="Com_Unik_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('Com_Unik_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- end IMS -->



<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Top Stories</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html">Lamar Advertising (NASDAQ:LAMR) Rating Lowered to C at TheStreet</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/five-below-nasdaqfive-cut-to-c-at-thestreet.html">Five Below (NASDAQ:FIVE) Cut to &#8220;C+&#8221; at TheStreet</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/natus-medical-nasdaqntus-cut-to-d-at-thestreet.html">Natus Medical (NASDAQ:NTUS) Cut to &#8220;D+&#8221; at TheStreet</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/sun-life-financial-nyseslf-cut-to-c-at-thestreet.html">Sun Life Financial (NYSE:SLF) Cut to C at TheStreet</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/insulet-nasdaqpodd-price-target-cut-to-206-00-by-analysts-at-citigroup.html">Insulet (NASDAQ:PODD) Price Target Cut to $206.00 by Analysts at Citigroup</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/paylocity-nasdaqpcty-given-new-115-00-price-target-at-suntrust-banks.html">Paylocity (NASDAQ:PCTY) Given New $115.00 Price Target at SunTrust Banks</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/simply-good-foods-nasdaqsmpl-upgraded-to-hold-at-zacks-investment-research.html">Simply Good Foods (NASDAQ:SMPL) Upgraded to Hold at Zacks Investment Research</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/petroshale-cvepsh-price-target-cut-to-c0-20-by-analysts-at-national-bank-financial.html">Petroshale (CVE:PSH) Price Target Cut to C$0.20 by Analysts at National Bank Financial</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/summit-industrial-income-reit-cvesmu-un-price-target-lowered-to-c11-50-at-cibc.html">Summit Industrial Income REIT (CVE:SMU.UN) Price Target Lowered to C$11.50 at CIBC</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/storagevault-canada-cvesvi-given-a-c3-50-price-target-at-raymond-james.html">StorageVault Canada (CVE:SVI) Given a C$3.50 Price Target at Raymond James</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/esquire-financial-nasdaqesq-downgraded-by-thestreet-to-c.html">Esquire Financial (NASDAQ:ESQ) Downgraded by TheStreet to &#8220;C-&#8220;</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/graham-nyseghm-rating-lowered-to-d-at-thestreet.html">Graham (NYSE:GHM) Rating Lowered to D+ at TheStreet</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/vaneck-au-corp-bond-etf-units-fp-plus-to-issue-interim-dividend-of-0-10-on-april-16th.html">Vaneck Au Corp Bond ETF Units FP (PLUS) to Issue Interim Dividend of $0.10 on  April 16th</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/royal-bank-of-scotland-group-nyserbs-lowered-to-d-at-thestreet.html">Royal Bank of Scotland Group (NYSE:RBS) Lowered to D+ at TheStreet</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/eastgroup-properties-nyseegp-coverage-initiated-by-analysts-at-royal-bank-of-canada.html">Eastgroup Properties (NYSE:EGP) Coverage Initiated by Analysts at Royal Bank of Canada</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/stemline-therapeutics-stml-overweight-rating-reiterated-at-cantor-fitzgerald.html">Stemline Therapeutics&#8217; (STML) &#8220;Overweight&#8221; Rating Reiterated at Cantor Fitzgerald</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/monness-crespi-hardt-trims-elastic-nyseestc-target-price-to-80-00.html">Monness Crespi &#038; Hardt Trims Elastic (NYSE:ESTC) Target Price to $80.00</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/turkcell-iletisim-hizmetleri-a-s-nysetkc-downgraded-by-thestreet-to-c.html">Turkcell Iletisim Hizmetleri A.S. (NYSE:TKC) Downgraded by TheStreet to &#8220;C+&#8221;</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/janus-henderson-group-nysejhg-rating-lowered-to-d-at-thestreet.html">Janus Henderson Group (NYSE:JHG) Rating Lowered to D+ at TheStreet</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/03/31/employers-nyseeig-downgraded-by-thestreet.html">Employers (NYSE:EIG) Downgraded by TheStreet</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->

		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html" />
				<h1 itemprop="headline" class="page-title">Lamar Advertising (NASDAQ:LAMR) Rating Lowered to C at TheStreet</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author"><a href="https://www.com-unik.info/author/cynthia" title="Posts by Cynthia Vaughn" rel="author">Cynthia Vaughn</a></span> on <span itemprop="datePublished dateModified" content="2020-03-31T10:58:43+0000">Mar 31st, 2020</span>
				</p><!--end .postmeta-->
				
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><a href='https://www.marketbeat.com/logos/lamar-advertising-company-logo.jpg'><img src='https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/lamar-advertising-company-logo.jpg' alt='Lamar Advertising Co logo' title='Lamar Advertising Co logo' class='companylogo size-full' /></a>TheStreet cut shares of <span style='font-weight:italic'>Lamar Advertising (NASDAQ:LAMR)</span> from a b- rating to a c rating in a research note published on Friday morning, <a href="http://www.thestreet.com/r/ratings/upgradesanddowngrades/index.html/" target="_blank" rel="noopener noreferrer">TheStreetRatingsTable</a> reports.</p>
<p>Several other equities analysts have also recently commented on LAMR. Imperial Capital upgraded shares of Lamar Advertising from an in-line rating to an outperform rating and boosted their price target for the company from $91.00 to $93.00 in a report on Tuesday, March 10th. Morgan Stanley boosted their price target on shares of Lamar Advertising from $92.00 to $94.00 and gave the company an equal weight rating in a report on Friday, February 21st. Citigroup raised shares of Lamar Advertising from a sell rating to a neutral rating in a research note on Wednesday, March 25th. BidaskClub lowered shares of Lamar Advertising from a sell rating to a strong sell rating in a research note on Thursday, March 19th. Finally, MKM Partners lifted their price objective on shares of Lamar Advertising to  in a research note on Wednesday, February 26th. One research analyst  has rated the stock with a sell rating, four have given a hold rating and one  has assigned  a buy rating to the company&#8217;s stock. The company  has an average rating of Hold and a consensus price target of $93.00.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Community Financial News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:LAMR" />    <label for="InPostRegistrationEmail">Get <b>Lamar Advertising</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p><a href='https://www.marketbeat.com/stocks/NASDAQ/LAMR/price-target/' target='_blank' rel="noopener noreferrer">NASDAQ LAMR</a> traded up $1.10 on Friday, hitting $52.37. 4,232 shares of the stock were exchanged, compared to its average volume of 1,529,110. The company&#8217;s 50-day moving average price is $75.14 and its two-hundred day moving average price is $82.74. The company has a debt-to-equity ratio of 3.24, a current ratio of 0.46 and a quick ratio of 0.46. Lamar Advertising has a 52-week low of $30.89 and a 52-week high of $96.82. The company has a market capitalization of $4.76 billion, a price-to-earnings ratio of 14.15 and a beta of 1.04. </p>
<p>
		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;width:340px;">

			  <!-- Network Wide AdSense Unit - In-Post Position -->
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9254111670"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

                 </div>


                 Lamar Advertising (NASDAQ:LAMR) last posted its quarterly earnings results on Thursday, February 20th. The real estate investment trust reported $1.02 EPS for the quarter, missing the consensus estimate of $1.10 by ($0.08). Lamar Advertising had a net margin of 21.21% and a return on equity of 32.37%. The company had revenue of $462.70 million for the quarter, compared to analysts&#8217; expectations of $464.04 million. During the same quarter in the prior year, the firm earned $0.96 earnings per share. The company&#8217;s revenue was up 8.1% on a year-over-year basis.  Equities analysts predict that  Lamar Advertising will post 5.93 EPS for the current fiscal year. </p>
<p>The firm also recently disclosed a quarterly dividend, which will be paid on Tuesday, March 31st. Investors of record on Monday, March 16th will be paid a $1.00 dividend. This represents a $4.00 annualized dividend and a dividend yield of 7.64%. The ex-dividend date is Friday, March 13th. This is a positive change from Lamar Advertising&#8217;s previous quarterly dividend of $0.96. Lamar Advertising&#8217;s payout ratio is presently 68.97%. </p>
<p>A number of institutional investors have recently added to or reduced their stakes in the business. Norges Bank acquired a new position in  Lamar Advertising during the 4th quarter worth $68,798,000.  Connor Clark &#038; Lunn Investment Management Ltd. acquired a new position in  Lamar Advertising during the 4th quarter worth $611,000.  Kennedy Capital Management Inc. lifted its position in  Lamar Advertising by 7.4% during the 4th quarter. Kennedy Capital Management Inc. now owns 56,121 shares of the real estate investment trust&#8217;s stock worth $5,009,000 after acquiring an additional 3,890 shares during the last quarter.  Institute for Wealth Management LLC. lifted its position in  Lamar Advertising by 5.2% during the 4th quarter. Institute for Wealth Management LLC. now owns 2,725 shares of the real estate investment trust&#8217;s stock worth $243,000 after acquiring an additional 135 shares during the last quarter.  Finally, Pearl River Capital LLC acquired a new position in  Lamar Advertising during the 4th quarter worth $353,000. 81.15% of the stock is owned by hedge funds and other institutional investors. </p>
<p><strong>Lamar Advertising Company Profile</strong></p>
<p>Founded in 1902, Lamar Advertising (Nasdaq: LAMR) is one of the largest outdoor advertising companies in North America, with approximately 360,000 displays across the United States and Canada. Lamar offers advertisers a variety of billboard, interstate logo, transit and airport advertising formats, helping both local businesses and national brands reach broad audiences every day.</p>
<p>Recommended Story: <a href='https://www.marketbeat.com/financial-terms/what-does-a-hold-rating-mean/'>Hold Rating</a><!--ViewCount:ArticleHistoryID=50253262&PostDate=2020-3-31&type=a&quinary=1&id=1377716--></p>
<p><!--Keyword: Lamar Advertising,NASDAQ:LAMR,LAMR,Finance,51281510,Downgrade,TheStreet--><!--Ratings:3,3,NASDAQ:LAMR--></p>
			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Lamar Advertising Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Lamar Advertising and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:LAMR&c=Lamar+Advertising" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:LAMR" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.marketbeat.com/logos/lamar-advertising-company-logo.jpg" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png">
 						<meta itemprop="height" content="90">
					 </div>
					<meta itemprop="name" content="Community Financial News"/>
					<meta itemprop="url" content="https://com-unik.info" />
 				</div>
				<!-- end article metadata -->

			</article>

<!-- IMS below post -->
		<div id="Com_Unik_ROS_BelowPost_1"></div><br><br>
<!-- end IMS below post -->	
		

<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>
<!-- More on MarketBeat -->



			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.com-unik.info/2020/03/31/insulet-nasdaqpodd-price-target-cut-to-206-00-by-analysts-at-citigroup.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Insulet (NASDAQ:PODD) Price Target Cut to $206.00 by Analysts at Citigroup</p></div></a>							
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/lamar-advertising-company-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Lamar Advertising  Rating Lowered to C at TheStreet" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html" rel="bookmark">Lamar Advertising  Rating Lowered to C at TheStreet</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/five-below-inc-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Five Below  Cut to &#8220;C+&#8221; at TheStreet" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/03/31/five-below-nasdaqfive-cut-to-c-at-thestreet.html" rel="bookmark">Five Below  Cut to &#8220;C+&#8221; at TheStreet</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Natus Medical  Cut to &#8220;D+&#8221; at TheStreet" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/03/31/natus-medical-nasdaqntus-cut-to-d-at-thestreet.html" rel="bookmark">Natus Medical  Cut to &#8220;D+&#8221; at TheStreet</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/sun-life-financial-inc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Sun Life Financial  Cut to C at TheStreet" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/03/31/sun-life-financial-nyseslf-cut-to-c-at-thestreet.html" rel="bookmark">Sun Life Financial  Cut to C at TheStreet</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/insulet-corp-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Insulet  Price Target Cut to $206.00 by Analysts at Citigroup" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/03/31/insulet-nasdaqpodd-price-target-cut-to-206-00-by-analysts-at-citigroup.html" rel="bookmark">Insulet  Price Target Cut to $206.00 by Analysts at Citigroup</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/paylocity-holding-corp-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Paylocity  Given New $115.00 Price Target at SunTrust Banks" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/03/31/paylocity-nasdaqpcty-given-new-115-00-price-target-at-suntrust-banks.html" rel="bookmark">Paylocity  Given New $115.00 Price Target at SunTrust Banks</a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
				<h2 style="padding: 5px 0; border-bottom: solid 1px #ddd; margin: 10px 0 4px 0;">Comments</h2>
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	</div> 			<!-- end comments section --> 



<!-- second ad spot -->


<br>

	</main> <!-- end main -->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<div style="clear:both"></div>
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2013-2020 <a href="https://www.com-unik.info">Community Financial News</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/js/wp-embed.min.js&#038;ver=1579791688'></script>

<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of StatCounter Code for Com-Unik -->
<script type="text/javascript">
var sc_project=10928871; 
var sc_invisible=1; 
var sc_security="cc698371"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/10928871/0/cc698371/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Com-Unik -->

<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html" target="_blank"><img src="https://www.com-unik.info//images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=Lamar Advertising $NASDAQ:LAMR Rating Lowered to C at TheStreet https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html" target="_blank"><img src="https://www.com-unik.info//images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html" target="_blank"><img src="https://www.com-unik.info//images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=Lamar Advertising $NASDAQ:LAMR Rating Lowered to C at TheStreet https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html" target="_blank"><img src="https://www.com-unik.info/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.com-unik.info/2020/03/31/lamar-advertising-nasdaqlamr-rating-lowered-to-c-at-thestreet.html&title=Lamar Advertising (NASDAQ:LAMR) Rating Lowered to C at TheStreet" target="_blank"><img src="https://www.com-unik.info//images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=50253262&PostDate=2020-3-31&type=a&quinary=1&id=1377716&domain=www.com-unik.info&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	</body>

</html>
