<!doctype html>
<html lang="en" style="display:block;min-width:1040px;">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="xqz76zmvfde7oisbofkg13kwkw4b67yf6bzn770iq7vzpcpjszundefy599v43fjk2m6zn9al-vxetd12no8tukobbk8y22lna705yov843ltiolagx5f7wj389vu-6c" />
<meta name="viewport" content="width=1040">
	
<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location};
var qva = '539382';var fan = '3739';var jwa = '116261';var geq = '-bup-ac';</script>

<link rel="stylesheet" type="text/css" href="https://www.com-unik.info/wp-content/themes/alambre-com-unik/style.css?v=12" media="screen" />
<link href="https://www.com-unik.info/feed" rel="alternate" title="Community Financial News RSS Feed" type="application/rss+xml" />
<link href="https://www.com-unik.info/feed/atom" rel="alternate" title="Community Financial News Atom Feed" type="application/atom+xml" />
<link href="https://www.com-unik.info/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css&#038;ver=1579791688' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://www.com-unik.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.com-unik.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.com-unik.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Brokerages Set Pool Co. (NASDAQ:POOL) Price Target at $225.60' href='https://www.com-unik.info/2020/04/06/brokerages-set-pool-co-nasdaqpool-price-target-at-225-60.html' />
<link rel='next' title='Mid-America Apartment Communities Inc (NYSE:MAA) COO Thomas L. Grimes, Jr. Sells 367 Shares' href='https://www.com-unik.info/2020/04/06/mid-america-apartment-communities-inc-nysemaa-coo-thomas-l-grimes-jr-sells-367-shares.html' />
<meta name="generator" content="WordPress 5.3.2" />
<link rel="canonical" href="https://www.com-unik.info/2020/04/06/geospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html" />
<link rel='shortlink' href='https://www.com-unik.info/?p=2864910' />
<link rel="alternate" type="application/json+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F04%2F06%2Fgeospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F04%2F06%2Fgeospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html&#038;format=xml" />
<link rel="amphtml" href="https://www.com-unik.info/2020/04/06/geospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html/amp" /><link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="32x32" />
<link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
<meta name="msapplication-TileImage" content="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
 
	
<!-- Start Meta Data -->

<title>Geospace Technologies Co. (NASDAQ:GEOS) Director Richard F. Miles Buys 10,000 Shares - Community Financial News</title>


<meta name="description" content="Geospace Technologies Co. (NASDAQ:GEOS) Director Richard F. Miles purchased 10,000 shares of Geospace Technologies stock in a transaction that occurred on Monday, April 6th. The stock was acquired at an average price of $6.55 per share, for a total transaction of $65,500.00. Following the transaction, the director now directly owns 18,600 shares of the company&#8217;s [&hellip;]" />
<meta name="author" content="Carolyn Dwyer">
<meta name="news_keywords" content="Geospace Technologies,NASDAQ:GEOS,GEOS,Computer and Technology,37364X10,Insider Trading, Insider Trades, Stocks" />
<meta name="keywords" content="Geospace Technologies,NASDAQ:GEOS,GEOS,Computer and Technology,37364X10,Insider Trading, Insider Trades, Stocks" />
<meta name="ticker" content="NASDAQ:GEOS" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@CFinancialNews" />
<meta name="twitter:title" content="Geospace Technologies Co. (NASDAQ:GEOS) Director Richard F. Miles Buys 10,000 Shares"/>
<meta name="twitter:description" content="Geospace Technologies Co. (NASDAQ:GEOS) Director Richard F. Miles purchased 10,000 shares of Geospace Technologies stock in a transaction that occurred on Monday, April 6th. The stock was acquired at an average price of $6.55 per share, for a total transaction of $65,500.00. Following the transaction, the director now directly owns 18,600 shares of the company&#8217;s [&hellip;]" />
<meta name="twitter:creator" content="@CFinancialNews" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/geospace-technologies-corp-logo.jpg" />

<!-- Open Graph Data -->
<meta property="og:title" content="Geospace Technologies Co. (NASDAQ:GEOS) Director Richard F. Miles Buys 10,000 Shares" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.com-unik.info/2020/04/06/geospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/geospace-technologies-corp-logo.jpg" />
<meta property="og:description" content="Geospace Technologies Co. (NASDAQ:GEOS) Director Richard F. Miles purchased 10,000 shares of Geospace Technologies stock in a transaction that occurred on Monday, April 6th. The stock was acquired at an average price of $6.55 per share, for a total transaction of $65,500.00. Following the transaction, the director now directly owns 18,600 shares of the company&#8217;s [&hellip;]" />
<meta property="og:site_name" content="Community Financial News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-04-06T19:32:22+0000" />
<meta property="article:modified_time" content="2020-04-06T19:32:22+0000" />
<meta property="article:tag" content="NASDAQ:GEOS" />
<meta property="article:tag" content="Geospace Technologies,NASDAQ:GEOS,GEOS,Computer and Technology,37364X10,Insider Trading, Insider Trades, Stocks" />
<meta property="article:section" content="Finance" />


<!-- End Meta Data -->

<script type='text/javascript'>var PopupAdChannel=''; </script>


 <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'com-unik.info';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e44ae816-df10-443c-9af6-8ac7ebff4880",
      safari_web_id: 'web.onesignal.auto.486fe890-0d3a-4b25-a01f-9ae2be714cd5',
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}
  </script>

<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
	
<!-- start ims header script -->
	<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13226773,
				sizes: [[300,250]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'Com_Unik_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
	
	<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	
<!-- end ims header script -->
	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
</head>

<body>


<!-- Start MarketBeat Modern Popup -->
<script type='text/javascript'> var ShowInsiderTradesPopupFirst = true;</script><link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Community Financial News', 'com-unik.info', 'NASDAQ:GEOS', 'Geospace Technologies', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/geospace-technologies-corp-logo.jpg');</script>
<!-- End MarketBeat Modern Popup -->
	


<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-nav" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>				<form id="searchform" action="https://www.com-unik.info/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding" style="height:110px"><!-- start: width-limiter with logo and space for alternate header unit -->
<div style="float:left;width:280px;">
		<a href="https://www.com-unik.info"><img id="logo" src="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png" alt="community financial news logo"></a>



</div>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" style='float:right;width:728px;height:90px;'>
<iframe src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no"></iframe>
	</div> 
<!-- End Header Unit-->

	</div> <!-- end: width-limiter with logo and space for alternate header unit -->



	<div id="menu">
		<div class="width-limiter">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-front-page-categories" class="menu"><li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li id="menu-item-107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter">
		<aside>
	
<iframe src="https://marketbeat.com/scripts/SidebarAdNewsSites.ashx" width="336" height="280" frameborder="no"></iframe><br>

	
<!-- first square unit -->
<div class="ad336x280">

<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

</div>
<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
<!-- end second square unit -->
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Geospace Technologies</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Geospace Technologies with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:GEOS" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<a href="https://twitter.com/CFinancialNews" class="twitter-follow-button" data-show-count="false">Follow @CFinancialNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FCommunity-Financial-News-1775168779380432&amp;width=336&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true&amp;appId=229098600454584" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:336px; height:250px;" allowTransparency="true"></iframe>






<!-- start IMS -->
	
<div id="Com_Unik_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('Com_Unik_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- end IMS -->



<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Top Stories</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/iqiyi-inc-nasdaqiq-receives-22-97-consensus-price-target-from-analysts.html">IQIYI Inc (NASDAQ:IQ) Receives $22.97 Consensus Price Target from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/corbus-pharmaceuticals-holdings-inc-nasdaqcrbp-receives-44-25-consensus-pt-from-brokerages.html">Corbus Pharmaceuticals Holdings Inc (NASDAQ:CRBP) Receives $44.25 Consensus PT from Brokerages</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/pernod-ricard-s-adr-otcmktspdrdy-given-average-rating-of-hold-by-analysts.html">PERNOD RICARD S/ADR (OTCMKTS:PDRDY) Given Average Rating of &#8220;Hold&#8221; by Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/brokerages-set-essential-properties-realty-trust-inc-nyseeprt-pt-at-23-56.html">Brokerages Set Essential Properties Realty Trust Inc (NYSE:EPRT) PT at $23.56</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/valuengine-upgrades-hailiang-education-group-nasdaqhlg-to-hold.html">ValuEngine Upgrades Hailiang Education Group (NASDAQ:HLG) to &#8220;Hold&#8221;</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/vivint-solar-inc-nysevslr-given-consensus-recommendation-of-buy-by-analysts.html">Vivint Solar Inc (NYSE:VSLR) Given Consensus Recommendation of &#8220;Buy&#8221; by Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/brokerages-anticipate-neenah-inc-nysenp-to-post-0-95-eps-2.html">Brokerages Anticipate Neenah Inc (NYSE:NP) to Post $0.95 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/tt-electronics-plc-lonttg-receives-gbx-251-67-average-price-target-from-analysts.html">TT Electronics plc (LON:TTG) Receives GBX 251.67 Average Price Target from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/identiv-inc-nasdaqinve-receives-average-recommendation-of-buy-from-brokerages.html">Identiv Inc (NASDAQ:INVE) Receives Average Recommendation of &#8220;Buy&#8221; from Brokerages</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/gibson-energy-inc-tsegei-receives-average-recommendation-of-buy-from-analysts.html">Gibson Energy Inc. (TSE:GEI) Receives Average Recommendation of &#8220;Buy&#8221; from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/tencent-holding-adr-otcmktstcehy-receives-55-00-average-pt-from-analysts.html">TENCENT HOLDING/ADR (OTCMKTS:TCEHY) Receives $55.00 Average PT from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/kloeckner-co-se-etrkco-given-average-rating-of-hold-by-analysts.html">Kloeckner &#038; Co SE (ETR:KCO) Given Average Rating of &#8220;Hold&#8221; by Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/central-garden-pet-co-nasdaqcenta-receives-34-67-average-price-target-from-brokerages.html">Central Garden &#038; Pet Co (NASDAQ:CENTA) Receives $34.67 Average Price Target from Brokerages</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/ishares-1-3-year-treasury-bond-etf-nasdaqshy-lifted-to-hold-at-valuengine.html">iShares 1-3 Year Treasury Bond ETF (NASDAQ:SHY) Lifted to &#8220;Hold&#8221; at ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/analysts-set-kirkland-lake-gold-ltd-nysekl-pt-at-46-25.html">Analysts Set Kirkland Lake Gold Ltd (NYSE:KL) PT at $46.25</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/intercontinental-hotels-group-plc-nyseihg-receives-average-rating-of-hold-from-analysts.html">InterContinental Hotels Group PLC (NYSE:IHG) Receives Average Rating of &#8220;Hold&#8221; from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/brokerages-anticipate-neenah-inc-nysenp-to-post-0-95-eps.html">Brokerages Anticipate Neenah Inc (NYSE:NP) to Post $0.95 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/brokerages-anticipate-onesmart-international-edun-gr-ltd-nyseone-to-announce-0-04-eps.html">Brokerages Anticipate OneSmart International Edun Gr Ltd &#8211; (NYSE:ONE) to Announce $0.04 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/happiness-biotech-group-nasdaqhapp-raised-to-buy-at-valuengine.html">Happiness Biotech Group (NASDAQ:HAPP) Raised to Buy at ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/04/06/greensky-nasdaqgsky-downgraded-by-valuengine.html">GreenSky (NASDAQ:GSKY) Downgraded by ValuEngine</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->

		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.com-unik.info/2020/04/06/geospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html" />
				<h1 itemprop="headline" class="page-title">Geospace Technologies Co. (NASDAQ:GEOS) Director Richard F. Miles Buys 10,000 Shares</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author"><a href="https://www.com-unik.info/author/carolyn" title="Posts by Carolyn Dwyer" rel="author">Carolyn Dwyer</a></span> on <span itemprop="datePublished dateModified" content="2020-04-06T19:32:22+0000">Apr 6th, 2020</span>
				</p><!--end .postmeta-->
				
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/geospace-technologies-corp-logo.jpg" alt="Geospace Technologies logo" title="Geospace Technologies logo" class="companylogo" />Geospace Technologies Co. (NASDAQ:GEOS) Director Richard F. Miles purchased 10,000 shares of Geospace Technologies stock in a transaction that occurred on Monday, April 6th. The stock was acquired at an average price of $6.55 per share, for a total transaction of $65,500.00. Following the transaction, the director now directly owns 18,600 shares of the company&#8217;s stock, valued at approximately $121,830. The acquisition was disclosed in a document filed with the SEC, which is accessible through <a href='http://www.sec.gov/Archives/edgar/data/1001115/000120919120023631/xslF345X03/doc4.xml' target='_blank' rel="noopener noreferrer">this hyperlink</a>. </p>
<p><a href='https://www.marketbeat.com/stocks/NASDAQ/GEOS/insider-trades/' target='_blank' rel="noopener noreferrer">GEOS</a> traded up $1.20 during trading hours on Monday, hitting $6.80. The company&#8217;s stock had a trading volume of 312,600 shares, compared to its average volume of 72,091. Geospace Technologies Co. has a 12 month low of $4.61 and a 12 month high of $17.66. The stock has a market cap of $81.14 million, a price-to-earnings ratio of 21.94 and a beta of 2.34. The business&#8217;s 50-day moving average price is $9.07 and its 200-day moving average price is $13.58. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Community Financial News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:GEOS" />    <label for="InPostRegistrationEmail">Get <b>Geospace Technologies</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>Geospace Technologies (NASDAQ:GEOS) last posted its quarterly earnings data on Wednesday, February 5th. The oil and gas company reported ($0.10) earnings per share for the quarter. Geospace Technologies had a net margin of 4.26% and a negative return on equity of 2.71%. The firm had revenue of $25.70 million for the quarter. </p>
<p>
		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;width:340px;">

			  <!-- Network Wide AdSense Unit - In-Post Position -->
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9254111670"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

                 </div>


                 Separately, <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?ValuEngine=1&#038;Symbol=GEOS'>ValuEngine</a> upgraded shares of Geospace Technologies from a &#8220;hold&#8221; rating to a &#8220;buy&#8221; rating in a research report on Saturday, January 18th.</p>
<p>A number of hedge funds have recently bought and sold shares of GEOS. State Street Corp increased its position in  Geospace Technologies by 13.7% during the third quarter. State Street Corp now owns 334,126 shares of the oil and gas company&#8217;s stock valued at $5,136,000 after acquiring an additional 40,299 shares during the last quarter.  Moors &#038; Cabot Inc. purchased a new stake in shares of  Geospace Technologies during the fourth quarter valued at $288,000.  LS Investment Advisors LLC boosted its stake in shares of  Geospace Technologies by 1,620.9% during the fourth quarter. LS Investment Advisors LLC now owns 7,658 shares of the oil and gas company&#8217;s stock valued at $128,000 after purchasing an additional 7,213 shares during the period.  Rhumbline Advisers boosted its stake in shares of  Geospace Technologies by 7.0% during the fourth quarter. Rhumbline Advisers now owns 38,809 shares of the oil and gas company&#8217;s stock valued at $651,000 after purchasing an additional 2,543 shares during the period.  Finally, Crossmark Global Holdings Inc. purchased a new stake in shares of  Geospace Technologies during the fourth quarter valued at $206,000. Institutional investors and hedge funds own  70.04% of the company&#8217;s stock. </p>
<p><strong>Geospace Technologies Company Profile</strong></p>
<p>Geospace Technologies Corporation designs and manufactures instruments and equipment used in the oil and gas industry to acquire seismic data in order to locate, characterize, and monitor hydrocarbon producing reservoirs. The company operates through three segments: Oil and Gas Markets, Adjacent Markets, and Emerging Markets.</p>
<p>Further Reading: <a href='https://www.marketbeat.com/financial-terms/hedge-funds-how-they-work-investors/'>Hedge Funds &#8211; Risk or Reward?<br />
</a><!--ViewCount:ArticleHistoryID=50635888&PostDate=2020-4-6&type=i&id=384598--></p>
<p><!--Keyword: Geospace Technologies,NASDAQ:GEOS,GEOS,Computer and Technology,37364X10,Insider Trading, Insider Trades, Stocks--></p>
			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Geospace Technologies Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Geospace Technologies and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:GEOS&c=Geospace+Technologies" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:GEOS" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.marketbeat.com/logos/geospace-technologies-corp-logo.jpg" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png">
 						<meta itemprop="height" content="90">
					 </div>
					<meta itemprop="name" content="Community Financial News"/>
					<meta itemprop="url" content="https://com-unik.info" />
 				</div>
				<!-- end article metadata -->

			</article>

		

<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>
<!-- More on MarketBeat -->
<!-- IMS below post -->
		<div id="Com_Unik_ROS_BelowPost_1"></div><br><br>
<!-- end IMS below post -->	


			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.com-unik.info/2020/04/06/brokerages-set-pool-co-nasdaqpool-price-target-at-225-60.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Brokerages Set Pool Co. (NASDAQ:POOL) Price Target at $225.60</p></div></a>				<a href="https://www.com-unik.info/2020/04/06/mid-america-apartment-communities-inc-nysemaa-coo-thomas-l-grimes-jr-sells-367-shares.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>Mid-America Apartment Communities Inc (NYSE:MAA) COO Thomas L. Grimes, Jr. Sells 367 Shares</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/iqiyi-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="IQIYI Inc  Receives $22.97 Consensus Price Target from Analysts" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/04/06/iqiyi-inc-nasdaqiq-receives-22-97-consensus-price-target-from-analysts.html" rel="bookmark">IQIYI Inc  Receives $22.97 Consensus Price Target from Analysts</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/corbus-pharmaceuticals-holdings-inc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Corbus Pharmaceuticals Holdings Inc  Receives $44.25 Consensus PT from Brokerages" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/04/06/corbus-pharmaceuticals-holdings-inc-nasdaqcrbp-receives-44-25-consensus-pt-from-brokerages.html" rel="bookmark">Corbus Pharmaceuticals Holdings Inc  Receives $44.25 Consensus PT from Brokerages</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/pernod-ricard-sa-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="PERNOD RICARD S/ADR  Given Average Rating of &#8220;Hold&#8221; by Analysts" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/04/06/pernod-ricard-s-adr-otcmktspdrdy-given-average-rating-of-hold-by-analysts.html" rel="bookmark">PERNOD RICARD S/ADR  Given Average Rating of &#8220;Hold&#8221; by Analysts</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/essential-properties-realty-trust-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Brokerages Set Essential Properties Realty Trust Inc  PT at $23.56" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/04/06/brokerages-set-essential-properties-realty-trust-inc-nyseeprt-pt-at-23-56.html" rel="bookmark">Brokerages Set Essential Properties Realty Trust Inc  PT at $23.56</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="ValuEngine Upgrades Hailiang Education Group  to &#8220;Hold&#8221;" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/04/06/valuengine-upgrades-hailiang-education-group-nasdaqhlg-to-hold.html" rel="bookmark">ValuEngine Upgrades Hailiang Education Group  to &#8220;Hold&#8221;</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/vivint-solar-holdings-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Vivint Solar Inc  Given Consensus Recommendation of &#8220;Buy&#8221; by Analysts" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/04/06/vivint-solar-inc-nysevslr-given-consensus-recommendation-of-buy-by-analysts.html" rel="bookmark">Vivint Solar Inc  Given Consensus Recommendation of &#8220;Buy&#8221; by Analysts</a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
				<h2 style="padding: 5px 0; border-bottom: solid 1px #ddd; margin: 10px 0 4px 0;">Comments</h2>
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	</div> 			<!-- end comments section --> 



<!-- second ad spot -->


<br>

	</main> <!-- end main -->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<div style="clear:both"></div>
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2013-2020 <a href="https://www.com-unik.info">Community Financial News</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/js/wp-embed.min.js&#038;ver=1579791688'></script>

<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of StatCounter Code for Com-Unik -->
<script type="text/javascript">
var sc_project=10928871; 
var sc_invisible=1; 
var sc_security="cc698371"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/10928871/0/cc698371/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Com-Unik -->

<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.com-unik.info/2020/04/06/geospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html" target="_blank"><img src="https://www.com-unik.info//images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=Geospace Technologies Co. $NASDAQ:GEOS Director Richard F. Miles Buys 10,000 Shares https://www.com-unik.info/2020/04/06/geospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html" target="_blank"><img src="https://www.com-unik.info//images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.com-unik.info/2020/04/06/geospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html" target="_blank"><img src="https://www.com-unik.info//images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=Geospace Technologies Co. $NASDAQ:GEOS Director Richard F. Miles Buys 10,000 Shares https://www.com-unik.info/2020/04/06/geospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html" target="_blank"><img src="https://www.com-unik.info/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.com-unik.info/2020/04/06/geospace-technologies-co-nasdaqgeos-director-richard-f-miles-buys-10000-shares.html&title=Geospace Technologies Co. (NASDAQ:GEOS) Director Richard F. Miles Buys 10,000 Shares" target="_blank"><img src="https://www.com-unik.info//images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=50635888&PostDate=2020-4-6&type=i&id=384598&domain=www.com-unik.info&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	</body>

</html>
