<!doctype html>
<html lang="en" style="display:block;min-width:1040px;">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="xqz76zmvfde7oisbofkg13kwkw4b67yf6bzn770iq7vzpcpjszundefy599v43fjk2m6zn9al-vxetd12no8tukobbk8y22lna705yov843ltiolagx5f7wj389vu-6c" />
<meta name="viewport" content="width=1040">
	
<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location};
var qva = '539382';var fan = '3739';var jwa = '116261';var geq = '-bup-ac';</script>

<link rel="stylesheet" type="text/css" href="https://www.com-unik.info/wp-content/themes/alambre-com-unik/style.css?v=12" media="screen" />
<link href="https://www.com-unik.info/feed" rel="alternate" title="Community Financial News RSS Feed" type="application/rss+xml" />
<link href="https://www.com-unik.info/feed/atom" rel="alternate" title="Community Financial News Atom Feed" type="application/atom+xml" />
<link href="https://www.com-unik.info/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css&#038;ver=1579791688' type='text/css' media='all' />
<link rel='https://api.w.org/' href='https://www.com-unik.info/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.com-unik.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.com-unik.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Nike Inc (NYSE:NKE) Given Consensus Recommendation of &#8220;Buy&#8221; by Brokerages' href='https://www.com-unik.info/2020/06/08/nike-inc-nysenke-given-consensus-recommendation-of-buy-by-brokerages.html' />
<link rel='next' title='Expedia Group (NASDAQ:EXPE) Upgraded by ValuEngine to Buy' href='https://www.com-unik.info/2020/06/08/expedia-group-nasdaqexpe-upgraded-by-valuengine-to-buy.html' />
<meta name="generator" content="WordPress 5.4.1" />
<link rel="canonical" href="https://www.com-unik.info/2020/06/08/izea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html" />
<link rel='shortlink' href='https://www.com-unik.info/?p=3041759' />
<link rel="alternate" type="application/json+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F06%2F08%2Fizea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F06%2F08%2Fizea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html&#038;format=xml" />
<link rel="amphtml" href="https://www.com-unik.info/2020/06/08/izea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html/amp" /><link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="32x32" />
<link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
<meta name="msapplication-TileImage" content="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
 
	
<!-- Start Meta Data -->

<title>IZEA Worldwide (NASDAQ:IZEA) Downgraded to Hold at ValuEngine - Community Financial News</title>


<meta name="description" content="IZEA Worldwide (NASDAQ:IZEA) was downgraded by ValuEngine from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating in a research report issued to clients and investors on Monday, ValuEngine reports. Several other analysts also recently commented on IZEA. Craig Hallum downgraded shares of IZEA Worldwide from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating and set a $0.50 [&hellip;]" />
<meta name="author" content="Carolyn Dwyer">
<meta name="news_keywords" content="IZEA Worldwide,NASDAQ:IZEA,IZEA,Computer and Technology,Downgrade,ValuEngine" />
<meta name="keywords" content="IZEA Worldwide,NASDAQ:IZEA,IZEA,Computer and Technology,Downgrade,ValuEngine" />
<meta name="ticker" content="NASDAQ:IZEA" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@CFinancialNews" />
<meta name="twitter:title" content="IZEA Worldwide (NASDAQ:IZEA) Downgraded to Hold at ValuEngine"/>
<meta name="twitter:description" content="IZEA Worldwide (NASDAQ:IZEA) was downgraded by ValuEngine from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating in a research report issued to clients and investors on Monday, ValuEngine reports. Several other analysts also recently commented on IZEA. Craig Hallum downgraded shares of IZEA Worldwide from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating and set a $0.50 [&hellip;]" />
<meta name="twitter:creator" content="@CFinancialNews" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/izea-inc-logo.png" />

<!-- Open Graph Data -->
<meta property="og:title" content="IZEA Worldwide (NASDAQ:IZEA) Downgraded to Hold at ValuEngine" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.com-unik.info/2020/06/08/izea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/izea-inc-logo.png" />
<meta property="og:description" content="IZEA Worldwide (NASDAQ:IZEA) was downgraded by ValuEngine from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating in a research report issued to clients and investors on Monday, ValuEngine reports. Several other analysts also recently commented on IZEA. Craig Hallum downgraded shares of IZEA Worldwide from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating and set a $0.50 [&hellip;]" />
<meta property="og:site_name" content="Community Financial News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-06-08T22:02:41+0000" />
<meta property="article:modified_time" content="2020-06-08T22:02:41+0000" />
<meta property="article:tag" content="NASDAQ:IZEA" />
<meta property="article:tag" content="IZEA Worldwide,NASDAQ:IZEA,IZEA,Computer and Technology,Downgrade,ValuEngine" />
<meta property="article:section" content="Finance" />


<!-- End Meta Data -->

<script type='text/javascript'>var PopupAdChannel=''; </script>


 <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'com-unik.info';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e44ae816-df10-443c-9af6-8ac7ebff4880",
      safari_web_id: 'web.onesignal.auto.486fe890-0d3a-4b25-a01f-9ae2be714cd5',
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}
  </script>

<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
	
<!-- start ims header script -->
	<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13226773,
				sizes: [[300,250]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'Com_Unik_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
	
	<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	
<!-- end ims header script -->
	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
</head>

<body>


<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Community Financial News', 'com-unik.info', 'NASDAQ:IZEA', 'IZEA Worldwide', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/izea-inc-logo.png');</script>
<!-- End MarketBeat Modern Popup -->
	


<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-nav" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>				<form id="searchform" action="https://www.com-unik.info/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding" style="height:110px"><!-- start: width-limiter with logo and space for alternate header unit -->
<div style="float:left;width:280px;">
		<a href="https://www.com-unik.info"><img id="logo" src="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png" alt="community financial news logo"></a>



</div>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" style='float:right;width:728px;height:90px;'>
<iframe src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no"></iframe>
	</div> 
<!-- End Header Unit-->

	</div> <!-- end: width-limiter with logo and space for alternate header unit -->



	<div id="menu">
		<div class="width-limiter">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-front-page-categories" class="menu"><li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li id="menu-item-107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter">
		<aside>
	
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no"></iframe><br><br>
	
<!-- first square unit -->
<div class="ad336x280">

<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

</div>
<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
<!-- end second square unit -->
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for IZEA Worldwide</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for IZEA Worldwide with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:IZEA" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<a href="https://twitter.com/CFinancialNews" class="twitter-follow-button" data-show-count="false">Follow @CFinancialNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FCommunity-Financial-News-1775168779380432&amp;width=336&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true&amp;appId=229098600454584" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:336px; height:250px;" allowTransparency="true"></iframe>






<!-- start IMS -->
	
<div id="Com_Unik_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('Com_Unik_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- end IMS -->



<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Top Stories</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/valuengine-lowers-vtv-therapeutics-nasdaqvtvt-to-hold.html">ValuEngine Lowers vTv Therapeutics (NASDAQ:VTVT) to Hold</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/univest-financial-nasdaquvsp-downgraded-by-valuengine.html">Univest Financial (NASDAQ:UVSP) Downgraded by ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/ocean-power-technologies-nasdaqoptt-stock-rating-upgraded-by-valuengine.html">Ocean Power Technologies (NASDAQ:OPTT) Stock Rating Upgraded by ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/catalyst-pharmaceuticals-nasdaqcprx-rating-lowered-to-strong-sell-at-valuengine.html">Catalyst Pharmaceuticals (NASDAQ:CPRX) Rating Lowered to Strong Sell at ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/rush-enterprises-nasdaqrusha-stock-rating-lowered-by-valuengine.html">Rush Enterprises (NASDAQ:RUSHA) Stock Rating Lowered by ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/nlight-nasdaqlasr-lowered-to-hold-at-valuengine.html">Nlight (NASDAQ:LASR) Lowered to Hold at ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/expedia-group-nasdaqexpe-upgraded-by-valuengine-to-buy.html">Expedia Group (NASDAQ:EXPE) Upgraded by ValuEngine to Buy</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/valuengine-lowers-etrade-financial-nasdaqetfc-to-sell.html">ValuEngine Lowers E*TRADE Financial (NASDAQ:ETFC) to Sell</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/izea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html">IZEA Worldwide (NASDAQ:IZEA) Downgraded to Hold at ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/capitala-finance-nasdaqcpta-stock-rating-upgraded-by-valuengine.html">Capitala Finance (NASDAQ:CPTA) Stock Rating Upgraded by ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/conns-nasdaqconn-stock-rating-upgraded-by-valuengine.html">Conn&#8217;s (NASDAQ:CONN) Stock Rating Upgraded by ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/chembio-diagnostics-nasdaqcemi-rating-lowered-to-hold-at-valuengine.html">Chembio Diagnostics (NASDAQ:CEMI) Rating Lowered to Hold at ValuEngine</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/nike-inc-nysenke-given-consensus-recommendation-of-buy-by-brokerages.html">Nike Inc (NYSE:NKE) Given Consensus Recommendation of &#8220;Buy&#8221; by Brokerages</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/acute-angle-cloud-aac-trading-1-8-lower-this-week.html">Acute Angle Cloud (AAC)  Trading 1.8% Lower  This Week</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/mt-bank-corp-has-33-73-million-position-in-nike-inc-nysenke.html">M&#038;T Bank Corp Has $33.73 Million Position in Nike Inc (NYSE:NKE)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/north-american-construction-group-ltd-tsenoa-director-martin-robert-ferron-sells-10000-shares.html">North American Construction Group Ltd (TSE:NOA) Director Martin Robert Ferron Sells 10,000 Shares</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/yee-yee-hits-24-hour-trading-volume-of-55423-00.html">YEE (YEE) Hits 24 Hour Trading Volume of $55,423.00</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/lunes-price-reaches-0-0046-lunes.html">Lunes Price Reaches $0.0046  (LUNES)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/dex-price-down-18-2-over-last-week-dex.html">DEX Price Down 18.2% Over Last Week (DEX)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/06/08/neutron-ntrn-price-up-13-3-over-last-week.html">Neutron (NTRN) Price Up 13.3% Over Last Week</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->

		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.com-unik.info/2020/06/08/izea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html" />
				<h1 itemprop="headline" class="page-title">IZEA Worldwide (NASDAQ:IZEA) Downgraded to Hold at ValuEngine</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author"><a href="https://www.com-unik.info/author/carolyn" title="Posts by Carolyn Dwyer" rel="author">Carolyn Dwyer</a></span> on <span itemprop="datePublished dateModified" content="2020-06-08T22:02:41+0000">Jun 8th, 2020</span>
				</p><!--end .postmeta-->
				
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/izea-inc-logo.png" alt="IZEA Worldwide logo" title="IZEA Worldwide logo" class="companylogo" /><span>IZEA Worldwide (NASDAQ:IZEA)</span> was downgraded by <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?ValuEngine=1&#038;Symbol=IZEA'>ValuEngine</a> from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating in a research report issued to clients and investors on Monday, <a href="http://www.valuengine.com/" target="_blank" rel="noopener noreferrer">ValuEngine</a> reports.</p>
<p>Several other analysts also recently commented on IZEA. Craig Hallum downgraded shares of IZEA Worldwide from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating and set a $0.50 price target for the company. in a research report on Friday, May 15th. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> upgraded shares of IZEA Worldwide from a &#8220;hold&#8221; rating to a &#8220;strong-buy&#8221; rating and set a $0.75 price target for the company in a research report on Wednesday, June 3rd.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Community Financial News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:IZEA" />    <label for="InPostRegistrationEmail">Get <b>IZEA Worldwide</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>Shares of <a href='https://www.marketbeat.com/stocks/NASDAQ/IZEA/price-target/' target='_blank' rel="noopener noreferrer">NASDAQ:IZEA</a> traded up $0.66 during trading on Monday, hitting $1.26. 44,558,329 shares of the company were exchanged, compared to its average volume of 5,200,649. The stock has a market capitalization of $21.31 million, a P/E ratio of -3.32 and a beta of 2.34. The company has a debt-to-equity ratio of 0.01, a current ratio of 1.06 and a quick ratio of 1.06. IZEA Worldwide has a 12-month low of $0.07 and a 12-month high of $1.28. The firm&#8217;s 50 day moving average price is $0.46 and its 200-day moving average price is $0.30. </p>
<p>
		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;width:340px;">

			  <!-- Network Wide AdSense Unit - In-Post Position -->
<ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9254111670"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

                 </div>


                 IZEA Worldwide (NASDAQ:IZEA) last released its quarterly earnings results on Thursday, May 14th. The company reported ($0.05) EPS for the quarter, beating the consensus estimate of ($0.07) by $0.02. IZEA Worldwide had a negative net margin of 61.41% and a negative return on equity of 57.08%. The firm had revenue of $4.76 million during the quarter.  As a group, equities research analysts anticipate that  IZEA Worldwide will post -0.08 EPS for the current year. </p>
<p><strong>About IZEA Worldwide</strong></p>
<p>IZEA Worldwide, Inc creates and operates online marketplaces that connect marketers and content creators. Its technology solutions enable the management of content workflow, creator search and targeting, bidding, analytics, and payment processing. The company engages creator for influencer marketing campaigns, or to create content for the marketers&#x27; use and distribution.</p>
<p>Read More: <a href='https://www.marketbeat.com/financial-terms/fundamental-analysis-stocks/'>Fundamental Analysis and Choosing Stocks</a><!--ViewCount:ArticleHistoryID=54866742&PostDate=2020-6-8&type=a&id=1426722--></p>
<p>To view ValuEngine&#8217;s full report, visit <a href="http://www.valuengine.com/rep/order_report?pid=64&#038;srchfor=IZEA">ValuEngine&#8217;s official website</a>.</p>
<p><!--Keyword: IZEA Worldwide,NASDAQ:IZEA,IZEA,Computer and Technology,Downgrade,ValuEngine--><!--Ratings:3,1,NASDAQ:IZEA--></p>
			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for IZEA Worldwide Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for IZEA Worldwide and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:IZEA&c=IZEA+Worldwide" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:IZEA" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.marketbeat.com/logos/izea-inc-logo.png" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png">
 						<meta itemprop="height" content="90">
					 </div>
					<meta itemprop="name" content="Community Financial News"/>
					<meta itemprop="url" content="https://com-unik.info" />
 				</div>
				<!-- end article metadata -->

			</article>

		

<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>
<!-- More on MarketBeat -->
<!-- IMS below post -->
		<div id="Com_Unik_ROS_BelowPost_1"></div><br><br>
<!-- end IMS below post -->	


			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.com-unik.info/2020/06/08/nike-inc-nysenke-given-consensus-recommendation-of-buy-by-brokerages.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Nike Inc (NYSE:NKE) Given Consensus Recommendation of &#8220;Buy&#8221; by Brokerages</p></div></a>				<a href="https://www.com-unik.info/2020/06/08/expedia-group-nasdaqexpe-upgraded-by-valuengine-to-buy.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>Expedia Group (NASDAQ:EXPE) Upgraded by ValuEngine to Buy</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/vtv-therapeutics-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="ValuEngine Lowers vTv Therapeutics  to Hold" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/06/08/valuengine-lowers-vtv-therapeutics-nasdaqvtvt-to-hold.html" rel="bookmark">ValuEngine Lowers vTv Therapeutics  to Hold</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/univest-corp-of-pa-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Univest Financial  Downgraded by ValuEngine" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/06/08/univest-financial-nasdaquvsp-downgraded-by-valuengine.html" rel="bookmark">Univest Financial  Downgraded by ValuEngine</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Ocean Power Technologies  Stock Rating Upgraded by ValuEngine" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/06/08/ocean-power-technologies-nasdaqoptt-stock-rating-upgraded-by-valuengine.html" rel="bookmark">Ocean Power Technologies  Stock Rating Upgraded by ValuEngine</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/catalyst-pharmaceutical-partners-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Catalyst Pharmaceuticals  Rating Lowered to Strong Sell at ValuEngine" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/06/08/catalyst-pharmaceuticals-nasdaqcprx-rating-lowered-to-strong-sell-at-valuengine.html" rel="bookmark">Catalyst Pharmaceuticals  Rating Lowered to Strong Sell at ValuEngine</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/rush-enterprises-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Rush Enterprises  Stock Rating Lowered by ValuEngine" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/06/08/rush-enterprises-nasdaqrusha-stock-rating-lowered-by-valuengine.html" rel="bookmark">Rush Enterprises  Stock Rating Lowered by ValuEngine</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/nlight-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Nlight  Lowered to Hold at ValuEngine" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/06/08/nlight-nasdaqlasr-lowered-to-hold-at-valuengine.html" rel="bookmark">Nlight  Lowered to Hold at ValuEngine</a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
				<h2 style="padding: 5px 0; border-bottom: solid 1px #ddd; margin: 10px 0 4px 0;">Comments</h2>
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	</div> 			<!-- end comments section --> 



<!-- second ad spot -->


<br>

	</main> <!-- end main -->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<div style="clear:both"></div>
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2013-2020 <a href="https://www.com-unik.info">Community Financial News</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/js/wp-embed.min.js&#038;ver=1579791688'></script>

<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of StatCounter Code for Com-Unik -->
<script type="text/javascript">
var sc_project=10928871; 
var sc_invisible=1; 
var sc_security="cc698371"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/10928871/0/cc698371/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Com-Unik -->

<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.com-unik.info/2020/06/08/izea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html" target="_blank"><img src="https://www.com-unik.info//images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=IZEA Worldwide $NASDAQ:IZEA Downgraded to Hold at ValuEngine https://www.com-unik.info/2020/06/08/izea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html" target="_blank"><img src="https://www.com-unik.info//images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.com-unik.info/2020/06/08/izea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html" target="_blank"><img src="https://www.com-unik.info//images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=IZEA Worldwide $NASDAQ:IZEA Downgraded to Hold at ValuEngine https://www.com-unik.info/2020/06/08/izea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html" target="_blank"><img src="https://www.com-unik.info/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.com-unik.info/2020/06/08/izea-worldwide-nasdaqizea-downgraded-to-hold-at-valuengine.html&title=IZEA Worldwide (NASDAQ:IZEA) Downgraded to Hold at ValuEngine" target="_blank"><img src="https://www.com-unik.info//images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=54866742&PostDate=2020-6-8&type=a&id=1426722&domain=www.com-unik.info&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	</body>

</html>
