<!doctype html>
<html lang="en" style="display:block;min-width:1040px;">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="xqz76zmvfde7oisbofkg13kwkw4b67yf6bzn770iq7vzpcpjszundefy599v43fjk2m6zn9al-vxetd12no8tukobbk8y22lna705yov843ltiolagx5f7wj389vu-6c" />
<meta name="viewport" content="width=1040">
	
<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location};
var qva = '539382';var fan = '3739';var jwa = '116261';var geq = '-bup-ac';</script>

<link rel="stylesheet" type="text/css" href="https://www.com-unik.info/wp-content/themes/alambre-com-unik/style.css?v=12" media="screen" />
<link href="https://www.com-unik.info/feed" rel="alternate" title="Community Financial News RSS Feed" type="application/rss+xml" />
<link href="https://www.com-unik.info/feed/atom" rel="alternate" title="Community Financial News Atom Feed" type="application/atom+xml" />
<link href="https://www.com-unik.info/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css&#038;ver=1579791688' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.com-unik.info/wp-json/" /><link rel="alternate" type="application/json" href="https://www.com-unik.info/wp-json/wp/v2/posts/3368506" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.com-unik.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.com-unik.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Hemogenyx Pharmaceuticals (LON:HEMO) Trading 0.7% Higher' href='https://www.com-unik.info/2020/09/29/hemogenyx-pharmaceuticals-lonhemo-trading-0-7-higher.html' />
<link rel='next' title='Maya Gold &#038; Silver (CVE:MYA)  Shares Down 10.4%' href='https://www.com-unik.info/2020/09/29/maya-gold-silver-cvemya-shares-down-10-4.html' />
<meta name="generator" content="WordPress 5.5.1" />
<link rel="canonical" href="https://www.com-unik.info/2020/09/29/firan-technology-group-otcmktsftgff-shares-down-7.html" />
<link rel='shortlink' href='https://www.com-unik.info/?p=3368506' />
<link rel="alternate" type="application/json+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F09%2F29%2Ffiran-technology-group-otcmktsftgff-shares-down-7.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F09%2F29%2Ffiran-technology-group-otcmktsftgff-shares-down-7.html&#038;format=xml" />
<link rel="amphtml" href="https://www.com-unik.info/2020/09/29/firan-technology-group-otcmktsftgff-shares-down-7.html/amp" /><link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="32x32" />
<link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
<meta name="msapplication-TileImage" content="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
 
	
<!-- Start Meta Data -->

<title>Firan Technology Group (OTCMKTS:FTGFF)  Shares Down 7% - Community Financial News</title>


<meta name="description" content="Firan Technology Group Corp. (OTCMKTS:FTGFF)&#8217;s share price dropped 7% on Tuesday . The stock traded as low as $1.20 and last traded at $1.20. Approximately 500 shares traded hands during mid-day trading, a decline of 69% from the average daily volume of 1,613 shares. The stock had previously closed at $1.29. The company&#8217;s fifty day [&hellip;]" />
<meta name="author" content="Eileen French">
<meta name="news_keywords" content="Firan Technology Group,OTCMKTS:FTGFF,FTGFF,Industrial,Stocks,Technicals" />
<meta name="keywords" content="Firan Technology Group,OTCMKTS:FTGFF,FTGFF,Industrial,Stocks,Technicals" />
<meta name="ticker" content="OTCMKTS:FTGFF" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@CFinancialNews" />
<meta name="twitter:title" content="Firan Technology Group (OTCMKTS:FTGFF)  Shares Down 7%"/>
<meta name="twitter:description" content="Firan Technology Group Corp. (OTCMKTS:FTGFF)&#8217;s share price dropped 7% on Tuesday . The stock traded as low as $1.20 and last traded at $1.20. Approximately 500 shares traded hands during mid-day trading, a decline of 69% from the average daily volume of 1,613 shares. The stock had previously closed at $1.29. The company&#8217;s fifty day [&hellip;]" />
<meta name="twitter:creator" content="@CFinancialNews" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/generic-stocks.jpg" />

<!-- Open Graph Data -->
<meta property="og:title" content="Firan Technology Group (OTCMKTS:FTGFF)  Shares Down 7%" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.com-unik.info/2020/09/29/firan-technology-group-otcmktsftgff-shares-down-7.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/generic-stocks.jpg" />
<meta property="og:description" content="Firan Technology Group Corp. (OTCMKTS:FTGFF)&#8217;s share price dropped 7% on Tuesday . The stock traded as low as $1.20 and last traded at $1.20. Approximately 500 shares traded hands during mid-day trading, a decline of 69% from the average daily volume of 1,613 shares. The stock had previously closed at $1.29. The company&#8217;s fifty day [&hellip;]" />
<meta property="og:site_name" content="Community Financial News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-09-29T23:52:41+0000" />
<meta property="article:modified_time" content="2020-09-29T23:52:41+0000" />
<meta property="article:tag" content="OTCMKTS:FTGFF" />
<meta property="article:tag" content="Firan Technology Group,OTCMKTS:FTGFF,FTGFF,Industrial,Stocks,Technicals" />
<meta property="article:section" content="Finance" />


<!-- End Meta Data -->

<script type='text/javascript'>var PopupAdChannel=''; </script>


 <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'com-unik.info';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e44ae816-df10-443c-9af6-8ac7ebff4880",
      safari_web_id: 'web.onesignal.auto.486fe890-0d3a-4b25-a01f-9ae2be714cd5',
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}
  </script>

<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
	
<!-- start ims header script -->
	<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13226773,
				sizes: [[300,250]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'Com_Unik_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
	
	<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	
<!-- end ims header script -->
	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
</head>

<body>


<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Community Financial News', 'com-unik.info', 'OTCMKTS:FTGFF', 'Firan Technology Group', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg');</script>
<!-- End MarketBeat Modern Popup -->
	


<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-nav" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>				<form id="searchform" action="https://www.com-unik.info/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding" style="height:110px"><!-- start: width-limiter with logo and space for alternate header unit -->
<div style="float:left;width:280px;">
		<a href="https://www.com-unik.info"><img id="logo" src="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png" alt="community financial news logo"></a>



</div>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" style='float:right;width:728px;height:90px;'>
<iframe src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no"></iframe>
	</div> 
<!-- End Header Unit-->

	</div> <!-- end: width-limiter with logo and space for alternate header unit -->



	<div id="menu">
		<div class="width-limiter">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-front-page-categories" class="menu"><li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li id="menu-item-107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter">
		<aside>
	
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no"></iframe><br><br>
	
<!-- first square unit -->
<div class="ad336x280">

<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

</div>
<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
<!-- end second square unit -->
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Firan Technology Group</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Firan Technology Group with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="OTCMKTS:FTGFF" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<a href="https://twitter.com/CFinancialNews" class="twitter-follow-button" data-show-count="false">Follow @CFinancialNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FCommunity-Financial-News-1775168779380432&amp;width=336&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true&amp;appId=229098600454584" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:336px; height:250px;" allowTransparency="true"></iframe>






<!-- start IMS -->
	
<div id="Com_Unik_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('Com_Unik_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- end IMS -->



<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Top Stories</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/silvermet-cvesyi-shares-up-4-3.html">Silvermet (CVE:SYI) Shares Up 4.3%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/maya-gold-silver-cvemya-shares-down-10-4.html">Maya Gold &#038; Silver (CVE:MYA)  Shares Down 10.4%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/firm-capital-american-realty-prtnrs-cvefca-shares-down-26-8.html">Firm Capital American Realty Prtnrs (CVE:FCA)  Shares Down 26.8%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/vantage-drilling-international-otcmktsvtggf-trading-5-6-higher.html">Vantage Drilling International (OTCMKTS:VTGGF) Trading 5.6% Higher</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/steuben-tr-co-h-sh-otcmktssbho-stock-price-down-1-6.html">STEUBEN TR CO H/SH (OTCMKTS:SBHO) Stock Price Down 1.6%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/canabo-medical-cvecmm-trading-%e2%88%9e-higher.html">Canabo Medical (CVE:CMM) Trading ∞ Higher</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/kuka-etrku2-stock-price-down-0-8.html">Kuka (ETR:KU2) Stock Price Down 0.8%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/firan-technology-group-otcmktsftgff-shares-down-7.html">Firan Technology Group (OTCMKTS:FTGFF)  Shares Down 7%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/canada-zinc-metals-cveczx-trading-%e2%88%9e-higher.html">Canada Zinc Metals (CVE:CZX) Trading ∞ Higher</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/presidio-bank-otcmktspdob-trading-1-6-higher.html">Presidio Bank (OTCMKTS:PDOB) Trading 1.6% Higher</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/investment-loninv-trading-down-2-2.html">Investment (LON:INV) Trading Down 2.2%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/eqtec-loneqt-trading-down-4-2.html">Eqtec (LON:EQT) Trading Down 4.2%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/otis-gold-cveooo-stock-price-up-8-7.html">Otis Gold (CVE:OOO) Stock Price Up 8.7%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/hemogenyx-pharmaceuticals-lonhemo-trading-0-7-higher.html">Hemogenyx Pharmaceuticals (LON:HEMO) Trading 0.7% Higher</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/cora-gold-loncora-trading-down-5-3.html">Cora Gold (LON:CORA) Trading Down 5.3%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/conwest-partn-p-ut-ltd-partn-int-otcmktscwps-trading-down-4-1.html">CONWEST PARTN P/UT LTD PARTN INT (OTCMKTS:CWPS) Trading Down 4.1%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/ctry-bk-hldg-co-sh-otcmktscyhc-trading-3-1-higher.html">CTRY BK HLDG CO/SH (OTCMKTS:CYHC) Trading 3.1% Higher</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/caribbean-investment-loncihl-shares-down-7-9.html">Caribbean Investment (LON:CIHL)  Shares Down 7.9%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/dowg-two-par-vtg-fpd-0-001-londp2f-stock-price-down-60-5.html">DOWG TWO/PAR VTG FPD 0.001 (LON:DP2F) Stock Price Down 60.5%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/09/29/f-m-bancorp-ohio-otcmktsfmoo-shares-up-13-6.html">F &#038; M BANCORP OHIO (OTCMKTS:FMOO) Shares Up 13.6%</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->

		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.com-unik.info/2020/09/29/firan-technology-group-otcmktsftgff-shares-down-7.html" />
				<h1 itemprop="headline" class="page-title">Firan Technology Group (OTCMKTS:FTGFF)  Shares Down 7%</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author"><a href="https://www.com-unik.info/author/eileen" title="Posts by Eileen French" rel="author">Eileen French</a></span> on <span itemprop="datePublished dateModified" content="2020-09-29T23:52:41+0000">Sep 29th, 2020</span>
				</p><!--end .postmeta-->
				
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg" alt="Firan Technology Group logo" title="Firan Technology Group logo" class="companylogo" />Firan Technology Group Corp. (OTCMKTS:FTGFF)&#8217;s share price dropped 7% on Tuesday . The stock traded as low as $1.20 and last traded at $1.20. Approximately 500 shares traded hands during mid-day trading, a decline of 69% from the average daily volume of 1,613 shares. The stock had previously closed at $1.29.</p>
<p>The company&#8217;s fifty day moving average is $1.21 and its two-hundred day moving average is $1.45. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Community Financial News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="OTCMKTS:FTGFF" />    <label for="InPostRegistrationEmail">Get <b>Firan Technology Group</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>Firan Technology Group (OTCMKTS:FTGFF) last posted its earnings results on Wednesday, July 8th. The company reported $0.06 earnings per share for the quarter. The company had revenue of $175.49 million during the quarter. </p>
<p>
		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no"></iframe>
                 </div>


                 <strong>About Firan Technology Group</strong> (<a href='https://www.marketbeat.com/stocks/OTCMKTS/FTGFF/'>OTCMKTS:FTGFF</a>)</p>
<p>Firan Technology Group Corporation manufactures and sells printed circuit boards and precision illuminated display systems. It operates in two segments, FTG Aerospace and FTG Circuits. It offers mil-spec and technology printed circuit boards, such as specialty substrates, flexible circuits, rigid flex circuits, surface finishes, solder mask, and other products for various market applications, including avionics, military, telecom, medical, advanced test and measurement, contract manufacturers, and power.</p>
<p>Recommended Story: <a href='https://www.marketbeat.com/currencies/'>Forex</a><!--ViewCount:ArticleHistoryID=62185232&PostDate=2020-9-29&type=h&id=1107073--><!--Keyword: Firan Technology Group,OTCMKTS:FTGFF,FTGFF,Industrial,Stocks,Technicals--></p>
			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Firan Technology Group Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Firan Technology Group and related companies with <a href="/daily-email-updates-basic/?symbol=OTCMKTS:FTGFF&c=Firan+Technology+Group" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="OTCMKTS:FTGFF" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.marketbeat.com/logos/generic-stocks.jpg" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png">
 						<meta itemprop="height" content="90">
					 </div>
					<meta itemprop="name" content="Community Financial News"/>
					<meta itemprop="url" content="https://com-unik.info" />
 				</div>
				<!-- end article metadata -->

			</article>

		

<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>
<!-- More on MarketBeat -->
<!-- IMS below post -->
		<div id="Com_Unik_ROS_BelowPost_1"></div><br><br>
<!-- end IMS below post -->	


			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.com-unik.info/2020/09/29/hemogenyx-pharmaceuticals-lonhemo-trading-0-7-higher.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Hemogenyx Pharmaceuticals (LON:HEMO) Trading 0.7% Higher</p></div></a>				<a href="https://www.com-unik.info/2020/09/29/maya-gold-silver-cvemya-shares-down-10-4.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>Maya Gold &#038; Silver (CVE:MYA)  Shares Down 10.4%</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Silvermet  Shares Up 4.3%" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/09/29/silvermet-cvesyi-shares-up-4-3.html" rel="bookmark">Silvermet  Shares Up 4.3%</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Maya Gold &#038; Silver   Shares Down 10.4%" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/09/29/maya-gold-silver-cvemya-shares-down-10-4.html" rel="bookmark">Maya Gold &#038; Silver   Shares Down 10.4%</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Firm Capital American Realty Prtnrs   Shares Down 26.8%" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/09/29/firm-capital-american-realty-prtnrs-cvefca-shares-down-26-8.html" rel="bookmark">Firm Capital American Realty Prtnrs   Shares Down 26.8%</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Vantage Drilling International  Trading 5.6% Higher" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/09/29/vantage-drilling-international-otcmktsvtggf-trading-5-6-higher.html" rel="bookmark">Vantage Drilling International  Trading 5.6% Higher</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="STEUBEN TR CO H/SH  Stock Price Down 1.6%" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/09/29/steuben-tr-co-h-sh-otcmktssbho-stock-price-down-1-6.html" rel="bookmark">STEUBEN TR CO H/SH  Stock Price Down 1.6%</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Canabo Medical  Trading ∞ Higher" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/09/29/canabo-medical-cvecmm-trading-%e2%88%9e-higher.html" rel="bookmark">Canabo Medical  Trading ∞ Higher</a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
				<h2 style="padding: 5px 0; border-bottom: solid 1px #ddd; margin: 10px 0 4px 0;">Comments</h2>
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	</div> 			<!-- end comments section --> 



<!-- second ad spot -->


<br>

	</main> <!-- end main -->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<div style="clear:both"></div>
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2013-2020 <a href="https://www.com-unik.info">Community Financial News</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/js/wp-embed.min.js&#038;ver=1579791688'></script>

<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of StatCounter Code for Com-Unik -->
<script type="text/javascript">
var sc_project=10928871; 
var sc_invisible=1; 
var sc_security="cc698371"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/10928871/0/cc698371/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Com-Unik -->

<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.com-unik.info/2020/09/29/firan-technology-group-otcmktsftgff-shares-down-7.html" target="_blank"><img src="https://www.com-unik.info//images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=Firan Technology Group $OTCMKTS:FTGFF  Shares Down 7% https://www.com-unik.info/2020/09/29/firan-technology-group-otcmktsftgff-shares-down-7.html" target="_blank"><img src="https://www.com-unik.info//images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.com-unik.info/2020/09/29/firan-technology-group-otcmktsftgff-shares-down-7.html" target="_blank"><img src="https://www.com-unik.info//images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=Firan Technology Group $OTCMKTS:FTGFF  Shares Down 7% https://www.com-unik.info/2020/09/29/firan-technology-group-otcmktsftgff-shares-down-7.html" target="_blank"><img src="https://www.com-unik.info/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.com-unik.info/2020/09/29/firan-technology-group-otcmktsftgff-shares-down-7.html&title=Firan Technology Group (OTCMKTS:FTGFF)  Shares Down 7%" target="_blank"><img src="https://www.com-unik.info//images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=62185232&PostDate=2020-9-29&type=h&id=1107073&domain=www.com-unik.info&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	</body>

</html>
