<!doctype html>
<html lang="en" style="display:block;min-width:1040px;">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="xqz76zmvfde7oisbofkg13kwkw4b67yf6bzn770iq7vzpcpjszundefy599v43fjk2m6zn9al-vxetd12no8tukobbk8y22lna705yov843ltiolagx5f7wj389vu-6c" />
<meta name="viewport" content="width=1040">
	
<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location};
var qva = '539382';var fan = '3739';var jwa = '116261';var geq = '-bup-ac';</script>

<link rel="stylesheet" type="text/css" href="https://www.com-unik.info/wp-content/themes/alambre-com-unik/style.css?v=12" media="screen" />
<link href="https://www.com-unik.info/feed" rel="alternate" title="Community Financial News RSS Feed" type="application/rss+xml" />
<link href="https://www.com-unik.info/feed/atom" rel="alternate" title="Community Financial News Atom Feed" type="application/atom+xml" />
<link href="https://www.com-unik.info/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css&#038;ver=1579791688' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.com-unik.info/wp-json/" /><link rel="alternate" type="application/json" href="https://www.com-unik.info/wp-json/wp/v2/posts/3422913" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.com-unik.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.com-unik.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Yext (NYSE:YEXT) Given Buy Rating at Oppenheimer' href='https://www.com-unik.info/2020/10/18/yext-nyseyext-given-buy-rating-at-oppenheimer.html' />
<link rel='next' title='Lenovo Group (OTCMKTS:LNVGY) Downgraded by Zacks Investment Research to &#8220;Hold&#8221;' href='https://www.com-unik.info/2020/10/18/lenovo-group-otcmktslnvgy-downgraded-by-zacks-investment-research-to-hold.html' />
<meta name="generator" content="WordPress 5.5.1" />
<link rel="canonical" href="https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html" />
<link rel='shortlink' href='https://www.com-unik.info/?p=3422913' />
<link rel="alternate" type="application/json+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F10%2F18%2Fhl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F10%2F18%2Fhl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html&#038;format=xml" />
<link rel="amphtml" href="https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html/amp" /><link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="32x32" />
<link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
<meta name="msapplication-TileImage" content="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
 
	
<!-- Start Meta Data -->

<title>HL Acquisitions (NASDAQ:LPRO) Raised to Buy at Zacks Investment Research - Community Financial News</title>


<meta name="description" content="Zacks Investment Research upgraded shares of HL Acquisitions (NASDAQ:LPRO) from a hold rating to a buy rating in a research report report published on Wednesday, Zacks.com reports. Zacks Investment Research currently has $30.00 price target on the stock. According to Zacks, &#8220;Open Lending LLC, through its flagship product, Lenders Protection, offers loan analytics, risk-based pricing, [&hellip;]" />
<meta name="author" content="Cynthia Vaughn">
<meta name="news_keywords" content="HL Acquisitions,NASDAQ:LPRO,LPRO,Finance,Upgrade,Zacks Investment Research" />
<meta name="keywords" content="HL Acquisitions,NASDAQ:LPRO,LPRO,Finance,Upgrade,Zacks Investment Research" />
<meta name="ticker" content="NASDAQ:LPRO" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@CFinancialNews" />
<meta name="twitter:title" content="HL Acquisitions (NASDAQ:LPRO) Raised to Buy at Zacks Investment Research"/>
<meta name="twitter:description" content="Zacks Investment Research upgraded shares of HL Acquisitions (NASDAQ:LPRO) from a hold rating to a buy rating in a research report report published on Wednesday, Zacks.com reports. Zacks Investment Research currently has $30.00 price target on the stock. According to Zacks, &#8220;Open Lending LLC, through its flagship product, Lenders Protection, offers loan analytics, risk-based pricing, [&hellip;]" />
<meta name="twitter:creator" content="@CFinancialNews" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/generic-stocks.jpg" />

<!-- Open Graph Data -->
<meta property="og:title" content="HL Acquisitions (NASDAQ:LPRO) Raised to Buy at Zacks Investment Research" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/generic-stocks.jpg" />
<meta property="og:description" content="Zacks Investment Research upgraded shares of HL Acquisitions (NASDAQ:LPRO) from a hold rating to a buy rating in a research report report published on Wednesday, Zacks.com reports. Zacks Investment Research currently has $30.00 price target on the stock. According to Zacks, &#8220;Open Lending LLC, through its flagship product, Lenders Protection, offers loan analytics, risk-based pricing, [&hellip;]" />
<meta property="og:site_name" content="Community Financial News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-10-18T02:56:51+0000" />
<meta property="article:modified_time" content="2020-10-18T02:56:51+0000" />
<meta property="article:tag" content="NASDAQ:LPRO" />
<meta property="article:tag" content="HL Acquisitions,NASDAQ:LPRO,LPRO,Finance,Upgrade,Zacks Investment Research" />
<meta property="article:section" content="Finance" />


<!-- End Meta Data -->

<script type='text/javascript'>var PopupAdChannel=''; </script>


 <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'com-unik.info';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e44ae816-df10-443c-9af6-8ac7ebff4880",
      safari_web_id: 'web.onesignal.auto.486fe890-0d3a-4b25-a01f-9ae2be714cd5',
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}
  </script>

<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
	
<!-- start ims header script -->
	<script type="text/javascript">
		var apntag = apntag || {};
		apntag.anq = apntag.anq || [];
		(function() {
			var d = document, e = d.createElement('script'), p = d.getElementsByTagName('head')[0];
			e.type = 'text/javascript';  e.async = true;
			e.src = '//acdn.adnxs.com/ast/ast.js';
			p.insertBefore(e, p.firstChild);
		})();

		
		apntag.anq.push(function() {
			apntag.setPageOpts({
				member: 6989
			});
		});

		apntag.anq.push(function() {

      		apntag.defineTag({
				tagId: 13226773,
				sizes: [[300,250]],
				keywords: {'position': ['RightRail_1']},
				targetId: 'Com_Unik_ROS_RightRail_1'
			});
					});

		apntag.anq.push(function() {
			apntag.loadTags();
		});
		</script>
	
	<script type="text/javascript">
(function() {
window.advBidxc = window.advBidxc || {};
window.advBidxc.startTime = new Date().getTime();
function loadScript(tagSrc) {
var scriptTag = document.createElement('script'),
placeTag = document.getElementsByTagName("script")[0];
scriptTag.type = 'text/javascript';
scriptTag.async = true;
scriptTag.src = tagSrc;
placeTag.parentNode.insertBefore(scriptTag, placeTag);
}
var mnSrc = '//hbx.media.net/bidexchange.js?cid=8CU2C156D&version=5.1' + '&dn=' +
window.location.hostname;
loadScript(mnSrc);
})();
</script>
	
<!-- end ims header script -->
	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
</head>

<body>


<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Community Financial News', 'com-unik.info', 'NASDAQ:LPRO', 'HL Acquisitions', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg');</script>
<!-- End MarketBeat Modern Popup -->
	


<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-nav" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>				<form id="searchform" action="https://www.com-unik.info/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding" style="height:110px"><!-- start: width-limiter with logo and space for alternate header unit -->
<div style="float:left;width:280px;">
		<a href="https://www.com-unik.info"><img id="logo" src="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png" alt="community financial news logo"></a>



</div>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" style='float:right;width:728px;height:90px;'>
<iframe src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no"></iframe>
	</div> 
<!-- End Header Unit-->

	</div> <!-- end: width-limiter with logo and space for alternate header unit -->



	<div id="menu">
		<div class="width-limiter">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-front-page-categories" class="menu"><li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li id="menu-item-107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter">
		<aside>
	
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no"></iframe><br><br>
	
<!-- first square unit -->
<div class="ad336x280">

<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

</div>
<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
<!-- end second square unit -->
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for HL Acquisitions</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for HL Acquisitions with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:LPRO" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<a href="https://twitter.com/CFinancialNews" class="twitter-follow-button" data-show-count="false">Follow @CFinancialNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FCommunity-Financial-News-1775168779380432&amp;width=336&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true&amp;appId=229098600454584" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:336px; height:250px;" allowTransparency="true"></iframe>






<!-- start IMS -->
	
<div id="Com_Unik_ROS_RightRail_1" class="text-center">
			<script type="text/javascript">
			apntag.anq.push(function() {
				apntag.showTag('Com_Unik_ROS_RightRail_1');
			});
			</script>
		</div>
<!-- end IMS -->



<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Top Stories</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/lmp-automotive-nasdaqlmpx-stock-rating-upgraded-by-bidaskclub.html">LMP Automotive (NASDAQ:LMPX) Stock Rating Upgraded by BidaskClub</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/bidaskclub-upgrades-merit-medical-systems-nasdaqmmsi-to-strong-buy.html">BidaskClub Upgrades Merit Medical Systems (NASDAQ:MMSI) to &#8220;Strong-Buy&#8221;</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/zacks-investment-research-upgrades-landmark-infrastructure-partners-nasdaqlmrk-to-hold.html">Zacks Investment Research Upgrades Landmark Infrastructure Partners (NASDAQ:LMRK) to Hold</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/lenovo-group-otcmktslnvgy-downgraded-by-zacks-investment-research-to-hold.html">Lenovo Group (OTCMKTS:LNVGY) Downgraded by Zacks Investment Research to &#8220;Hold&#8221;</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html">HL Acquisitions (NASDAQ:LPRO) Raised to Buy at Zacks Investment Research</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/yext-nyseyext-given-buy-rating-at-oppenheimer.html">Yext (NYSE:YEXT) Given Buy Rating at Oppenheimer</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/mazda-motor-otcmktsmzday-lifted-to-strong-buy-at-zacks-investment-research.html">Mazda Motor (OTCMKTS:MZDAY) Lifted to Strong-Buy at Zacks Investment Research</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/navidea-biopharmaceuticals-nyseamericannavb-raised-to-buy-at-zacks-investment-research.html">Navidea Biopharmaceuticals (NYSEAMERICAN:NAVB) Raised to &#8220;Buy&#8221; at Zacks Investment Research</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/american-eagle-outfitters-nyseaeo-upgraded-by-loop-capital-to-hold.html">American Eagle Outfitters (NYSE:AEO) Upgraded by Loop Capital to &#8220;Hold&#8221;</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/albemarle-nysealb-cut-to-underperform-at-royal-bank-of-canada.html">Albemarle (NYSE:ALB) Cut to &#8220;Underperform&#8221; at Royal Bank of Canada</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/wipro-nysewit-stock-rating-lowered-by-investec.html">Wipro (NYSE:WIT) Stock Rating Lowered by Investec</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/barclays-reaffirms-neutral-rating-for-asos-plc-asc-l-lonasc.html">Barclays Reaffirms &#8220;Neutral&#8221; Rating for ASOS Plc (ASC.L) (LON:ASC)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/keycorp-raises-altra-industrial-motion-nasdaqaimc-price-target-to-48-00.html">KeyCorp Raises Altra Industrial Motion (NASDAQ:AIMC) Price Target to $48.00</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/apples-aapl-buy-rating-reiterated-at-needham-company-llc.html">Apple&#8217;s (AAPL) Buy Rating Reiterated at Needham &#038; Company LLC</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/jpmorgan-chase-co-analysts-give-apple-nasdaqaapl-a-150-00-price-target.html">JPMorgan Chase &#038; Co. Analysts Give Apple (NASDAQ:AAPL) a $150.00 Price Target</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/apple-nasdaqaapl-price-target-raised-to-140-00.html">Apple (NASDAQ:AAPL) Price Target Raised to $140.00</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/jpmorgan-chase-co-analysts-give-vodafone-group-lonvod-a-gbx-190-price-target.html">JPMorgan Chase &#038; Co. Analysts Give Vodafone Group (LON:VOD) a GBX 190 Price Target</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/whitbread-lonwtb-price-target-raised-to-gbx-2350-at-deutsche-bank-aktiengesellschaft.html">Whitbread (LON:WTB) Price Target Raised to GBX 2,350 at Deutsche Bank Aktiengesellschaft</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/president-energys-ppc-house-stock-rating-reiterated-at-shore-capital.html">President Energy&#8217;s (PPC) &#8220;House Stock&#8221; Rating Reiterated at Shore Capital</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/10/18/apple-nasdaqaapl-price-target-raised-to-106-00-at-credit-suisse-group.html">Apple (NASDAQ:AAPL) Price Target Raised to $106.00 at Credit Suisse Group</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->

		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html" />
				<h1 itemprop="headline" class="page-title">HL Acquisitions (NASDAQ:LPRO) Raised to Buy at Zacks Investment Research</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author"><a href="https://www.com-unik.info/author/cynthia" title="Posts by Cynthia Vaughn" rel="author">Cynthia Vaughn</a></span> on <span itemprop="datePublished dateModified" content="2020-10-18T02:56:51+0000">Oct 18th, 2020</span>
				</p><!--end .postmeta-->
				
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					
					<p><a href='https://www.marketbeat.com/logos/generic-stocks.jpg'><img src='https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg' alt='HL Acquisitions Corp. logo' title='HL Acquisitions Corp. logo' class='companylogo size-full' /></a><a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> upgraded shares of <span style='font-weight:italic'>HL Acquisitions (NASDAQ:LPRO)</span> from a hold rating to a buy rating in a research report report published on Wednesday, <a href="http://www.zacks.com//" target="_blank" rel="noopener noreferrer">Zacks.com</a> reports. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1'>Zacks Investment Research</a> currently has $30.00 price target on the stock. </p>
<p>According to Zacks, &#8220;Open Lending LLC, through its flagship product, Lenders Protection, offers loan analytics, risk-based pricing, risk modeling and default insurance, ensuring profitable auto loan portfolios for financial institutions. Open Lending LLC, formerly known as Nebula Acquisition Corporation, is based in AUSTIN, Texas.   &#8220;</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Community Financial News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:LPRO" />    <label for="InPostRegistrationEmail">Get <b>HL Acquisitions</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>A number of other equities analysts also recently issued reports on the company. DA Davidson began coverage on HL Acquisitions in a research note on Wednesday, September 23rd. They set a buy rating and a $29.00 price target for the company. Northland Securities  reissued a buy rating and set a $20.00 target price on shares of HL Acquisitions in a research report on Tuesday, August 11th. Canaccord Genuity  reissued a buy rating on shares of HL Acquisitions in a research report on Monday, September 21st. <a style='font-weight:bold' href='http://www.americanconsumernews.net/scripts/click.aspx?ValuEngine=1&#038;Symbol=LPRO'>ValuEngine</a> raised shares of HL Acquisitions from a sell rating to a hold rating in a research report on Thursday, October 1st. Finally, Deutsche Bank Aktiengesellschaft lifted their target price on shares of HL Acquisitions from $23.00 to $32.00 and gave the stock a buy rating in a research report on Friday, October 2nd. Two equities research analysts have rated the stock with a hold rating and eight have given a buy rating to the company&#8217;s stock. The stock presently has a consensus rating of Buy and a consensus target price of $27.50.</p>
<p>
		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no"></iframe>
                 </div>


                 <a href='https://www.analystratings.net/NASDAQ/LPRO/' target='_blank' rel="noopener noreferrer">LPRO stock</a> opened at $27.51 on Wednesday. HL Acquisitions has a 52-week low of $12.70 and a 52-week high of $28.50. The company&#8217;s 50-day moving average is $23.63. </p>
<p>HL Acquisitions (NASDAQ:LPRO) last released its quarterly earnings results on Tuesday, August 11th. The company reported ($0.03) earnings per share (EPS) for the quarter, missing analysts&#8217; consensus estimates of $0.07 by ($0.10). The business had revenue of $22.07 million during the quarter, compared to analyst estimates of $19.40 million.  Equities research analysts expect that  HL Acquisitions will post -0.1 earnings per share for the current fiscal year. </p>
<p><strong>About HL Acquisitions</strong></p>
<p>Open Lending Corporation provides lending enablement and risk analytics to credit unions, regional banks, and captive finance companies in the United States. It offers Lenders Protection Program, an auto lending enablement platform that allows financial institutions and other auto lenders to model their specific overhead and funding costs, as well as set desired ROA target for their insured portfolio; and features default insurance coverage for near-prime and non-prime automobile loans.</p>
<p>Read More: <a href='https://www.marketbeat.com/financial-terms/what-is-the-float-trading-stocks/'>How can you know how many shares are floating?</a><!--ViewCount:ArticleHistoryID=63301087&PostDate=2020-10-18&type=a&quinary=1&id=1489986--></p>
<p><a href="https://www.zacks.com/registration/pfp/?ALERT=ZER_LINK&#038;ADID=AMERBMN_CONTENT_ZER&#038;skip_rpt_name_check=skip_rpt_name_check&#038;t=LPRO">Get a free copy of the Zacks research report on HL Acquisitions (LPRO)</a></p>
<p>For more information about research offerings from Zacks Investment Research, visit <a href="http://www.americanconsumernews.net/scripts/click.aspx?Zacks=1">Zacks.com</a></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/RatingsChart.ashx?Prefix=NASDAQ&#038;Symbol=LPRO' alt='Analyst Recommendations for HL Acquisitions (NASDAQ:LPRO)' title='Analyst Recommendations for HL Acquisitions (NASDAQ:LPRO)' /></p>
<p><!--Keyword: HL Acquisitions,NASDAQ:LPRO,LPRO,Finance,Upgrade,Zacks Investment Research--><!--Ratings:4,7,NASDAQ:LPRO--></p>
			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for HL Acquisitions Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for HL Acquisitions and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:LPRO&c=HL+Acquisitions" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:LPRO" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.marketbeat.com/logos/generic-stocks.jpg" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png">
 						<meta itemprop="height" content="90">
					 </div>
					<meta itemprop="name" content="Community Financial News"/>
					<meta itemprop="url" content="https://com-unik.info" />
 				</div>
				<!-- end article metadata -->

			</article>

		

<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>
<!-- More on MarketBeat -->
<!-- IMS below post -->
		<div id="Com_Unik_ROS_BelowPost_1"></div><br><br>
<!-- end IMS below post -->	


			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.com-unik.info/2020/10/18/yext-nyseyext-given-buy-rating-at-oppenheimer.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Yext (NYSE:YEXT) Given Buy Rating at Oppenheimer</p></div></a>				<a href="https://www.com-unik.info/2020/10/18/lenovo-group-otcmktslnvgy-downgraded-by-zacks-investment-research-to-hold.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>Lenovo Group (OTCMKTS:LNVGY) Downgraded by Zacks Investment Research to &#8220;Hold&#8221;</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="LMP Automotive  Stock Rating Upgraded by BidaskClub" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/10/18/lmp-automotive-nasdaqlmpx-stock-rating-upgraded-by-bidaskclub.html" rel="bookmark">LMP Automotive  Stock Rating Upgraded by BidaskClub</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/merit-medical-systems-inc-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="BidaskClub Upgrades Merit Medical Systems  to &#8220;Strong-Buy&#8221;" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/10/18/bidaskclub-upgrades-merit-medical-systems-nasdaqmmsi-to-strong-buy.html" rel="bookmark">BidaskClub Upgrades Merit Medical Systems  to &#8220;Strong-Buy&#8221;</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/landmark-infrastructure-partners-lp-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Zacks Investment Research Upgrades Landmark Infrastructure Partners  to Hold" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/10/18/zacks-investment-research-upgrades-landmark-infrastructure-partners-nasdaqlmrk-to-hold.html" rel="bookmark">Zacks Investment Research Upgrades Landmark Infrastructure Partners  to Hold</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/lenovo-group-limited-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Lenovo Group  Downgraded by Zacks Investment Research to &#8220;Hold&#8221;" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/10/18/lenovo-group-otcmktslnvgy-downgraded-by-zacks-investment-research-to-hold.html" rel="bookmark">Lenovo Group  Downgraded by Zacks Investment Research to &#8220;Hold&#8221;</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="HL Acquisitions  Raised to Buy at Zacks Investment Research" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html" rel="bookmark">HL Acquisitions  Raised to Buy at Zacks Investment Research</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/yext-inc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Yext  Given Buy Rating at Oppenheimer" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/10/18/yext-nyseyext-given-buy-rating-at-oppenheimer.html" rel="bookmark">Yext  Given Buy Rating at Oppenheimer</a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
				<h2 style="padding: 5px 0; border-bottom: solid 1px #ddd; margin: 10px 0 4px 0;">Comments</h2>
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	</div> 			<!-- end comments section --> 



<!-- second ad spot -->


<br>

	</main> <!-- end main -->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<div style="clear:both"></div>
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2013-2020 <a href="https://www.com-unik.info">Community Financial News</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/js/wp-embed.min.js&#038;ver=1579791688'></script>

<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of StatCounter Code for Com-Unik -->
<script type="text/javascript">
var sc_project=10928871; 
var sc_invisible=1; 
var sc_security="cc698371"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/10928871/0/cc698371/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Com-Unik -->

<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html" target="_blank"><img src="https://www.com-unik.info//images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=HL Acquisitions $NASDAQ:LPRO Raised to Buy at Zacks Investment Research https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html" target="_blank"><img src="https://www.com-unik.info//images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html" target="_blank"><img src="https://www.com-unik.info//images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=HL Acquisitions $NASDAQ:LPRO Raised to Buy at Zacks Investment Research https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html" target="_blank"><img src="https://www.com-unik.info/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.com-unik.info/2020/10/18/hl-acquisitions-nasdaqlpro-raised-to-buy-at-zacks-investment-research.html&title=HL Acquisitions (NASDAQ:LPRO) Raised to Buy at Zacks Investment Research" target="_blank"><img src="https://www.com-unik.info//images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=63301087&PostDate=2020-10-18&type=a&quinary=1&id=1489986&domain=www.com-unik.info&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	</body>

</html>
