<!doctype html>
<html lang="en" style="display:block;min-width:1040px;">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="xqz76zmvfde7oisbofkg13kwkw4b67yf6bzn770iq7vzpcpjszundefy599v43fjk2m6zn9al-vxetd12no8tukobbk8y22lna705yov843ltiolagx5f7wj389vu-6c" />
<meta name="viewport" content="width=1040">
	
<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location};
var qva = '539382';var fan = '3739';var jwa = '116261';var geq = '-bup-ac';</script>

<link rel="stylesheet" type="text/css" href="https://www.com-unik.info/wp-content/themes/alambre-com-unik/style.css?v=12" media="screen" />
<link href="https://www.com-unik.info/feed" rel="alternate" title="Community Financial News RSS Feed" type="application/rss+xml" />
<link href="https://www.com-unik.info/feed/atom" rel="alternate" title="Community Financial News Atom Feed" type="application/atom+xml" />
<link href="https://www.com-unik.info/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css&#038;ver=1606755730' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.com-unik.info/wp-json/" /><link rel="alternate" type="application/json" href="https://www.com-unik.info/wp-json/wp/v2/posts/3692388" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.com-unik.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.com-unik.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Lantronix, Inc. (NASDAQ:LTRX) Receives Consensus Rating of &#8220;Buy&#8221; from Analysts' href='https://www.com-unik.info/2020/12/29/lantronix-inc-nasdaqltrx-receives-consensus-rating-of-buy-from-analysts.html' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel="canonical" href="https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html" />
<link rel='shortlink' href='https://www.com-unik.info/?p=3692388' />
<link rel="alternate" type="application/json+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F12%2F29%2Fpurple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2020%2F12%2F29%2Fpurple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html&#038;format=xml" />
<link rel="amphtml" href="https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html/amp" /><link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="32x32" />
<link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
<meta name="msapplication-TileImage" content="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
 
	
<!-- Start Meta Data -->

<title>Purple Innovation, Inc. (NASDAQ:PRPL) Given Average Recommendation of &#8220;Buy&#8221; by Brokerages - Community Financial News</title>


<meta name="description" content="Purple Innovation, Inc. (NASDAQ:PRPL) has earned an average rating of &#8220;Buy&#8221; from the fourteen brokerages that are presently covering the company, MarketBeat.com reports. One analyst has rated the stock with a sell recommendation, one has assigned a hold recommendation and eleven have assigned a buy recommendation to the company. The average 1 year price target [&hellip;]" />
<meta name="author" content="Cynthia Vaughn">
<meta name="news_keywords" content="Purple Innovation,NASDAQ:PRPL,PRPL,Consumer Staple,Ratings,Consensus" />
<meta name="keywords" content="Purple Innovation,NASDAQ:PRPL,PRPL,Consumer Staple,Ratings,Consensus" />
<meta name="ticker" content="NASDAQ:PRPL" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@CFinancialNews" />
<meta name="twitter:title" content="Purple Innovation, Inc. (NASDAQ:PRPL) Given Average Recommendation of &#8220;Buy&#8221; by Brokerages"/>
<meta name="twitter:description" content="Purple Innovation, Inc. (NASDAQ:PRPL) has earned an average rating of &#8220;Buy&#8221; from the fourteen brokerages that are presently covering the company, MarketBeat.com reports. One analyst has rated the stock with a sell recommendation, one has assigned a hold recommendation and eleven have assigned a buy recommendation to the company. The average 1 year price target [&hellip;]" />
<meta name="twitter:creator" content="@CFinancialNews" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/purple-innovation-inc-logo.png" />

<!-- Open Graph Data -->
<meta property="og:title" content="Purple Innovation, Inc. (NASDAQ:PRPL) Given Average Recommendation of &#8220;Buy&#8221; by Brokerages" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/purple-innovation-inc-logo.png" />
<meta property="og:description" content="Purple Innovation, Inc. (NASDAQ:PRPL) has earned an average rating of &#8220;Buy&#8221; from the fourteen brokerages that are presently covering the company, MarketBeat.com reports. One analyst has rated the stock with a sell recommendation, one has assigned a hold recommendation and eleven have assigned a buy recommendation to the company. The average 1 year price target [&hellip;]" />
<meta property="og:site_name" content="Community Financial News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2020-12-29T04:44:44+0000" />
<meta property="article:modified_time" content="2020-12-29T04:44:44+0000" />
<meta property="article:tag" content="NASDAQ:PRPL" />
<meta property="article:tag" content="Purple Innovation,NASDAQ:PRPL,PRPL,Consumer Staple,Ratings,Consensus" />
<meta property="article:section" content="Finance" />


<!-- End Meta Data -->

<script type='text/javascript'>var PopupAdChannel=''; </script>


 <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'com-unik.info';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e44ae816-df10-443c-9af6-8ac7ebff4880",
      safari_web_id: 'web.onesignal.auto.486fe890-0d3a-4b25-a01f-9ae2be714cd5',
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}
  </script>

<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
</head>

<body>


<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Community Financial News', 'com-unik.info', 'NASDAQ:PRPL', 'Purple Innovation', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/purple-innovation-inc-logo.png');</script>
<!-- End MarketBeat Modern Popup -->
	


<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-nav" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>				<form id="searchform" action="https://www.com-unik.info/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding" style="height:110px"><!-- start: width-limiter with logo and space for alternate header unit -->
<div style="float:left;width:280px;">
		<a href="https://www.com-unik.info"><img id="logo" src="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png" alt="community financial news logo"></a>



</div>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" style='float:right;width:728px;height:90px;'>
<iframe src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no"></iframe>
	</div> 
<!-- End Header Unit-->

	</div> <!-- end: width-limiter with logo and space for alternate header unit -->



	<div id="menu">
		<div class="width-limiter">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-front-page-categories" class="menu"><li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li id="menu-item-107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter">
		<aside>
	
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no"></iframe><br><br>
	
<!-- first square unit -->
<div class="ad336x280">

<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

</div>
<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
<!-- end second square unit -->
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Purple Innovation</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Purple Innovation with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:PRPL" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<a href="https://twitter.com/CFinancialNews" class="twitter-follow-button" data-show-count="false">Follow @CFinancialNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FCommunity-Financial-News-1775168779380432&amp;width=336&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true&amp;appId=229098600454584" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:336px; height:250px;" allowTransparency="true"></iframe>



<!-- sidebar unit position -->



<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Top Stories</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html">Purple Innovation, Inc. (NASDAQ:PRPL) Given Average Recommendation of &#8220;Buy&#8221; by Brokerages</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/lantronix-inc-nasdaqltrx-receives-consensus-rating-of-buy-from-analysts.html">Lantronix, Inc. (NASDAQ:LTRX) Receives Consensus Rating of &#8220;Buy&#8221; from Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/the-trade-desk-inc-nasdaqttd-ceo-jeffrey-terry-green-sells-928-shares.html">The Trade Desk, Inc. (NASDAQ:TTD) CEO Jeffrey Terry Green Sells 928 Shares</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/strs-ohio-has-490000-holdings-in-luminex-co-nasdaqlmnx.html">Strs Ohio Has $490,000 Holdings in Luminex Co. (NASDAQ:LMNX)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/sqi-diagnostics-otcmktssqidf-stock-price-passes-below-50-day-moving-average-of-0-19.html">SQI Diagnostics (OTCMKTS:SQIDF) Stock Price Passes Below 50 Day Moving Average of $0.19</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/huttig-building-products-nasdaqhbp-shares-pass-below-50-day-moving-average-of-3-66.html">Huttig Building Products (NASDAQ:HBP) Shares Pass Below 50 Day Moving Average of $3.66</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/drax-group-plc-drx-l-londrx-reaches-new-52-week-high-at-385-20.html">Drax Group plc (DRX.L) (LON:DRX) Reaches New 52-Week High at $385.20</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/evraz-plc-evr-l-lonevr-reaches-new-52-week-high-at-489-60.html">EVRAZ plc (EVR.L) (LON:EVR) Reaches New 52-Week High at $489.60</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/puretech-health-lonprtc-sets-new-52-week-high-at-447-66.html">PureTech Health (LON:PRTC) Sets New 52-Week High at $447.66</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/aqr-capital-management-llc-decreases-stock-position-in-duluth-holdings-inc-nasdaqdlth.html">AQR Capital Management LLC Decreases Stock Position in Duluth Holdings Inc (NASDAQ:DLTH)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/schonfeld-strategic-advisors-llc-buys-shares-of-11400-m-d-c-holdings-inc-nysemdc.html">Schonfeld Strategic Advisors LLC Buys Shares of 11,400 M.D.C. Holdings, Inc. (NYSE:MDC)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/51000-shares-in-sutro-biopharma-inc-nasdaqstro-purchased-by-schonfeld-strategic-advisors-llc.html">51,000 Shares in Sutro Biopharma, Inc. (NASDAQ:STRO) Purchased by Schonfeld Strategic Advisors LLC</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/v-gordon-clemons-sells-1200-shares-of-corvel-co-nasdaqcrvl-stock.html">V Gordon Clemons Sells 1,200 Shares of CorVel Co. (NASDAQ:CRVL) Stock</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/limoneira-nasdaqlmnr-ceo-harold-s-edwards-sells-9000-shares-of-stock.html">Limoneira (NASDAQ:LMNR) CEO Harold S. Edwards Sells 9,000 Shares of Stock</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/fortuna-silver-mines-inc-nysefsm-given-average-recommendation-of-buy-by-analysts.html">Fortuna Silver Mines Inc. (NYSE:FSM) Given Average Recommendation of &#8220;Buy&#8221; by Analysts</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/insider-selling-royce-global-value-trust-inc-nysergt-major-shareholder-sells-16866-shares-of-stock.html">Insider Selling: Royce Global Value Trust, Inc. (NYSE:RGT) Major Shareholder Sells 16,866 Shares of Stock</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/apple-inc-nasdaqaapl-stake-raised-by-rehmann-capital-advisory-group.html">Apple Inc. (NASDAQ:AAPL) Stake Raised by Rehmann Capital Advisory Group</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/paloma-partners-management-co-increases-position-in-entercom-communications-corp-nyseetm.html">Paloma Partners Management Co Increases Position in Entercom Communications Corp. (NYSE:ETM)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/lantheus-holdings-inc-nasdaqlnth-shares-bought-by-california-state-teachers-retirement-system.html">Lantheus Holdings, Inc. (NASDAQ:LNTH) Shares Bought by California State Teachers Retirement System</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2020/12/29/ardelyx-inc-nasdaqardx-shares-sold-by-california-state-teachers-retirement-system.html">Ardelyx, Inc. (NASDAQ:ARDX) Shares Sold by California State Teachers Retirement System</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->

		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html" />
				<h1 itemprop="headline" class="page-title">Purple Innovation, Inc. (NASDAQ:PRPL) Given Average Recommendation of &#8220;Buy&#8221; by Brokerages</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author"><a href="https://www.com-unik.info/author/cynthia" title="Posts by Cynthia Vaughn" rel="author">Cynthia Vaughn</a></span> on <span itemprop="datePublished dateModified" content="2020-12-29T04:44:44+0000">Dec 29th, 2020</span>
				</p><!--end .postmeta-->
				
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					<iframe src="https://www.marketbeat.com/scripts/TextAdNewsSites.ashx?color=bc4342" frameborder=no width="100%" height="35" scrolling="no"></iframe>
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/purple-innovation-inc-logo.png" alt="Purple Innovation logo" title="Purple Innovation logo" class="companylogo" />Purple Innovation, Inc. (NASDAQ:PRPL) has earned an average rating of &#8220;Buy&#8221; from the fourteen brokerages that are presently  covering the company, <a href='https://www.marketbeat.com/'>MarketBeat.com</a> reports. One analyst  has rated the stock with a sell recommendation, one  has assigned  a hold recommendation and eleven have assigned  a buy recommendation to  the company. The average 1 year price target among brokers that have issued a report on the stock in the last year is $34.33. </p>
<p>A number of equities research analysts have recently weighed in on the company. Oppenheimer assumed coverage on Purple Innovation in a research note on Wednesday, November 18th. They set a &#8220;buy&#8221; rating and a $37.00 price target on the stock. BidaskClub upgraded Purple Innovation from a &#8220;hold&#8221; rating to a &#8220;buy&#8221; rating in a research note on Tuesday, December 22nd. Raymond James boosted their price target on Purple Innovation from $28.00 to $36.00 and gave the stock an &#8220;outperform&#8221; rating in a research note on Monday, October 26th. Roth Capital boosted their price target on Purple Innovation from $27.00 to $32.00 and gave the stock a &#8220;buy&#8221; rating in a research note on Thursday, November 12th. Finally, KeyCorp boosted their price target on Purple Innovation from $26.00 to $34.00 and gave the stock an &#8220;overweight&#8221; rating in a research note on Tuesday, November 10th.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Community Financial News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:PRPL" />    <label for="InPostRegistrationEmail">Get <b>Purple Innovation</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p><a href='https://www.analystratings.net/NASDAQ/PRPL/' target='_blank' rel="noopener noreferrer">PRPL</a> opened at $33.12 on Tuesday. The business&#8217;s 50-day moving average is $29.11 and its two-hundred day moving average is $24.30. Purple Innovation has a 1 year low of $4.42 and a 1 year high of $36.18. The company has a debt-to-equity ratio of 2.19, a current ratio of 1.45 and a quick ratio of 1.10. The firm has a market capitalization of $2.04 billion, a PE ratio of -254.77, a price-to-earnings-growth ratio of 5.19 and a beta of 1.51. </p>
<p>
		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no"></iframe>
                 </div>


                 Purple Innovation (NASDAQ:PRPL) last posted its earnings results on Saturday, November 14th. The company reported $0.27 earnings per share (EPS) for the quarter, beating the consensus estimate of $0.24 by $0.03. Purple Innovation had a return on equity of 545.13% and a net margin of 0.81%. The company had revenue of $187.11 million for the quarter, compared to analyst estimates of $175.40 million. The company&#8217;s revenue for the quarter was up 59.4% compared to the same quarter last year.  As a group, sell-side analysts expect that  Purple Innovation will post 0.41 EPS for the current year. </p>
<p>In related news, insider Verdi Ray White III sold 10,000 shares of Purple Innovation stock in a transaction dated Tuesday, November 17th. The stock was sold at an average price of $28.51, for a total transaction of $285,100.00. Following the completion of the sale, the insider now owns 10,000 shares of the company&#8217;s stock, valued at $285,100. The transaction was disclosed in a filing with the Securities &amp; Exchange Commission, which is available at <a href='http://www.sec.gov/Archives/edgar/data/1643953/000121390020038137/xslF345X03/ownership.xml' target='_blank' rel="noopener noreferrer">the SEC website</a>. Also, COO John A. Legg sold 25,000 shares of the business&#8217;s stock in a transaction that occurred on Wednesday, September 30th. The shares were sold at an average price of $22.72, for a total value of $568,000.00. Following the completion of the transaction, the chief operating officer now directly owns 17,980 shares of the company&#8217;s stock, valued at $408,505.60. The disclosure for this sale can be found <a href='http://www.sec.gov/Archives/edgar/data/1529244/000121390020029333/xslF345X03/ownership.xml' target='_blank' rel="noopener noreferrer">here</a>. Insiders have sold 35,248 shares of company stock valued at $860,292 in the last ninety days. Corporate insiders own  75.10% of the company&#8217;s stock. </p>
<p>Large investors have recently made changes to their positions in the business. The Manufacturers Life Insurance Company acquired a new position in  Purple Innovation in the third quarter valued at approximately $318,000.  Marshall Wace North America L.P. acquired a new position in  Purple Innovation in the second quarter valued at approximately $3,716,000.  Bank of America Corp DE lifted its holdings in  Purple Innovation by 3,192.2% in the second quarter. Bank of America Corp DE now owns 165,698 shares of the company&#8217;s stock valued at $2,983,000 after acquiring an additional 160,665 shares during the period.  Point72 Hong Kong Ltd acquired a new position in  Purple Innovation in the third quarter valued at approximately $38,000.  Finally, Russell Investments Group Ltd. acquired a new position in  Purple Innovation in the second quarter valued at approximately $1,813,000. 64.45% of the stock is owned by institutional investors. </p>
<p><strong>About Purple Innovation</strong></p>
<p>Purple Innovation, Inc designs and manufactures mattresses, pillows, and cushions. It also offers sheets, mattress protector, bed frames, seat cushions, and weighted blanket and duvets. The company markets and sells its products through direct-to-consumer online channels, retail brick-and-mortar wholesale partners, and third-party online retailers, as well as through its factory outlet and the company owned showrooms.</p>
<p>Featured Story: <a href='https://www.marketbeat.com/financial-terms/what-is-a-management-fee/'>What is a management fee?</a><!--ViewCount:ArticleHistoryID=67475209&PostDate=2020-12-29&type=c&id=1017946--><!--Keyword: Purple Innovation,NASDAQ:PRPL,PRPL,Consumer Staple,Ratings,Consensus--><!--Ratings:4,10,NASDAQ:PRPL--></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/RatingsChart.ashx?Prefix=NASDAQ&#038;Symbol=PRPL' alt='Analyst Recommendations for Purple Innovation (NASDAQ:PRPL)' title='Analyst Recommendations for Purple Innovation (NASDAQ:PRPL)' /></p>
			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Purple Innovation Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Purple Innovation and related companies with <a href="/daily-email-updates-basic/?symbol=NASDAQ:PRPL&c=Purple+Innovation" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NASDAQ:PRPL" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.marketbeat.com/logos/purple-innovation-inc-logo.png" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png">
 						<meta itemprop="height" content="90">
					 </div>
					<meta itemprop="name" content="Community Financial News"/>
					<meta itemprop="url" content="https://com-unik.info" />
 				</div>
				<!-- end article metadata -->

			</article>

		

<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>
<!-- More on MarketBeat -->

		<!--  below post unit position -->
		


			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.com-unik.info/2020/12/29/lantronix-inc-nasdaqltrx-receives-consensus-rating-of-buy-from-analysts.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Lantronix, Inc. (NASDAQ:LTRX) Receives Consensus Rating of &#8220;Buy&#8221; from Analysts</p></div></a>							
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/purple-innovation-inc-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Purple Innovation, Inc.  Given Average Recommendation of &#8220;Buy&#8221; by Brokerages" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html" rel="bookmark">Purple Innovation, Inc.  Given Average Recommendation of &#8220;Buy&#8221; by Brokerages</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/lantronix-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Lantronix, Inc.  Receives Consensus Rating of &#8220;Buy&#8221; from Analysts" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/12/29/lantronix-inc-nasdaqltrx-receives-consensus-rating-of-buy-from-analysts.html" rel="bookmark">Lantronix, Inc.  Receives Consensus Rating of &#8220;Buy&#8221; from Analysts</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/trade-desk-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="The Trade Desk, Inc.  CEO Jeffrey Terry Green Sells 928 Shares" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/12/29/the-trade-desk-inc-nasdaqttd-ceo-jeffrey-terry-green-sells-928-shares.html" rel="bookmark">The Trade Desk, Inc.  CEO Jeffrey Terry Green Sells 928 Shares</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/luminex-logo.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Strs Ohio Has $490,000 Holdings in Luminex Co. " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/12/29/strs-ohio-has-490000-holdings-in-luminex-co-nasdaqlmnx.html" rel="bookmark">Strs Ohio Has $490,000 Holdings in Luminex Co. </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="SQI Diagnostics  Stock Price Passes Below 50 Day Moving Average of $0.19" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/12/29/sqi-diagnostics-otcmktssqidf-stock-price-passes-below-50-day-moving-average-of-0-19.html" rel="bookmark">SQI Diagnostics  Stock Price Passes Below 50 Day Moving Average of $0.19</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Huttig Building Products  Shares Pass Below 50 Day Moving Average of $3.66" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2020/12/29/huttig-building-products-nasdaqhbp-shares-pass-below-50-day-moving-average-of-3-66.html" rel="bookmark">Huttig Building Products  Shares Pass Below 50 Day Moving Average of $3.66</a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
				<h2 style="padding: 5px 0; border-bottom: solid 1px #ddd; margin: 10px 0 4px 0;">Comments</h2>
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	</div> 			<!-- end comments section --> 



<!-- second ad spot -->


<br>

	</main> <!-- end main -->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<div style="clear:both"></div>
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2013-2020 <a href="https://www.com-unik.info">Community Financial News</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/js/wp-embed.min.js&#038;ver=1606755730'></script>

<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of StatCounter Code for Com-Unik -->
<script type="text/javascript">
var sc_project=10928871; 
var sc_invisible=1; 
var sc_security="cc698371"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/10928871/0/cc698371/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Com-Unik -->

<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html" target="_blank"><img src="https://www.com-unik.info//images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=Purple Innovation, Inc. $NASDAQ:PRPL Given Average Recommendation of &#8220;Buy&#8221; by Brokerages https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html" target="_blank"><img src="https://www.com-unik.info//images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html" target="_blank"><img src="https://www.com-unik.info//images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=Purple Innovation, Inc. $NASDAQ:PRPL Given Average Recommendation of &#8220;Buy&#8221; by Brokerages https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html" target="_blank"><img src="https://www.com-unik.info/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.com-unik.info/2020/12/29/purple-innovation-inc-nasdaqprpl-given-average-recommendation-of-buy-by-brokerages.html&title=Purple Innovation, Inc. (NASDAQ:PRPL) Given Average Recommendation of &#8220;Buy&#8221; by Brokerages" target="_blank"><img src="https://www.com-unik.info//images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/viewcount.ashx?ArticleHistoryID=67475209&PostDate=2020-12-29&type=c&id=1017946&domain=www.com-unik.info&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	</body>

</html>
