<!doctype html>
<html lang="en" style="display:block;min-width:1040px;">

<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
<meta name="msvalidate.01" content="8D3F505D642C99EB26E45507554512BC" />
<meta name="norton-safeweb-site-verification" content="xqz76zmvfde7oisbofkg13kwkw4b67yf6bzn770iq7vzpcpjszundefy599v43fjk2m6zn9al-vxetd12no8tukobbk8y22lna705yov843ltiolagx5f7wj389vu-6c" />
<meta name="viewport" content="width=1040">
	
<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location};
var qva = '539382';var fan = '3739';var jwa = '116261';var geq = '-bup-ac';</script>

<link rel="stylesheet" type="text/css" href="https://www.com-unik.info/wp-content/themes/alambre-com-unik/style.css?v=12" media="screen" />
<link href="https://www.com-unik.info/feed" rel="alternate" title="Community Financial News RSS Feed" type="application/rss+xml" />
<link href="https://www.com-unik.info/feed/atom" rel="alternate" title="Community Financial News Atom Feed" type="application/atom+xml" />
<link href="https://www.com-unik.info/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css&#038;ver=1606755730' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.com-unik.info/wp-json/" /><link rel="alternate" type="application/json" href="https://www.com-unik.info/wp-json/wp/v2/posts/3769841" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.com-unik.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.com-unik.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Rockfire Resources (LON:ROCK)  Shares Down 4.8%' href='https://www.com-unik.info/2021/02/21/rockfire-resources-lonrock-shares-down-4-8.html' />
<link rel='next' title='IMA Wealth Inc. Has $2.71 Million Holdings in iShares MSCI EAFE Min Vol Factor ETF (BATS:EFAV)' href='https://www.com-unik.info/2021/02/21/ima-wealth-inc-has-2-71-million-holdings-in-ishares-msci-eafe-min-vol-factor-etf-batsefav.html' />
<meta name="generator" content="WordPress 5.5.3" />
<link rel="canonical" href="https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html" />
<link rel='shortlink' href='https://www.com-unik.info/?p=3769841' />
<link rel="alternate" type="application/json+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2021%2F02%2F21%2Fseelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2021%2F02%2F21%2Fseelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html&#038;format=xml" />
<link rel="amphtml" href="https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html/amp" /><link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="32x32" />
<link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
<meta name="msapplication-TileImage" content="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
 
	
<!-- Start Meta Data -->

<title>Seelaus Asset Management LLC Raises Stock Position in Citigroup Inc. (NYSE:C) - Community Financial News</title>


<meta name="description" content="Seelaus Asset Management LLC boosted its holdings in Citigroup Inc. (NYSE:C) by 4.6% in the fourth quarter, HoldingsChannel reports. The institutional investor owned 8,265 shares of the company&#8217;s stock after purchasing an additional 362 shares during the quarter. Seelaus Asset Management LLC&#8217;s holdings in Citigroup were worth $510,000 at the end of the most recent [&hellip;]" />
<meta name="author" content="Cynthia Vaughn">
<meta name="news_keywords" content="Citigroup,NYSE:C,C,Finance,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="keywords" content="Citigroup,NYSE:C,C,Finance,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="ticker" content="NYSE:C" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@CFinancialNews" />
<meta name="twitter:title" content="Seelaus Asset Management LLC Raises Stock Position in Citigroup Inc. (NYSE:C)"/>
<meta name="twitter:description" content="Seelaus Asset Management LLC boosted its holdings in Citigroup Inc. (NYSE:C) by 4.6% in the fourth quarter, HoldingsChannel reports. The institutional investor owned 8,265 shares of the company&#8217;s stock after purchasing an additional 362 shares during the quarter. Seelaus Asset Management LLC&#8217;s holdings in Citigroup were worth $510,000 at the end of the most recent [&hellip;]" />
<meta name="twitter:creator" content="@CFinancialNews" />
<meta name="twitter:image" content="https://www.marketbeat.com/logos/generic-stocks.jpg" />

<!-- Open Graph Data -->
<meta property="og:title" content="Seelaus Asset Management LLC Raises Stock Position in Citigroup Inc. (NYSE:C)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html" />
<meta property="og:image" content="https://www.marketbeat.com/logos/generic-stocks.jpg" />
<meta property="og:description" content="Seelaus Asset Management LLC boosted its holdings in Citigroup Inc. (NYSE:C) by 4.6% in the fourth quarter, HoldingsChannel reports. The institutional investor owned 8,265 shares of the company&#8217;s stock after purchasing an additional 362 shares during the quarter. Seelaus Asset Management LLC&#8217;s holdings in Citigroup were worth $510,000 at the end of the most recent [&hellip;]" />
<meta property="og:site_name" content="Community Financial News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2021-02-21T09:21:14+0000" />
<meta property="article:modified_time" content="2021-02-21T09:21:14+0000" />
<meta property="article:tag" content="NYSE:C" />
<meta property="article:tag" content="Citigroup,NYSE:C,C,Finance,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta property="article:section" content="Finance" />


<!-- End Meta Data -->

<script type='text/javascript'>var PopupAdChannel=''; </script>


 <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'com-unik.info';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e44ae816-df10-443c-9af6-8ac7ebff4880",
      safari_web_id: 'web.onesignal.auto.486fe890-0d3a-4b25-a01f-9ae2be714cd5',
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
	if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}
  </script>

<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: true
     });
</script>
	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=9"></script>
	
</head>

<body>


<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=11"/>
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=52"></script>

	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Community Financial News', 'com-unik.info', 'NYSE:C', 'Citigroup', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg');</script>
<!-- End MarketBeat Modern Popup -->
	


<header>
	<div id="top-bar">
		<div class="width-limiter">
				<!-- top nav bar -->
				<nav class="navigation"><ul id="menu-nav" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>				<form id="searchform" action="https://www.com-unik.info/" method="get">
					<div id="search">
						<input id="s" class="searchinput" name="s" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
				</form><!-- end: searchform -->
		</div><!-- end: width-limiter in top-bar -->
	</div><!-- end: top-bar -->

	<div class="width-limiter add-padding" style="height:110px"><!-- start: width-limiter with logo and space for alternate header unit -->
<div style="float:left;width:280px;">
		<a href="https://www.com-unik.info"><img id="logo" src="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png" alt="community financial news logo"></a>



</div>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" style='float:right;width:728px;height:90px;'>
<iframe src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="90" frameborder="no" scrolling="no"></iframe>
	</div> 
<!-- End Header Unit-->

	</div> <!-- end: width-limiter with logo and space for alternate header unit -->



	<div id="menu">
		<div class="width-limiter">
			<!-- start main category menu -->
			<nav class="navigation"><ul id="menu-front-page-categories" class="menu"><li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li id="menu-item-107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->

</header> <!-- end: header -->
	<div class="width-limiter">
		<aside>
	
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no"></iframe><br><br>
	
<!-- first square unit -->
<div class="ad336x280">

<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->

</div>
<!-- end first square unit -->

<!-- second square unit -->
<div class="ad336x280">
<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
</div>
<!-- end second square unit -->
	



<!-- OptIn Form -->
<!-- Start Sidebar Registration -->
    <div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for Citigroup</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for Citigroup with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" name="RegisterEmail" type="email" placeholder="Your Email Address">
        <input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Sidebar">
        <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:C" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:336px;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>
<!-- End Sidebar Registration -->


<a href="https://twitter.com/CFinancialNews" class="twitter-follow-button" data-show-count="false">Follow @CFinancialNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2FCommunity-Financial-News-1775168779380432&amp;width=336&amp;height=250&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=false&amp;show_border=true&amp;appId=229098600454584" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:336px; height:250px;" allowTransparency="true"></iframe>



<!-- sidebar unit position -->



<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Top Stories</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/huron-consulting-group-inc-nasdaqhurn-expected-to-announce-quarterly-sales-of-199-98-million.html">Huron Consulting Group Inc. (NASDAQ:HURN) Expected to Announce Quarterly Sales of $199.98 Million</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/brokerages-expect-broadridge-financial-solutions-inc-nysebr-to-post-1-67-eps.html">Brokerages Expect Broadridge Financial Solutions, Inc. (NYSE:BR) to Post $1.67 EPS</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/ankr-ankr-price-hits-0-0284.html">Ankr (ANKR) Price Hits $0.0284</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/resource-management-llc-cuts-stock-position-in-general-electric-nysege.html">Resource Management LLC Cuts Stock Position in General Electric (NYSE:GE)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/ima-wealth-inc-has-2-71-million-holdings-in-ishares-msci-eafe-min-vol-factor-etf-batsefav.html">IMA Wealth Inc. Has $2.71 Million Holdings in iShares MSCI EAFE Min Vol Factor ETF (BATS:EFAV)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/ishares-core-sp-small-cap-etf-nysearcaijr-shares-purchased-by-sigfig-wealth-management-llc.html">iShares Core S&#038;P Small-Cap ETF (NYSEARCA:IJR) Shares Purchased by SigFig Wealth Management LLC</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html">Seelaus Asset Management LLC Raises Stock Position in Citigroup Inc. (NYSE:C)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/rockfire-resources-lonrock-shares-down-4-8.html">Rockfire Resources (LON:ROCK)  Shares Down 4.8%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/patriot-one-technologies-cvepat-trading-7-6-higher.html">Patriot One Technologies (CVE:PAT) Trading 7.6% Higher</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/altium-otcmktsalmff-stock-price-up-4-6.html">Altium (OTCMKTS:ALMFF) Stock Price Up 4.6%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/vanguard-ftse-canadian-capped-reit-index-etf-vre-to-tsevre-shares-up-0-3.html">Vanguard FTSE Canadian Capped REIT Index ETF (VRE.TO) (TSE:VRE) Shares Up 0.3%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/pharmacielo-otcmktsphcef-trading-down-2-8.html">Pharmacielo (OTCMKTS:PHCEF) Trading Down 2.8%</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/amplify-crowdbureaur-online-lending-digital-banking-etf-nysearcalend-trading-1-8-higher.html">Amplify CrowdBureau(R) Online Lending &#038; Digital Banking ETF (NYSEARCA:LEND) Trading 1.8% Higher</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-lowers-holdings-in-lowes-companies-inc-nyselow.html">Seelaus Asset Management LLC Lowers Holdings in Lowe&#8217;s Companies, Inc. (NYSE:LOW)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/littelfuse-inc-nasdaqlfus-stake-lessened-by-seelaus-asset-management-llc.html">Littelfuse, Inc. (NASDAQ:LFUS) Stake Lessened by Seelaus Asset Management LLC</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/sentinel-chain-hits-24-hour-trading-volume-of-54148-00-senc.html">Sentinel Chain Hits 24-Hour Trading Volume of $54,148.00 (SENC)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/rmpl-trading-9-4-higher-this-week-rmpl.html">RMPL Trading 9.4% Higher  This Week (RMPL)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/resource-management-llc-sells-8512-shares-of-vanguard-high-dividend-yield-index-fund-etf-shares-nysearcavym.html">Resource Management LLC Sells 8,512 Shares of Vanguard High Dividend Yield Index Fund ETF Shares (NYSEARCA:VYM)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/liquidapps-price-up-30-7-over-last-week-dapp.html">LiquidApps Price Up 30.7% Over Last Week (DAPP)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2021/02/21/newport-trust-co-cuts-stake-in-british-american-tobacco-p-l-c-nysebti.html">Newport Trust Co Cuts Stake in British American Tobacco p.l.c. (NYSE:BTI)</a></li>
                        </ul>
        </div>  
<!-- end recent posts -->

</aside><!--end #sidebar-->

		<main>
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html" />
				<h1 itemprop="headline" class="page-title">Seelaus Asset Management LLC Raises Stock Position in Citigroup Inc. (NYSE:C)</h1>
				
				<p class="postmeta">
					Posted by <span itemprop="author"><a href="https://www.com-unik.info/author/cynthia" title="Posts by Cynthia Vaughn" rel="author">Cynthia Vaughn</a></span> on <span itemprop="datePublished dateModified" content="2021-02-21T09:21:14+0000">Feb 21st, 2021</span>
				</p><!--end .postmeta-->
				
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
					<iframe src="https://www.marketbeat.com/scripts/TextAdNewsSites.ashx?color=bc4342" frameborder=no width="100%" height="35" scrolling="no"></iframe>
					
					<p><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&zc=1&src=https://www.marketbeat.com/logos/generic-stocks.jpg" alt="Citigroup logo" title="Citigroup logo" class="companylogo" />Seelaus Asset Management LLC boosted its holdings in  Citigroup Inc. (NYSE:C) by 4.6% in the fourth quarter, <a href='http://www.holdingschannel.com/'>HoldingsChannel</a> reports. The institutional investor  owned 8,265 shares of the company&#8217;s stock after purchasing an additional 362 shares during the quarter. Seelaus Asset Management LLC&#8217;s holdings in Citigroup were worth $510,000 at the end of the most recent reporting period. </p>
<p>Several other institutional investors have also recently modified their holdings of C. Great Valley Advisor Group Inc. grew its position in shares of  Citigroup by 13.0% during the third quarter. Great Valley Advisor Group Inc. now owns 5,335 shares of the company&#8217;s stock valued at $230,000 after purchasing an additional 615 shares in the last quarter.  Ballentine Partners LLC grew its position in shares of  Citigroup by 9.5% during the third quarter. Ballentine Partners LLC now owns 9,979 shares of the company&#8217;s stock valued at $430,000 after purchasing an additional 868 shares in the last quarter.  Coastal Investment Advisors Inc. grew its position in shares of  Citigroup by 35.7% during the third quarter. Coastal Investment Advisors Inc. now owns 10,451 shares of the company&#8217;s stock valued at $451,000 after purchasing an additional 2,752 shares in the last quarter.  Deltec Asset Management LLC grew its position in shares of  Citigroup by 10.6% during the third quarter. Deltec Asset Management LLC now owns 52,100 shares of the company&#8217;s stock valued at $2,246,000 after purchasing an additional 5,000 shares in the last quarter.  Finally, Optas LLC purchased a new position in shares of  Citigroup during the third quarter valued at about $214,000. Hedge funds and other institutional investors own  72.99% of the company&#8217;s stock. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Community Financial News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:C" />    <label for="InPostRegistrationEmail">Get <b>Citigroup</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></input></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>Several research analysts recently commented on C shares. DA Davidson lifted their price target on Citigroup from $77.00 to $84.00 and gave the stock a &#8220;buy&#8221; rating in a research report on Tuesday, January 19th. Berenberg Bank downgraded shares of Citigroup from a &#8220;buy&#8221; rating to a &#8220;hold&#8221; rating and raised their price objective for the stock from $55.00 to $70.00 in a research note on Thursday, January 21st. Daiwa Capital Markets began coverage on shares of Citigroup in a research note on Wednesday, January 6th. They issued a &#8220;buy&#8221; rating and a $75.00 price objective for the company. TheStreet raised shares of Citigroup from a &#8220;c&#8221; rating to a &#8220;b&#8221; rating in a research note on Friday, January 15th. Finally, Royal Bank of Canada raised their price objective on shares of Citigroup from $66.00 to $73.00 and gave the stock an &#8220;outperform&#8221; rating in a research note on Tuesday, January 19th. One analyst  has rated the stock with a sell rating, six have issued  a hold rating, seventeen have given a buy rating and one  has assigned  a strong buy rating to the stock. The company currently has a consensus rating of &#8220;Buy&#8221; and an average price target of $71.57.</p>
<p>
		  <div style="float:left;padding-right: 10px;padding-bottom:10px;padding-top:10px;width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no"></iframe>
                 </div>


                 Shares of <a href='https://www.marketbeat.com/stocks/NYSE/C/sec-filings/' target='_blank' rel="noopener noreferrer">C</a> traded up $2.30 during midday trading on Friday, hitting $65.78. 20,456,223 shares of the company&#8217;s stock traded hands, compared to its average volume of 20,560,211. Citigroup Inc. has a 1 year low of $32.00 and a 1 year high of $78.69. The firm&#8217;s fifty day moving average is $62.88 and its 200-day moving average is $53.40. The company has a current ratio of 0.97, a quick ratio of 0.97 and a debt-to-equity ratio of 1.50. The stock has a market capitalization of $136.95 billion, a price-to-earnings ratio of 13.08, a price-to-earnings-growth ratio of 1.25 and a beta of 1.95. </p>
<p>Citigroup (NYSE:C) last issued its quarterly earnings data on Thursday, January 14th. The company reported $2.08 EPS for the quarter, beating the consensus estimate of $1.34 by $0.74. Citigroup had a return on equity of 6.63% and a net margin of 13.17%. The firm had revenue of $16.50 billion during the quarter, compared to analyst estimates of $16.71 billion. During the same quarter in the prior year, the business posted $1.90 EPS. The business&#8217;s revenue for the quarter was down 10.2% compared to the same quarter last year.  On average, equities research analysts anticipate that  Citigroup Inc. will post 6.42 EPS for the current year. </p>
<p>The firm also recently disclosed a quarterly dividend, which will be paid on Friday, February 26th. Stockholders of record on Monday, February 1st will be issued a dividend of $0.51 per share. The ex-dividend date of this dividend is Friday, January 29th. This represents a $2.04 annualized dividend and a dividend yield of 3.10%. Citigroup&#8217;s dividend payout ratio  is presently 41.80%. </p>
<p><strong>Citigroup Company Profile</strong></p>
<p>Citigroup Inc, a diversified financial services holding company, provides various financial products and services to consumers, corporations, governments, and institutions in North America, Latin America, Asia, Europe, the Middle East, and Africa. The company operates in two segments, Global Consumer Banking (GCB) and Institutional Clients Group (ICG).</p>
<p>Read More: <a href='https://www.marketbeat.com/financial-terms/what-member-countries-make-up-the-g-20/'>What is the G-20?<br />
</a><!--ViewCount:ArticleHistoryID=69584040&PostDate=2021-2-21&type=f&id=8691820--></p>
<p><strong>Want to see what other hedge funds are holding C?</strong> <a href='https://www.holdingschannel.com/hedge-funds/holding-c/'>Visit HoldingsChannel.com</a> to get the latest 13F filings and insider trades for Citigroup Inc. (NYSE:C).</p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/SECFilingChart.ashx?Prefix=NYSE&#038;Symbol=C' alt='Institutional Ownership by Quarter for Citigroup (NYSE:C)' title='Institutional Ownership by Quarter for Citigroup (NYSE:C)' /></p>
<p><!--Keyword: Citigroup,NYSE:C,C,Finance,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings--><!--Ratings:4,24,NYSE:C--></p>
			 	<!-- end inline unit -->

				<!-- end main text -->

				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->


<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for Citigroup Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for Citigroup and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:C&c=Citigroup" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" class="signup" />
<input type="hidden" id="Hidden1" name="RegistrationCode" value="Community Financial News-Footer" />
<input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:C" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->


				</div> <!-- end: entry -->
				
				 
				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.marketbeat.com/logos/generic-stocks.jpg" />
 					<meta itemprop="width" content="300">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
 						<meta itemprop="url" content="https://www.com-unik.info/wp-content/uploads/2016/05/community-financial-news-03.png">
 						<meta itemprop="height" content="90">
					 </div>
					<meta itemprop="name" content="Community Financial News"/>
					<meta itemprop="url" content="https://com-unik.info" />
 				</div>
				<!-- end article metadata -->

			</article>

		

<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx"></iframe>
<!-- More on MarketBeat -->

		<!--  below post unit position -->
		


			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.com-unik.info/2021/02/21/rockfire-resources-lonrock-shares-down-4-8.html" rel="prev"><div class="previous"><span class="left">&nbsp;&laquo;&nbsp;</span><h4>PREVIOUS</h4><p>Rockfire Resources (LON:ROCK)  Shares Down 4.8%</p></div></a>				<a href="https://www.com-unik.info/2021/02/21/ima-wealth-inc-has-2-71-million-holdings-in-ishares-msci-eafe-min-vol-factor-etf-batsefav.html" rel="next"><div class="next"><span class="right">&nbsp;&raquo;&nbsp;</span><h4>NEXT</h4><p>IMA Wealth Inc. Has $2.71 Million Holdings in iShares MSCI EAFE Min Vol Factor ETF (BATS:EFAV)</p></div></a>			
			</nav><!-- end previous and next article links -->

			<div id="latest-news">
				<h2>Latest News</h2>
								 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/huron-consulting-group-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Huron Consulting Group Inc.  Expected to Announce Quarterly Sales of $199.98 Million" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2021/02/21/huron-consulting-group-inc-nasdaqhurn-expected-to-announce-quarterly-sales-of-199-98-million.html" rel="bookmark">Huron Consulting Group Inc.  Expected to Announce Quarterly Sales of $199.98 Million</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/broadridge-financial-solutions-inc-logo.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Brokerages Expect Broadridge Financial Solutions, Inc.  to Post $1.67 EPS" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2021/02/21/brokerages-expect-broadridge-financial-solutions-inc-nysebr-to-post-1-67-eps.html" rel="bookmark">Brokerages Expect Broadridge Financial Solutions, Inc.  to Post $1.67 EPS</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=wp-content/themes/alambre-com-unik/images/image-pending.gif&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Ankr  Price Hits $0.0284" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2021/02/21/ankr-ankr-price-hits-0-0284.html" rel="bookmark">Ankr  Price Hits $0.0284</a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/general-electric-company-logo.png&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="Resource Management LLC Cuts Stock Position in General Electric " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2021/02/21/resource-management-llc-cuts-stock-position-in-general-electric-nysege.html" rel="bookmark">Resource Management LLC Cuts Stock Position in General Electric </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="IMA Wealth Inc. Has $2.71 Million Holdings in iShares MSCI EAFE Min Vol Factor ETF " />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2021/02/21/ima-wealth-inc-has-2-71-million-holdings-in-ishares-msci-eafe-min-vol-factor-etf-batsefav.html" rel="bookmark">IMA Wealth Inc. Has $2.71 Million Holdings in iShares MSCI EAFE Min Vol Factor ETF </a>
				</div>
	 							 <div class="latest-news-item">
												<img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/generic-stocks.jpg&amp;h=95&amp;w=95&amp;zc=1" height="95" width="95" alt="iShares Core S&#038;P Small-Cap ETF  Shares Purchased by SigFig Wealth Management LLC" />
						<br/>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2021/02/21/ishares-core-sp-small-cap-etf-nysearcaijr-shares-purchased-by-sigfig-wealth-management-llc.html" rel="bookmark">iShares Core S&#038;P Small-Cap ETF  Shares Purchased by SigFig Wealth Management LLC</a>
				</div>
	 						</div><!-- end latest news -->

			<!-- start comments section -->
				<h2 style="padding: 5px 0; border-bottom: solid 1px #ddd; margin: 10px 0 4px 0;">Comments</h2>
					
				
<div class="comments-box">
	<a name="comments" id="comments"></a>
	</div> 			<!-- end comments section --> 



<!-- second ad spot -->


<br>

	</main> <!-- end main -->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<div style="clear:both"></div>
<footer class="full-width">
			<div class="width-limiter">

				<div id="footer-info" class="add-padding">
					<nav class="navigation"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>					<span id="copyright">
						&copy; 2013-2021 <a href="https://www.com-unik.info">Community Financial News</a>
					</span>
				</div><!-- end #footer-info -->

			</div>	
		</footer>
		<script type='text/javascript' src='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/js/wp-embed.min.js&#038;ver=1606755730'></script>

<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1"></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of StatCounter Code for Com-Unik -->
<script type="text/javascript">
var sc_project=10928871; 
var sc_invisible=1; 
var sc_security="cc698371"; 
var sc_https=1; 
var scJsHost = (("https:" == document.location.protocol) ? "https://secure." : "http://www.");
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script><noscript><img class="statcounter" src="//c.statcounter.com/10928871/0/cc698371/1/" alt="Web Analytics"></a></noscript>
<!-- End of StatCounter Code for Com-Unik -->

<!-- Begin Social Sharing -->
		<div style="top:25%;left:0;position:fixed;width:50px;z-index:20;box-sizing:content-box;" class="mobile-hide">
	<div style="background-color:#305891;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.facebook.com/sharer/sharer.php?u=https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html" target="_blank"><img src="https://www.com-unik.info//images/social-fb.png" style="margin:0;padding:0;" alt="share news on Facebook"></a></div>
	<div style="background-color:#2CA8D2;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://twitter.com/intent/tweet?text=Seelaus Asset Management LLC Raises Stock Position in Citigroup Inc. $NYSE:C https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html" target="_blank"><img src="https://www.com-unik.info//images/social-tw.png" style="margin:0;padding:0;" alt="tweet this investment news"></a></div>
	<div style="background-color:#007BB6;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.linkedin.com/cws/share?mini=true&url=https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html" target="_blank"><img src="https://www.com-unik.info//images/social-in.png" style="margin:0;padding:0;" alt="share on linkedin"></a></div>
	<div style="background-color:#89120a;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://api.stocktwits.com/widgets/share?via=AnalystRatingsNetwork&body=Seelaus Asset Management LLC Raises Stock Position in Citigroup Inc. $NYSE:C https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html" target="_blank"><img src="https://www.com-unik.info/images/social-st.png" style="margin:0;padding:0;box-sizing:content-box;" alt="share on StockTwits"></a></div>
	<div style="background-color:#FF1A00;border:0;width:30px;height:30px;padding:9px;box-sizing:content-box;"><a href="https://www.reddit.com/submit?url=https://www.com-unik.info/2021/02/21/seelaus-asset-management-llc-raises-stock-position-in-citigroup-inc-nysec.html&title=Seelaus Asset Management LLC Raises Stock Position in Citigroup Inc. (NYSE:C)" target="_blank"><img src="https://www.com-unik.info//images/social-reddit.png" style="margin:0;padding:0;" alt="share on reddit"></a></div>
	</div>
	<!-- End Social Sharing -->

<!-- Begin Internal Tracking Pixel 2 -->
<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/viewcount.ashx?ArticleHistoryID=69584040&PostDate=2021-2-21&type=f&id=8691820&domain=www.com-unik.info&referrer=' + encodeURIComponent(document.referrer) + '" />');</script>
<!-- End Internal Tracking Pixel 2-->

<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "16807273" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=16807273&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->


	</body>

</html>
