<!doctype html>
<html lang="en">
<head>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />

<meta name="theme-color" content="#bc4342"/>
 

<meta name="viewport" content="width=device-width, initial-scale=1.0">

<!-- Escape from Frames -->
<script type="text/javascript">if(self==top){document.documentElement.style.display="block"}else{top.location=self.location}</script>

<link rel="preconnect" href="https://fonts.gstatic.com">
<link href="https://fonts.googleapis.com/css2?family=Roboto&display=swap" rel="stylesheet">


<style>

:root {
  --header-background: #ffffff;
  --button-background: #bc4342;
  --button-background-2: #bc4342;
  --button-hover-background: #a63a3a;
  --button-hover-background-2: #a63a3a;
  --button-text-color: #fff;
  --link-color: #bc4342;
  --link-hover-color: #a63a3a;
  --link-text-decoration: none; /* text field */
  --hover-link-text-decoration: underline; /* text field */
  --menu-background: #3c505a;
  --menu-background-2: #3c505a;
  --menu-text-color: #fff;
  --menu-active-hover-background: #bc4342;
  --menu-active-hover-text-color: #fff;
  --top-menu-background: #bc4342;
  --top-menu-link-color: #ffffff;
  --top-menu-link-hover-color: #ededed;
  --accent-color: #3c505a;
  --accent-color-2: #bc4342;
  --sidebar-h3-color: #3c505a;
  --light-gray-color:#ddd;
  --light-gray-link-color:#ddd;
  --light-gray-link-hover-color:#ddd;
  --list-item-bottom-border: solid 1px #bc4342;
  --border-radius: 0;
  --border-radius-small-items: 0;
  --H1-font: bold 2em/1.3 "Roboto",sans-serif;
  --H2-font:  bold 1.3em/1.3 "Roboto",sans-serif;
  --H3-font:  bold uppercase 1.1em/1.3 "Roboto",sans-serif;
  --body-font: 15px "Roboto",sans-serif;
  --menu-font: 1em "Roboto", sans-serif;
  --box-shadow: none; 
  --body-background: #e2e2e2;
  --body-background-2: #dddddd;
  --body-font-color: #000000;

}


body {
	font: var(--body-font);
    background: var(--body-background);
	color: var(--body-font-color);
	 
		
	background: -moz-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -webkit-gradient(left top,left bottom,color-stop(0%, var(--body-background)),color-stop(100%, var(--body-background-2)));
    background: -webkit-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -o-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: -ms-linear-gradient(top, var(--body-background) 0%, var(--body-background-2) 100%);
    background: linear-gradient(to bottom, var(--body-background) 0%, var(--body-background-2) 100%);
		
    background-attachment: fixed;
    background-size: cover;
}

</style>
<link rel="stylesheet" href="https://www.com-unik.info/wp-content/themes/responsalambre/style.css?v=2021abcdefghij" type="text/css" media="screen">
	
<link href="https://www.com-unik.info/feed" rel="alternate" title="Community Financial News RSS Feed" type="application/rss+xml" />
<link href="https://www.com-unik.info/feed/atom" rel="alternate" title="Community Financial News Atom Feed" type="application/atom+xml" />
<link href="https://www.com-unik.info/xmlrpc.php" rel="pingback" />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='stylesheet' id='wp-block-library-group-css' href='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/css/dist/block-library/style.min.css&#038;ver=1621979507' type='text/css' media='all' />
<link rel="https://api.w.org/" href="https://www.com-unik.info/wp-json/" /><link rel="alternate" type="application/json" href="https://www.com-unik.info/wp-json/wp/v2/posts/5559169" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.com-unik.info/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.com-unik.info/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='MATH Price Reaches $0.15 on Major Exchanges (MATH)' href='https://www.com-unik.info/2022/06/11/math-price-reaches-0-15-on-major-exchanges-math.html' />
<link rel='next' title='The Container Store Group, Inc. (NYSE:TCS) Shares Sold by Kanen Wealth Management LLC' href='https://www.com-unik.info/2022/06/11/the-container-store-group-inc-nysetcs-shares-sold-by-kanen-wealth-management-llc.html' />
<meta name="generator" content="WordPress 5.5.9" />
<link rel="canonical" href="https://www.com-unik.info/2022/06/11/kc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html" />
<link rel='shortlink' href='https://www.com-unik.info/?p=5559169' />
<link rel="alternate" type="application/json+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2022%2F06%2F11%2Fkc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.com-unik.info/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.com-unik.info%2F2022%2F06%2F11%2Fkc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html&#038;format=xml" />
<link rel="manifest" href="https://www.com-unik.info/manifest.json"><link rel="amphtml" href="https://www.com-unik.info/2022/06/11/kc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html/amp" /><link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="32x32" />
<link rel="icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />
<meta name="msapplication-TileImage" content="https://www.com-unik.info/wp-content/uploads/2017/09/favicon-com-unik.png" />

<!-- Start Meta Data -->
<title>KC Investment Advisors LLC Purchases New Shares in BlackRock, Inc. (NYSE:BLK) - Community Financial News</title>
<meta name="description" content="Read KC Investment Advisors LLC Purchases New Shares in BlackRock, Inc. (NYSE:BLK) at Community Financial News"/>
<meta name="distribution" content="global" />
<meta name="robots" content="follow, all" />
<meta name="description" content="KC Investment Advisors LLC purchased a new stake in shares of BlackRock, Inc. (NYSE:BLK &#8211; Get Rating) during the 4th quarter, according to the company in its most recent 13F filing with the Securities &amp; Exchange Commission. The firm purchased 305 shares of the asset manager&#8217;s stock, valued at approximately $279,000. Other hedge funds have [&hellip;]" />
<meta name="author" content="Eileen French">
<meta name="news_keywords" content="BlackRock,NYSE:BLK,BLK,Finance,09247X10,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="keywords" content="BlackRock,NYSE:BLK,BLK,Finance,09247X10,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta name="ticker" content="NYSE:BLK" />
<meta name="contentType" content="article">

<!-- Twitter Card Data -->
<meta name="twitter:card" content="summary"/>
<meta name="twitter:site" content="@MarketBeatCom" />
<meta name="twitter:title" content="KC Investment Advisors LLC Purchases New Shares in BlackRock, Inc. (NYSE:BLK)"/>
<meta name="twitter:description" content="KC Investment Advisors LLC purchased a new stake in shares of BlackRock, Inc. (NYSE:BLK &#8211; Get Rating) during the 4th quarter, according to the company in its most recent 13F filing with the Securities &amp; Exchange Commission. The firm purchased 305 shares of the asset manager&#8217;s stock, valued at approximately $279,000. Other hedge funds have [&hellip;]" />
<meta name="twitter:creator" content="@RatingsNetwork" />
<meta name="twitter:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/blackrock-inc-logo.gif&amp;w=240&amp;h=240&amp;zc=2" />

<!-- Open Graph Data -->
<meta property="og:title" content="KC Investment Advisors LLC Purchases New Shares in BlackRock, Inc. (NYSE:BLK)" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.com-unik.info/2022/06/11/kc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html" />
<meta property="og:image" content="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/blackrock-inc-logo.gif&amp;w=240&amp;h=240&amp;zc=2" />
<meta property="og:image:width" content="240" />
<meta property="og:image:height" content="240" />
<meta property="og:description" content="KC Investment Advisors LLC purchased a new stake in shares of BlackRock, Inc. (NYSE:BLK &#8211; Get Rating) during the 4th quarter, according to the company in its most recent 13F filing with the Securities &amp; Exchange Commission. The firm purchased 305 shares of the asset manager&#8217;s stock, valued at approximately $279,000. Other hedge funds have [&hellip;]" />
<meta property="og:site_name" content="Community Financial News" />
<meta property="og:locale" content="en_US" />

<!-- OG Article Template -->
<meta property="article:published_time" content="2022-06-11T10:46:42+0000" />
<meta property="article:modified_time" content="2022-06-11T10:46:42+0000" />
<meta property="article:tag" content="NYSE:BLK" />
<meta property="article:tag" content="BlackRock,NYSE:BLK,BLK,Finance,09247X10,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings" />
<meta property="article:section" content="Finance" />

<!-- Google meta is in the body-->

<!-- End Meta Data -->

	
<script type='text/javascript'>var PopupAdChannel=''; </script>

  <link rel="manifest" href="/manifest.json">
  <script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js"></script>
  <script>
  	function registerUserChange(action) {
		OneSignal.getUserId( function(userId) {
			OneSignalIdString = userId;
			var Domain = 'com-unik.info';
			var url = "https://www.marketbeat.com/scripts/OneSignalTracking.ashx?OneSignalID=" + OneSignalIdString + "&domain=" + Domain + "&action=" + action;
			var xhr = new XMLHttpRequest();
			xhr.open('GET', url);
			xhr.onload = function () {
				if (xhr.status !== 200) {
					console.log('GET failed.  Returned status of ' + xhr.status);
				}
			};
			xhr.send();
		});
	}
    var OneSignal = window.OneSignal || [];
    OneSignal.push(["init", {
      appId: "e44ae816-df10-443c-9af6-8ac7ebff4880",
      safari_web_id: 'web.onesignal.auto.486fe890-0d3a-4b25-a01f-9ae2be714cd5', 
      autoRegister: false,
      notifyButton: {
        enable: false /* Set to false to hide */
      },
 welcomeNotification: {
        "title": "Join Wall Street's Brightest Minds.",
        "message": "Receive research in your inbox from top analysts, before the market opens. Click here to learn how.",
         "url": "https://www.marketbeat.com/subscribe/subscribe.aspx?ReferralType=OneSignalThankYou&ProductCode=1997t"
    }
    },
		OneSignal.once('subscriptionChange', function (isSubscribed) {
			if(isSubscribed) {
				registerUserChange("subscribe");
			}
			else {
				registerUserChange("unsubscribe");
			}
			
		  })
	]);
if((navigator.userAgent.toLowerCase().indexOf('firefox') > -1)||((navigator.userAgent.toLowerCase().indexOf('safari') > -1)&&(!(navigator.userAgent.toLowerCase().indexOf('chrome') > -1)))){
		OneSignal.showSlidedownPrompt();
	} else {
		OneSignal.showNativePrompt();		
	}  </script>



<script type="text/javascript">var vbnfgha = '211626'; var ertdfga = '13739-bup-ac'; var qhyuioa = '53938'; var AdClientID = qhyuioa + vbnfgha + ertdfga; AdClientID = AdClientID.split("").reverse().join("");</script>


	
	<script type="text/javascript" src="https://www.marketbeat.com/Scripts/lowerrightad.js?v=2021"></script>
	
	<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: AdClientID,
          enable_page_level_ads: false
     });
</script>

</head>
<body>
<div id="wrap">
<script type="text/javascript" src="https://www.marketbeat.com/scripts/modal/modernpopup.js?v=60"></script>
	
<!-- Start MarketBeat Modern Popup -->
<link rel="stylesheet" type="text/css" media="all" href="https://www.marketbeat.com/scripts/modal/modernpopup.css?v=12"/>
	
	
	<script type="text/javascript">LoadPopupRatings('ModernMarketsPopup-Community Financial News', 'com-unik.info', 'NYSE:BLK', 'BlackRock', 'https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=175&zc=1&src=https://www.marketbeat.com/logos/blackrock-inc-logo.gif');</script>
	<!-- End MarketBeat Modern Popup -->
	
<a class="skip-link scroll" href="#main">Skip to main content</a>
<header>
	<div class="width-limiter background-light top-menu-bar">
		<div style='color:#222;text-align:right;'>
			<nav class="navigation top-menu" aria-label="Utility Links"><ul id="menu-nav" class="menu"><li id="menu-item-12" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li id="menu-item-13" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>		</div>
   </div>
<!-- start for mobile menu -->
<div class="width-limiter top-mobile-menu" id='mobile-logo-bar'>
	 <label for="nav-trigger" style="display:inline-block; width:30vw; color:#12424d;vertical-align:middle;">&#9776;</label> 
	 <a style='vertical-align:middle;width:33vw;display:inline-block;text-align:center;padding:5px;' href="https://www.com-unik.info"><img style='max-height: 60px;' src="https://www.com-unik.info/wp-content/uploads/2021/05/community-financial-news-200-03-1.png" alt="Community Financial News logo" width="737" height="248"></a>
	</div>
	<div class="width-limiter" style="min-height: 5px;" id='mobile-menu-bar'>
		
                	<input type="checkbox" id="nav-trigger" class="navOpen" />
                
                	<div class="mobile-nav nice-scroll">
                		
							
                			
                			<nav class="mobile-menu" aria-label="Category Mobile Menu"><ul id="menu-front-page-categories" class="menu"><li id="menu-item-110" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li id="menu-item-108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li id="menu-item-114" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li id="menu-item-113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li id="menu-item-107" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>                			<nav class="mobile-menu" aria-label="Utility Mobile Menu"><ul id="menu-nav-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-12"><a href="https://www.com-unik.info/news">Headlines</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.com-unik.info/about-cfn">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-13"><a href="https://www.com-unik.info/privacy-policy">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="https://www.com-unik.info/contact-us">Contact Us</a></li>
</ul></nav>                			
                			<form class="mobile-search" id="mobileSearchForm" action="https://www.com-unik.info/" method="get">
                				<div class="search">
                					<input id="s" style='margin-left:0;' class="searchinput" aria-label="Search Keywords" name="s" onclick="this.value='';" type="text" />
                					<input class="searchsubmit" type="submit" value="SEARCH" />
                				</div>
                			</form>
						<div>
	
						</div>
                	</div>
		
	</div>
<!-- end for mobile menu -->
	<div class="width-limiter add-padding flex-container"><!-- start: width-limiter with logo and space for alternate header unit -->
		
		<a class="logo-link flex-logo" id="header-logo-link" href="https://www.com-unik.info" title="Community Financial News"><img id="logo" src="https://www.com-unik.info/wp-content/uploads/2021/05/community-financial-news-200-03-1.png" alt="Community Financial News logo" width="737" height="248"></a>

<!-- Begin Header Unit -->
<div id="AlternateHeaderUnit" class="flex-header-ad">
	<iframe class="large-show" src="https://marketbeat.com/scripts/HeaderAdNewsSites.ashx" width="728" height="110" frameborder="no" scrolling="no" style="width: 100%;overflow:hidden;" title="Ad"></iframe>
	<iframe class="small-show" src="https://marketbeat.com/scripts/SidebarAdNewsSites.ashx" width="336" height="280" frameborder="no"scrolling="no" style="overflow:hidden;margin:0 auto;" title="Ad"></iframe>
</div> 

<!-- End Header Unit-->
	</div> <!-- end: width-limiter with logo and space for alternate header unit -->
	<div id="menu">
		<div class="width-limiter flex-container" id="nav-main">
			
			<!-- start main category menu -->
			
			<div class="flex-nav">
			   
			  



			<nav class="navigation" aria-label="Main Menu"><ul id="menu-front-page-categories-1" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>			
			</div>
				<form class="flex-search" id="searchform" action="https://www.com-unik.info/" method="get">
					<div class="search">
						<input id="s-main" class="searchinput" name="s" aria-label="Search Keywords" onclick="this.value='';" type="text" />
						<input class="searchsubmit" type="submit" value="SEARCH" />
					</div>
					
				</form><!-- end: searchform -->
		</div> <!-- end: width-limiter for menu -->
	</div> <!-- end: menu -->
</header> <!-- end: header -->
	<div class="width-limiter main-content flex-container">
		

		<main class="flex-main" id="main">
			 <article itemscope itemtype="http://schema.org/NewsArticle">
				
				<link itemprop="mainEntityOfPage" href="https://www.com-unik.info/2022/06/11/kc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html" />
				<h1 itemprop="headline" class="page-title">KC Investment Advisors LLC Purchases New Shares in BlackRock, Inc. (NYSE:BLK)</h1>

				<p class="postmeta">
					Posted by <span itemprop="author" itemscope itemtype="https://schema.org/Person"><span itemprop="name"><a href="https://www.com-unik.info/author/eileen" title="Posts by Eileen French" rel="author">Eileen French</a></span></span> on <span itemprop="datePublished dateModified" content="2022-06-11T10:46:42+0000">Jun 11th, 2022</span>
				</p><!--end .postmeta-->

				<div class="social-shares">
					
					
		 
			
					<a title="Share on Twitter" rel="noopener nofollow" target="_blank" style="background: #1DA1F2;" href="https://twitter.com/intent/tweet?original_referer=https%3A%2F%2Fwww.com-unik.info&ref_src=twsrc%5Etfw&text=KC%20Investment%20Advisors%20LLC%20Purchases%20New%20Shares%20in%20BlackRock%2C%20Inc.%20%28NYSE%3ABLK%29%20%24BLK&tw_p=tweetbutton&url=https%3A%2F%2Fwww.com-unik.info%2F2022%2F06%2F11%2Fkc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html&via=CFinancialNews"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"/></svg></span><span class="share-title">Share on Twitter</span></a>
					
					
	<a title="Share on Facebook" rel="noopener nofollow" target="_blank" style="background:#4267B2;" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.com-unik.info%2F2022%2F06%2F11%2Fkc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M9 8h-3v4h3v12h5v-12h3.642l.358-4h-4v-1.667c0-.955.192-1.333 1.115-1.333h2.885v-5h-3.808c-3.596 0-5.192 1.583-5.192 4.615v3.385z"/></svg></span><span class="share-title">Share on Facebook</span></a>
				 
<a title="Share on LinkedIn" rel="noopener nofollow" target="_blank" style="background: #0067b1;" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Fwww.com-unik.info%2F2022%2F06%2F11%2Fkc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html"><span class="share-button"><svg style="fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M4.98 3.5c0 1.381-1.11 2.5-2.48 2.5s-2.48-1.119-2.48-2.5c0-1.38 1.11-2.5 2.48-2.5s2.48 1.12 2.48 2.5zm.02 4.5h-5v16h5v-16zm7.982 0h-4.968v16h4.969v-8.399c0-4.67 6.029-5.052 6.029 0v8.399h4.988v-10.131c0-7.88-8.922-7.593-11.018-3.714v-2.155z"/></svg></span><span class="share-title">Share on LinkedIn</span></a>
				 
				<a title="Share on Stocktwits" rel="noopener nofollow" style="background:#228dff;" href="https://api.stocktwits.com/widgets/share?via=MarketBeat&amp;body=KC%20Investment%20Advisors%20LLC%20Purchases%20New%20Shares%20in%20BlackRock%2C%20Inc.%20%28NYSE%3ABLK%29%20%24BLK" title="Share on StockTwits"><span class="share-button"><svg style="fill:#fff;" version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"  width="24" height="24" viewBox="0 0 30 30" style="enable-background:new 0 0 30 30;" xml:space="preserve"><polygon class="st0" points="21.98,17.75 21.98,13.29 14.54,9.67 21.98,6.19 21.98,1.84 9.02,8.45 9.02,11.12 "/><polygon class="st0" points="9.07,13.19 9.07,17.65 16.49,21.27 9.07,24.76 9.07,29.1 21.98,22.49 21.98,19.82 "/></svg></span><span class="share-title">Share on Stocktwits</span></a>
					
</div>
<div style="clear:both"></div>
				<!--sse-->
				<div class="entry" itemprop="articleBody"> 
				<!-- start main text -->
				<iframe src="https://www.marketbeat.com/scripts/TextAdNewsSites.ashx?color=3c505a" frameborder=no width="100%" height="35" scrolling="no" title="Advertisement"></iframe>

					<p><img height="150" width="250" src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=250&h=150&zc=2&src=https://www.marketbeat.com/logos/blackrock-inc-logo.gif" alt="BlackRock logo" title="BlackRock" class="companylogo" />KC Investment Advisors LLC purchased a new stake in shares of  BlackRock, Inc. (<a href='https://www.marketbeat.com/stocks/NYSE/BLK/'>NYSE:BLK</a> &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=BLK&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=BLK&#038;utm_content=text_link'>Get Rating</a>) during the 4th quarter, according to the company in its most recent 13F filing with the Securities &amp; Exchange Commission. The firm purchased 305 shares of the asset manager&#8217;s stock, valued at approximately $279,000. </p>
<p>Other hedge funds have also recently added to or reduced their stakes in the company. Column Capital Advisors LLC lifted its stake in shares of  BlackRock by 28,992.4% in the fourth quarter. Column Capital Advisors LLC now owns 2,847,273 shares of the asset manager&#8217;s stock worth $2,847,000 after buying an additional 2,837,486 shares in the last quarter.  State Street Corp raised its stake in  BlackRock by 3.0% during the fourth quarter. State Street Corp now owns 6,539,029 shares of the asset manager&#8217;s stock worth $5,986,873,000 after purchasing an additional 192,641 shares during the period.  Assenagon Asset Management S.A. raised its stake in  BlackRock by 334.0% during the fourth quarter. Assenagon Asset Management S.A. now owns 195,750 shares of the asset manager&#8217;s stock worth $179,221,000 after purchasing an additional 150,647 shares during the period.  Cantillon Capital Management LLC purchased a new position in  BlackRock during the fourth quarter worth about $93,657,000.  Finally, Capital Research Global Investors raised its stake in  BlackRock by 16.7% during the fourth quarter. Capital Research Global Investors now owns 594,754 shares of the asset manager&#8217;s stock worth $544,533,000 after purchasing an additional 85,136 shares during the period. Institutional investors own  93.81% of the company&#8217;s stock. </p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx" style="border-bottom-width: 1px; border-color: #D2D2D2; border-style: solid; border-top-width: 1px; margin-bottom: 24px; margin-top: 12px; padding: 12px 0;border-right:none;border-left:none;clear:both;">
    <input type="hidden" id="Hidden1" name="RegistrationCode" value="InPost-Community Financial News"  />
    <input type="hidden" id="Hidden2" name="RegisterTicker" value="NYSE:BLK" />    <label for="InPostRegistrationEmail">Get <b>BlackRock</b> alerts:</label>
    <div style="display:inline-block;"><input id="InPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Enter Your Email Address" style="border: 1px solid #D2D2D2;font-size: 12px;line-height: 18px;margin: 0;min-width: 200px; padding: 4px;" /><input type="submit" name="submit" onclick="return CheckEmail('InPostRegistrationEmail','ShowSuggestionInPost');" value="Submit" style="-webkit-appearance: none;-moz-appearance: none;appearance: none;background-color: #1361A2;border: 1px solid #1361A2;border-bottom-right-radius: .5em;border-top-right-radius: .5em;color: #fff;font-size: 12px;font-weight: 700;line-height: 18px;padding: 4px 18px"></div>
</form>
<div id="ShowSuggestionInPost"></div>


<p>A number of brokerages have commented on BLK. Citigroup reduced their target price on shares of BlackRock from $1,035.00 to $900.00 and set a &#8220;buy&#8221; rating on the stock in a research note on Tuesday, April 12th. Morgan Stanley reduced their price target on shares of BlackRock from $966.00 to $932.00 and set an &#8220;overweight&#8221; rating on the stock in a research note on Thursday, April 14th. BNP Paribas downgraded shares of BlackRock from an &#8220;outperform&#8221; rating to a &#8220;neutral&#8221; rating and set a $725.00 price target on the stock. in a research note on Tuesday, March 8th. Deutsche Bank Aktiengesellschaft reduced their price target on shares of BlackRock from $905.00 to $747.00 in a research note on Thursday, May 19th. Finally, The Goldman Sachs Group reduced their price target on shares of BlackRock from $1,000.00 to $800.00 and set a &#8220;buy&#8221; rating on the stock in a research note on Monday, March 14th. Five research analysts have rated the stock with a hold rating and ten have given a buy rating to the stock. According to MarketBeat.com, the stock currently has a consensus rating of &#8220;Buy&#8221; and an average target price of $873.86.</p>
<p>
		  <div class="in-article-ad" class="width:340px;">
<iframe src="https://marketbeat.com/scripts/336x280AdNewsSites.ashx" width="336" height="280" frameborder="no" title="Offer"></iframe>
</div>


                 <a href='https://www.marketbeat.com/stocks/NYSE/BLK/sec-filings/' target='_blank' rel="noopener noreferrer">NYSE BLK</a> opened at $617.67 on Friday. The company has a quick ratio of 4.33, a current ratio of 4.33 and a debt-to-equity ratio of 0.39. BlackRock, Inc. has a 52 week low of $582.58 and a 52 week high of $973.16. The stock has a market capitalization of $93.58 billion, a PE ratio of 15.52, a price-to-earnings-growth ratio of 2.11 and a beta of 1.27. The firm has a 50 day moving average of $660.18 and a two-hundred day moving average of $765.01. </p>
<p>BlackRock (<a href='https://www.marketbeat.com/stocks/NYSE/BLK/'>NYSE:BLK</a> &#8211; <a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=BLK&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=BLK&#038;utm_content=text_link'>Get Rating</a>) last issued its earnings results on Wednesday, April 13th. The asset manager reported $9.52 earnings per share (EPS) for the quarter, beating the consensus estimate of $8.92 by $0.60. BlackRock had a net margin of 31.20% and a return on equity of 17.00%. The business had revenue of $4.70 billion during the quarter, compared to analysts&#8217; expectations of $4.76 billion. During the same quarter in the prior year, the business posted $7.77 EPS. The company&#8217;s revenue for the quarter was up 6.8% on a year-over-year basis.  On average, equities research analysts expect that  BlackRock, Inc. will post 38.35 earnings per share for the current fiscal year. </p>
<p>The business also recently announced a quarterly dividend, which will be paid on Thursday, June 23rd. Stockholders of record on Monday, June 6th will be issued a $4.88 dividend. This represents a $19.52 annualized dividend and a dividend yield of 3.16%. The ex-dividend date of this dividend is Friday, June 3rd. BlackRock&#8217;s payout ratio is 49.06%. </p>
<p>In other BlackRock news, Director William E. Ford purchased 2,000 shares of BlackRock stock in a transaction that occurred on Monday, April 18th. The stock was purchased at an average price of $681.44 per share, for a total transaction of $1,362,880.00. Following the transaction, the director now directly owns 14,915 shares in the company, valued at $10,163,677.60. The purchase was disclosed in a document filed with the Securities &amp; Exchange Commission, which is available at <a href='http://www.sec.gov/Archives/edgar/data/1193345/000112760222012094/xslF345X03/form4.xml' target='_blank' rel="noopener noreferrer">the SEC website</a>. Also, Director <a target='_blank' rel="noopener noreferrer" href='https://www.insidertrades.com/blackrock-inc-stock/william-e-ford-1/'>William E. Ford</a> purchased 1,000 shares of BlackRock stock in a transaction that occurred on Thursday, April 14th. The stock was acquired at an average price of $701.00 per share, with a total value of $701,000.00. Following the transaction, the director now owns 12,915 shares in the company, valued at $9,053,415. The disclosure for this purchase can be found <a href='http://www.sec.gov/Archives/edgar/data/1193345/000112760222012094/xslF345X03/form4.xml' target='_blank' rel="noopener noreferrer">here</a>. Corporate insiders own  1.06% of the company&#8217;s stock. </p>
<p><strong>BlackRock Profile</strong> (<a style='font-weight:normal;text-decoration:italic;color:green' href='https://report.stocknews.com/sign-up/ticker/?ticker=BLK&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=BLK&#038;utm_content=text_link'>Get Rating</a>)</p>
<p>BlackRock, Inc is a publicly owned investment manager. The firm primarily provides its services to institutional, intermediary, and individual investors including corporate, public, union, and industry pension plans, insurance companies, third-party mutual funds, endowments, public institutions, governments, foundations, charities, sovereign wealth funds, corporations, official institutions, and banks.</p>
<p><strong>Recommended Stories</strong></p>
<ul>
<li><a href='https://report.stocknews.com/sign-up/ticker/?ticker=BLK&#038;lead_source=marketbeat_snra&#038;utm_source=marketbeat_snra&#038;utm_medium=article&#038;utm_campaign=ticker&#038;utm_term=BLK&#038;utm_content=text_link' target='_blank' rel="noopener noreferrer">Get a free copy of the StockNews.com research report on BlackRock (BLK)</a></li>
<li><a href='https://www.marketbeat.com/originals/three-upgrades-you-need-to-pay-attention-too/' target='_blank' rel="noopener noreferrer">Three Upgrades You Need To Pay Attention Too </a></li>
<li><a href='https://www.marketbeat.com/originals/consider-these-dividend-paying-stocks-during-inflationary-times/' target='_blank' rel="noopener noreferrer">Consider These Dividend-Paying Stocks During Inflationary Times</a></li>
<li><a href='https://www.marketbeat.com/originals/marketbeat-week-in-review-6-6-6-10/' target='_blank' rel="noopener noreferrer">MarketBeat: Week in Review 6/6 – 6/10</a></li>
<li><a href='https://www.marketbeat.com/originals/nio-nyse-nio-justifies-recent-rally/' target='_blank' rel="noopener noreferrer">NIO (NYSE: NIO) Justifies Recent Rally</a></li>
<li><a href='https://www.marketbeat.com/originals/hubspot-a-more-competitive-valuation/' target='_blank' rel="noopener noreferrer">HubSpot: A More Competitive Valuation</a></li>
</ul>
<p><!--ViewCount:ArticleHistoryID=90726054&PostDate=2022-6-11&type=f&id=11956692--></p>
<p style='text-align:center'><img src='https://www.marketbeat.com/scripts/SECFilingChart.ashx?Prefix=NYSE&#038;Symbol=BLK' alt='Institutional Ownership by Quarter for BlackRock (NYSE:BLK)' width='650' height='350'/></p>
<p><!--Keyword: BlackRock,NYSE:BLK,BLK,Finance,09247X10,SEC Filings,13F,Hedge Fund Holdings,Institutional Investor Holdings--><!--Ratings:4,14,NYSE:BLK--></p>

			 	<!-- end inline unit -->
				<!-- end main text -->
				<!-- Invalidate Article -->
					 
				<!-- End Invalidate -->

<!--Begin Footer Opt-In-->
<p style="clear:both"><strong>Receive News &amp; Ratings for BlackRock Daily</strong> - Enter your email address below to receive a concise daily summary of the latest news and analysts' ratings for BlackRock and related companies with <a href="/daily-email-updates-basic/?symbol=NYSE:BLK&c=BlackRock" rel="nofollow" style="text-decoration:underline;font-weight:bold">MarketBeat.com's FREE daily email newsletter</a>.</p>
<form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
<input id="BelowPostRegistrationEmail" name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address" class="signup" />
<input type="hidden" id="Hidden3" name="RegistrationCode" value="Community Financial News-Footer" />
<input type="hidden" id="Hidden4" name="RegisterTicker" value="NYSE:BLK" /><input class="button" type="submit" name="submit" onclick="return CheckEmail('BelowPostRegistrationEmail','ShowSuggestionFooter');" value="Sign-Up Now (Free)">
</form>
<div id="ShowSuggestionFooter"></div>
<!-- End Footer Opt-In -->

				</div> <!-- end: entry -->
				<!--/sse-->
				 				<!-- start article metadata -->
				 <div itemscope itemprop="image" itemtype="https://schema.org/ImageObject" style='display:none'>
 					<link itemprop="url" href="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?w=500&h=300&zc=2&src=https://www.marketbeat.com/logos/blackrock-inc-logo.gif" />
 					<meta itemprop="width" content="500">
 					<meta itemprop="height" content="300">
				 </div>
				<div itemscope itemprop="publisher" itemtype="https://schema.org/Organization" style="display:none">
 					<div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
					 	<meta itemprop="url" content="https://www.com-unik.info/wp-content/uploads/2021/05/community-financial-news-200-03-1.png">
						  						 <meta itemprop="width" content="737">
						 <meta itemprop="height" content="248">
					 </div>
					<meta itemprop="name" content="Community Financial News"/>
					<meta itemprop="url" content="https://com-unik.info" />
 				</div>
				<!-- end article metadata -->
			</article>


<!-- More on MarketBeat -->
<iframe width="100%" height="600" scrolling="no" frameborder="no" src="https://www.marketbeat.com/scripts/MoreOnMarketBeatBelowPost.aspx" title="More Headlines"></iframe>
<!-- More on MarketBeat -->

<!--  below post unit position -->
		

			<nav id="prevnext"><!-- previous and next article links -->
				<a href="https://www.com-unik.info/2022/06/11/math-price-reaches-0-15-on-major-exchanges-math.html" rel="prev"><div class="previous"><h2 class="h4">&laquo; PREVIOUS HEADLINE</h2><p>MATH Price Reaches $0.15 on Major Exchanges (MATH)</p></div></a>				<a href="https://www.com-unik.info/2022/06/11/the-container-store-group-inc-nysetcs-shares-sold-by-kanen-wealth-management-llc.html" rel="next"><div class="next"><h2 class="h4">NEXT HEADLINE &raquo;</h2><p>The Container Store Group, Inc. (NYSE:TCS) Shares Sold by Kanen Wealth Management LLC</p></div></a>			
			</nav><!-- end previous and next article links -->
			
		
		<div id="latest-news">
				
				<h2>You might be interested in:</h2>
			 				 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/equinix-inc-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Penserra Capital Management LLC Grows Holdings in Equinix, Inc. " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2022/06/11/penserra-capital-management-llc-grows-holdings-in-equinix-inc-nasdaqeqix.html" rel="bookmark">Penserra Capital Management LLC Grows Holdings in Equinix, Inc. </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/nyse-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="The Container Store Group, Inc.  Shares Sold by Kanen Wealth Management LLC" />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2022/06/11/the-container-store-group-inc-nysetcs-shares-sold-by-kanen-wealth-management-llc.html" rel="bookmark">The Container Store Group, Inc.  Shares Sold by Kanen Wealth Management LLC</a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/camping-world-holdings-inc-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Kanen Wealth Management LLC Raises Stock Holdings in Camping World Holdings, Inc. " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2022/06/11/kanen-wealth-management-llc-raises-stock-holdings-in-camping-world-holdings-inc-nysecwh.html" rel="bookmark">Kanen Wealth Management LLC Raises Stock Holdings in Camping World Holdings, Inc. </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/blackrock-inc-logo.gif&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="KC Investment Advisors LLC Purchases New Shares in BlackRock, Inc. " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2022/06/11/kc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html" rel="bookmark">KC Investment Advisors LLC Purchases New Shares in BlackRock, Inc. </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/tripcom-group-limited-logo.png&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Penserra Capital Management LLC Decreases Stock Position in Trip.com Group Limited " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2022/06/11/penserra-capital-management-llc-decreases-stock-position-in-trip-com-group-limited-nasdaqtcom.html" rel="bookmark">Penserra Capital Management LLC Decreases Stock Position in Trip.com Group Limited </a>
				</div>
	 							 <div class="latest-news-item">
												<div class="item-image-bar"><div class="item-image-wrapper"><img src="https://www.americanbankingnews.com/wp-content/timthumb/timthumb.php?src=https://www.marketbeat.com/logos/qorvo-inc-logo.jpg&amp;h=45&amp;w=95&amp;zc=2" width="65" height="31" alt="Penserra Capital Management LLC Decreases Stock Holdings in Qorvo, Inc. " />
						</div></div>
				 <!--end: longthumb-->
						<a href="https://www.com-unik.info/2022/06/11/penserra-capital-management-llc-decreases-stock-holdings-in-qorvo-inc-nasdaqqrvo.html" rel="bookmark">Penserra Capital Management LLC Decreases Stock Holdings in Qorvo, Inc. </a>
				</div>
	 						</div><!-- end latest news -->

<!-- second ad spot -->

<br>
	</main> <!-- end main -->
<aside class="flex-sidebar">
<div class="flex-container">	
<div class="sidebar-section">
	
<iframe src="https://marketbeat.com/scripts/MoreOnMarketBeat.aspx" width="336" height="600" frameborder="no" title="More Articles"></iframe><br><br>
	
<!-- Network Wide AdSense Unit - Top Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="1875628183" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
<br><br>
<!-- end first square unit -->

<!-- Network Wide AdSense Unit - Middle Sidebar Position -->
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9373162611283935" data-ad-slot="9445683366" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
<!-- End AdSense Unit -->
<br><br>	
<!-- end second square unit -->
		
</div>	
<div class="sidebar-section">
<!-- OptIn Form -->

<!-- Start Sidebar Registration -->
<div class="sidebar-email">
                        <h3>Daily Ratings &amp; News for BlackRock</h3>
        	Complete the form below to receive the latest headlines and analysts' recommendations for BlackRock with our free daily email newsletter:<br/>
        <form method="get" action="https://www.marketbeat.com/newsletter/default.aspx">
        <input id="RegisterEmailSidebar" style='width:100%' name="RegisterEmail" type="email" placeholder="Your Email Address" aria-label="Your Email Address">
        <input type="hidden" id="Hidden7" name="RegistrationCode" value="Community Financial News-Sidebar">
        <input type="hidden" id="Hidden8" name="RegisterTicker" value="NYSE:BLK" />        <input type="submit" name="submit" onclick="return CheckEmail('RegisterEmailSidebar', 'ShowSuggestionSidebar');" value="Subscribe Now (Free Sign-Up)" class="button" style="width:100%;height:30px">
    <div id="ShowSuggestionSidebar" style="padding-top:7px"></div>
    </form>
    </div>

<!-- End Sidebar Registration -->
	
<!-- optional social media -->
	
 
		<br>
	
	<a style="background: #075A8D;color: #fff;padding: 5px 7px 4px;border-radius: 3px;font-size: 12px;text-decoration: none;" href="https://twitter.com/intent/follow?original_referer=https%3A%2F%2Fwww.com-unik.info%2F&ref_src=twsrc%5Etfw&screen_name=CFinancialNews" target="_blank" rel="noopener nofollow">
<svg style="width: 13px;vertical-align: middle;margin-right: 4px;fill: #fff;" xmlns="http://www.w3.org/2000/svg" width="24" height="24" viewBox="0 0 24 24"><path d="M24 4.557c-.883.392-1.832.656-2.828.775 1.017-.609 1.798-1.574 2.165-2.724-.951.564-2.005.974-3.127 1.195-.897-.957-2.178-1.555-3.594-1.555-3.179 0-5.515 2.966-4.797 6.045-4.091-.205-7.719-2.165-10.148-5.144-1.29 2.213-.669 5.108 1.523 6.574-.806-.026-1.566-.247-2.229-.616-.054 2.281 1.581 4.415 3.949 4.89-.693.188-1.452.232-2.224.084.626 1.956 2.444 3.379 4.6 3.419-2.07 1.623-4.678 2.348-7.29 2.04 2.179 1.397 4.768 2.212 7.548 2.212 9.142 0 14.307-7.721 13.995-14.646.962-.695 1.797-1.562 2.457-2.549z"/></svg> Follow @CFinancialNews</a>
		
	
<!-- end optional social media -->

<!-- sidebar unit position -->


<!-- start Recent Posts -->
        <br/>
        <div>
        <h3>Recent News</h3>
            <ul>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/penserra-capital-management-llc-grows-holdings-in-equinix-inc-nasdaqeqix.html">Penserra Capital Management LLC Grows Holdings in Equinix, Inc. (NASDAQ:EQIX)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/the-container-store-group-inc-nysetcs-shares-sold-by-kanen-wealth-management-llc.html">The Container Store Group, Inc. (NYSE:TCS) Shares Sold by Kanen Wealth Management LLC</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/kanen-wealth-management-llc-raises-stock-holdings-in-camping-world-holdings-inc-nysecwh.html">Kanen Wealth Management LLC Raises Stock Holdings in Camping World Holdings, Inc. (NYSE:CWH)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/kc-investment-advisors-llc-purchases-new-shares-in-blackrock-inc-nyseblk.html">KC Investment Advisors LLC Purchases New Shares in BlackRock, Inc. (NYSE:BLK)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/penserra-capital-management-llc-decreases-stock-position-in-trip-com-group-limited-nasdaqtcom.html">Penserra Capital Management LLC Decreases Stock Position in Trip.com Group Limited (NASDAQ:TCOM)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/penserra-capital-management-llc-decreases-stock-holdings-in-qorvo-inc-nasdaqqrvo.html">Penserra Capital Management LLC Decreases Stock Holdings in Qorvo, Inc. (NASDAQ:QRVO)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/dell-technologies-inc-nysedell-shares-acquired-by-penserra-capital-management-llc.html">Dell Technologies Inc. (NYSE:DELL) Shares Acquired by Penserra Capital Management LLC</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/penserra-capital-management-llc-has-16-95-million-stock-holdings-in-intel-co-nasdaqintc.html">Penserra Capital Management LLC Has $16.95 Million Stock Holdings in Intel Co. (NASDAQ:INTC)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/math-price-reaches-0-15-on-major-exchanges-math.html">MATH Price Reaches $0.15 on Major Exchanges (MATH)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/lendefi-new-ldfi-reaches-market-cap-of-1-94-million.html">Lendefi (new) (LDFI) Reaches Market Cap of $1.94 Million</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/plus-coin-price-tops-0-0000-nplc.html">Plus-Coin Price Tops $0.0000  (NPLC)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/0x-zrx-one-day-volume-tops-27-76-million.html">0x (ZRX) One Day Volume Tops $27.76 Million</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/dforce-market-capitalization-achieves-16-13-million-df.html">dForce Market Capitalization Achieves $16.13 Million (DF)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/temco-temco-tops-24-hour-volume-of-38167-00.html">TEMCO (TEMCO) Tops 24 Hour Volume of $38,167.00</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/melalie-mel-hits-24-hour-volume-of-27734-00.html">Melalie (MEL) Hits 24-Hour Volume of $27,734.00</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/hm-payson-co-has-2-10-million-stock-holdings-in-oshkosh-co-nyseosk.html">HM Payson &#038; Co. Has $2.10 Million Stock Holdings in Oshkosh Co. (NYSE:OSK)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/hm-payson-co-acquires-490-shares-of-ishares-sp-smallcap-600-etf-nysearcaijr.html">HM Payson &#038; Co. Acquires 490 Shares of iShares S&#038;P SmallCap 600 ETF (NYSEARCA:IJR)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/hm-payson-co-grows-holdings-in-albemarle-co-nysealb.html">HM Payson &#038; Co. Grows Holdings in Albemarle Co. (NYSE:ALB)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/west-family-investments-inc-reduces-stock-holdings-in-paychex-inc-nasdaqpayx.html">West Family Investments Inc. Reduces Stock Holdings in Paychex, Inc. (NASDAQ:PAYX)</a></li>
                        <li class="recent-posts"><a href="https://www.com-unik.info/2022/06/11/west-family-investments-inc-sells-186-shares-of-t-mobile-us-inc-nasdaqtmus.html">West Family Investments Inc. Sells 186 Shares of T-Mobile US, Inc. (NASDAQ:TMUS)</a></li>
                        </ul>
        </div>  
</div>
</div>
<!-- end recent posts -->
</aside><!--end #sidebar-->
	<div style="clear: both;"></div>
</div> <!-- end .width-limiter -->
<footer class="full-width">
	<div class="width-limiter flex-container">
		<div id="footer-info" class="add-padding flex-nav">
			<nav class="navigation" aria-label="Category Links"><ul id="menu-front-page-categories-2" class="menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-110"><a href="https://www.com-unik.info/finance">Finance</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-108"><a href="https://www.com-unik.info/news">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-114"><a href="https://www.com-unik.info/world">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-113"><a href="https://www.com-unik.info/u-s">U.S.</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-111"><a href="https://www.com-unik.info/sports">Sports</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112"><a href="https://www.com-unik.info/technology">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107"><a href="https://www.com-unik.info/education">Education</a></li>
</ul></nav>		</div><!-- end #footer-info -->
		<span id="copyright" class="add-padding flex-copyright">
				&copy; 2018-2022 <a href="https://www.com-unik.info">Community Financial News</a>
	    </span>
	</div>	
	<!-- Begin Internal Tracking Pixel 2 -->
		<script type='text/javascript'>document.write('<img src="https://www.american' + 'consumernews.net/scripts/standalone/viewcount.ashx?ArticleHistoryID=90723982&PostDate=2022-6-11&type=f&id=11952128&domain=www.com-unik.info&referrer=' + encodeURIComponent(document.referrer) + '" alt="" width="1" height="1" style="float:left;" />');</script>
		<!-- End Internal Tracking Pixel 2-->
</footer>
		<script type='text/javascript' src='https://www.com-unik.info/wp-content/plugins/bwp-minify/min/?f=wp-includes/js/wp-embed.min.js&#038;ver=1621979507'></script>
</div>
<!-- MarketBeat News Network StatCounter Code -->
<script type="text/javascript">var sc_project=9021069; var sc_invisible=1; var sc_security="fdde5482"; var sc_https=1; </script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/9021069/0/fdde5482/1/" height="1" width="1" alt=""></noscript>
<!-- End MarketBeat News Network StatCounter Code -->

<!-- Start of Site Specific StatCounter Code -->
<script type="text/javascript">
var sc_project=10928871; 
var sc_invisible=1; 
var sc_security="cc698371"; 
</script>
<script type="text/javascript" src="https://www.statcounter.com/counter/counter.js"></script>
<noscript><img class="statcounter" src="https://c.statcounter.com/10928871/0/cc698371/1/" height="1" width="1"  alt=""></noscript>
<!-- End of Site Specific StatCounter Code -->

	</body>
</html>
